Subject: Re: [Adslmib] (no subject)

From: [email-masked]
Date: Tue, 24 Sep 2002 13:03:37 +0300

Bob,

Thanks for explaining what you did with the
vdslLineSCMConfProfileTxBandEntry, but my question referred to
vdslLineSCMConfProfileTable.

Did you add an index there too?

Best regards,
Moti

                      "Bob Ray"                                                                                                        
                      <bob.ray@                To:      [email-masked], "Bob Ray" <[email-masked]>,              
                      knology.net>             [email-masked], [email-masked]                                                
                                               cc:                                                                                     
                      24/09/02 12:54           Subject: Re: [Adslmib] (no subject)                                                     

> Hi Bob,
>
> In 3j, did you add "side" as part of the index for the
> vdslLineSCMConfProfileTable or do you have downstream
> objects and upstream objects in the same entry?
>
> Best regards,
> Moti
>

I added it as part of the index to vdslLineSCMConfProfileTxBandEntry.
To accomplish this, I had to add an object to the TxBandEntry
denoting the physical side (vtu-r or vtu-c).  This is because
vdslPhysSide and vdslLineConfProfileIndex reside in distinct tables,
and for indices one can only use objects from the entry being
defined or one other table.

I believe this is per the recent email exchange between you
and Travis/Paradyne.  A more orthogonal approach would be to
have separate tx and rx band tables as with MCM, but I believe
this accomplishes the same result.  That is,

    -- combined with side as partial index

    prof = 1
    side = 1
    band = 0
    while (prof = 1) and (side = 1)
         band = entry.getNext(prof, side, band)
    while (prof = 1) and (side = 2)
         band = entry.getNext(prof, side, band)

    -- separate tables

    prof = 1
    band = 0
    while (prof = 1) and (eot(rxentry) = false)
          band = rxentry.getNext(prof,band)
    prof = 1
    band = 0
    while (prof = 1) and (eot(txentry) = false)
          band = txentry.getNext(prof,band)

Personally, I don't see much difference, although purists would
argue one way or the other.  For example, having separate tables
reduces network traffic (smaller objects on the wire).  Having
separate tables potentially increases agent complexity (on the
sophomoric notion that more objects implies a larger agent).

Bob

_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: Bob Ray <[email-masked]>
Date: Tue, 24 Sep 2002 05:49:56 -0500

> Did you add an index there too?

No.  Looks like I should have, though.  When they get the draft posted,
please review it carefully, as I would like to wrap it up before Atlanta.
Perhaps I'm being optimistic, but maybe we can finish the thing with 
one more round.

Thanks,
Bob Ray