Subject: [Adslmib] RE: WG Last Call: draft-ietf-adslmib-vdsl-09.txt

From: Flemisch Felix <[email-masked]>
Date: Fri, 30 May 2003 14:06:18 +0200

Hi all,

I sent the mentioned Word document to Mike, Bob, and Rajesh.  I will not send it to the Adslmib mailing list (which accepts only plain text attachments) but see the summary of my comments below.

Best Regards,

Felix Flemisch
Siemens AG

-----Original Message-----
From: Flemisch Felix 
Sent: Friday, May 30, 2003 1:58 PM
To: [email-masked]'; [email-masked]'; [email-masked]'
Subject: RE: WG Last Call: draft-ietf-adslmib-vdsl-09.txt

Mike, Bob, and Rajesh,

please find attached a Word version of draft-ietf-adslmib-vdsl-09 with continuous line numbering where I have added my comments using change tracking.

In the following I summarize the proposed changes.

Mechanical and editorial changes were made to the following lines:

1-4, 128, 133, 146, 165, 183/184, 204, 255/256, 260-263, 269, 313, 348/349, 378-380, 384-387, 389, 391, 396, 400, 420, 427, 431/432, 454, 459/460, 477/478, 482, 487, 494-496, 505-510, 521/522, 607, 609, 614, 637, 644, 653, 663, 669/670, 678, 683, 696, 700, 715, 719, 721, 722ff, 723, 815, 819, 839, 849/850, 948, 960, 1007/1008, 1134, 1620, 1760/1761, 2078, 2141/2142, 2203, 2205, 2253/2254, 2276, 2278, 2322, 2333, 2689-2691, 2986, 3215, 3228, 3246, 3487, 3534, 3576, 3594, 3600, 3602, 3605, 3621, 3701, 3709.

Clarifications were made to, or between, the following lines:

142ff, 259f, 663ff, 673f, 2445ff, 2455ff, 2490ff, 2500ff, 2732ff, 2744ff, 2760ff, 2762/2763, 2775ff, 2792f, 2797, 2801, 2806, 2810, 2815, 2819, 2824, 2833. 

Changes according to my email of 13th March (Adslmib digest #77) were made to, or between, the following lines:

805-808f, 830, 2252, 2704, 2719-2720f.

Substantial changes were made between the following lines:

548f, 678ff, 711ff, 2267f, 2879ff, 2900, 3424f, 3556ff.

Please use the Word file itself and not this line number account for reviewing and discussing my comments.

Best Regards,

Felix Flemisch
Siemens AG

-----Original Message-----
From: Flemisch Felix 
Sent: Friday, May 30, 2003 12:12 PM
To: [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]';
[email-masked]'; [email-masked]';
[email-masked]'; [email-masked]';
[email-masked]'; [email-masked]'; Kopetzky Walter; Muhn Harald
Subject: WG Last Call: draft-ietf-adslmib-vdsl-09.txt

Hi all,

on 16th May I requested additional time to review draft-ietf-adslmib-vdsl-09 personally and to collect comments by Siemens.  This is completed now, and I will send out the details with the next email.  As a matter of fact, to ease the consideration of integration of the comments [mechanical, editorial, clarifying, substantial] into the RFC (or, maybe only into draft-ietf-adslmib-vdsl-10) I have prepared a detailed WORD update of draft-ietf-adslmib-vdsl-09.txt with change tracking.

This email provides a high-level summary of our position and proposals how to proceed.  The result is that I vote YES WITH COMMENTS but request willingness for utmost acceleration of line-code specific (LCS) VDSL management framework and MIB standardization in both DSLF and IETF to avoid a longer period where urgently needed LCS parameters have to be specified on a proprietary base.  The LCS MIB(s), for SCM and MCM, MUST then be used together with the core VDSL-LINE-MIB.

VDSL MIB standardization seems to be in a sort of unhappy state at the moment but I'm much confident that this can be improved considerably on the short term.  The standardization work on VDSL line management is ongoing for quite some time now in both DSLF and IETF, and a couple of months ago it seemed to turn out to be a never-ending story.  A major reason for this paralysis is, of course, the religious battle for the true line code:  SCM/QAM/Coalition or MCM/DMT/Alliance, that's the question.

But then the DSLF found the philosophers' stone, and split off all LCS issues in order to be able to specify a core protocol-independent management framework for VDSL lines.  This pioneering task resulted in the publication of TR-057 in February 2003.

Though it was realized in the meantime that TR-057 has some flaws (which are already addressed by DSLF's OpNM WG with a new WT for an addendum to TR-057 that will be fast tracked through straw ballot), IETF's ADSLMIB WG agreed to adopt DSLF's strategy and created a VDSL MIB that consists of a core set of essential parameters for managing VDSL lines in a line-code independent manner and is fully aligned with TR-057, and even includes first flaw resolutions (configuration of slow burst protection and fast FEC overhead).  This equally pioneering work should not be held up unnecessarily.

It turned out, however, that the agreed core set covers completely the PMS-TC sublayer but not completely enough the PMD sublayer.  As a consequence no agreement was reached, not even within the SCM fraction, that basic (whatever this means) configuration of VDSL lines will be possible using the core VDSL MIB of draft-ietf-adslmib-vdsl-09 without additional LCS parameters.  Therefore the development of an LCS-specific framework for both SCM and MCM by the DSLF and the development of one (or two) corresponding LCS VDSL MIB(s) are a MUST since otherwise vendor-specific MIBs need to be implemented at the disadvantage of customers (who regularly require multi-vendor capability).  Also, the important, line-code independent question of how to configure the read-only channelization mode "vdslLineType" at start-up could not be settled.

For the latter I'm proposing a new read-create parameter "vdslLineConfLineType" while for the LCS defects I'm proposing to add a note to the description of the VDSL-LINE-MIB module stating that a standardized LCS VDSL Line Extension MIB (VDSL-LINE-EXT-MIB) module is seen as a MANDATORY supplement to VDSL-LINE-MIB.  All other comments are clarifications or based on my earlier comments of 13th March.

For details see my next email.

Best Regards,

Felix Flemisch
Siemens AG
_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 30 May 2003 08:49:19 -0700

Hi -

> From: "Flemisch Felix" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]'>; "Kopetzky Walter" <[email-masked]>; "Muhn Harald"
<[email-masked]>
> Sent: Friday, May 30, 2003 5:06 AM

>
> Hi all,
>
> I sent the mentioned Word document to Mike, Bob, and Rajesh.  I will not send it to the Adslmib mailing list (which accepts only
plain text attachments) but see the summary of my comments below.
...

I object.  Particularly at this late stage in the process (WG last call!),
I believe it is important that any changes that are not purely editorial
or mechanical should be posted to the WG mailing list, in plain text.

Randy