Subject: [alto] New draft on use cases for ALTO & CDNs

From: Ben Niven-Jenkins <[email-masked]>
Date: Wed, 27 Apr 2011 16:45:15 +0100

Colleagues,

During the ALTO meeting at IETF80 I made some comments at the microphone highlighting my concerns with the scope of draft-penno-alto-cdn-03 being far too wide and that we should first focus on documenting the use cases and requirements.

To that end I've been working with a couple of folks to co-author a draft focussed on documenting the use cases for ALTO & CDNs, the thinking being that a fresh draft with a tighter focus than draft-penno-alto-cdn-03 makes highlighting and discussing the use cases without slipping into possible solution mechanisms much simpler and cleaner.

We have just published a -00 version which is available here:
http://tools.ietf.org/html/draft-jenkins-alto-cdn-use-cases-00
 
So far we have only included details on two use cases and included placeholders for another two because we wanted to socialise the work early to see if others were interested in contributing text for the use cases they have as well as to solicit early feedback on the structure and focus of the draft.

Comments/Suggestions/etc on the draft are welcomed.

Ben

---

From: stefano previdi <[email-masked]>
Date: Thu, 28 Apr 2011 11:58:45 +0200

Ben,

On Apr 27, 2011, at 5:45 PM, Ben Niven-Jenkins wrote:
> Colleagues,
>
> During the ALTO meeting at IETF80 I made some comments at the  
> microphone highlighting my concerns with the scope of draft-penno- 
> alto-cdn-03 being far too wide and that we should first focus on  
> documenting the use cases and requirements.
>
> To that end I've been working with a couple of folks to co-author a  
> draft focussed on documenting the use cases for ALTO & CDNs, the  
> thinking being that a fresh draft with a tighter focus than draft- 
> penno-alto-cdn-03 makes highlighting and discussing the use cases  
> without slipping into possible solution mechanisms much simpler and  
> cleaner.

makes sense.

> So far we have only included details on two use cases and included  
> placeholders for another two because we wanted to socialise the work  
> early to see if others were interested in contributing text for the  
> use cases they have as well as to solicit early feedback on the  
> structure and focus of the draft.

splitting the current alto-cdn document makes sense to me and we
need to define:
a. use cases
b. requirements
c. proposed solutions

your draft addresses the use cases and you may want to merge the
use cases sections we currently have in the alto-cdn draft so to
focus that one only on the proposed solution(s).

The question is about requirements: do we want to include them
in one of the two drafts or into a separate document ?

s.

> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto

---

From: Jan Medved <[email-masked]>
Date: Thu, 28 Apr 2011 08:30:30 -0700

>splitting the current alto-cdn document makes sense to me and we

This seems to be most logical split.

>focus that one only on the proposed solution(s).

The first two uses cases in draft-jenkins-cdn-use-cases are described in
draft-penno-alto-cdn. Agreed that the text from draft-penno-alto-cdn
should be merged into the appropriate sections of
draft-jenkins-cdn-use-cases.

>in one of the two drafts or into a separate document ?

/Jan

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Thu, 28 Apr 2011 19:27:55 +0100

Jan, Stefano, Colleagues,

> This seems to be most logical split.

Agreed.

> draft-jenkins-cdn-use-cases.

I'm OK with that. When I read draft-penno-alto-cdn I found it hard to extract text that is pure use case though but if you could provide text or pointers to sections I'm happy to start discussing how we could merge the use case text in draft-penno-alto-cdn with that in draft-jenkins-alto-cdn-use-cases.

>> in one of the two drafts or into a separate document ?

My opinion is that the requirements should be documented separately to the solutions. I don't currently have a strong opinion about whether they should be documented in draft-jenkins-alto-cdn-use-cases or a separate draft. 

Ben

---

From: stefano previdi <[email-masked]>
Date: Thu, 28 Apr 2011 20:43:49 +0200

Ben, Jan, Nabil, Grant, Richard, Richard, Reinaldo,

thinking more about it, I believe the requirements will have to be put
into a separate draft, for clarity.

I agree with Jan about the duplication of text between alto-cdn and your
draft so we should merge. Therefore, I'd propose the following plan:

Co-authors of alto-cdn and jenkins draft meet and propose a unified
use cases description draft. At this stage most of the work will be just
editorial (cut/paste) as we clearly agree on the content (i.e.: use case
description).

It would be good to come reasonably soon with a proposal to the WG.

How does it sound ?

s.

On Apr 28, 2011, at 8:27 PM, Ben Niven-Jenkins wrote:

> I'm OK with that. When I read draft-penno-alto-cdn I found it hard  
> to extract text that is pure use case though but if you could  
> provide text or pointers to sections I'm happy to start discussing  
> how we could merge the use case text in draft-penno-alto-cdn with  
> that in draft-jenkins-alto-cdn-use-cases.
>
> My opinion is that the requirements should be documented separately  
> to the solutions. I don't currently have a strong opinion about  
> whether they should be documented in draft-jenkins-alto-cdn-use- 
> cases or a separate draft.
>
> Ben
>

---

From: Richard Alimi <[email-masked]>
Date: Sat, 30 Apr 2011 08:30:13 -0700

> It would be good to come reasonably soon with a proposal to the WG.

This sounds great to me.

Rich

>> I'm OK with that. When I read draft-penno-alto-cdn I found it hard to
>> extract text that is pure use case though but if you could provide text or
>> pointers to sections I'm happy to start discussing how we could merge the
>> use case text in draft-penno-alto-cdn with that in
>> draft-jenkins-alto-cdn-use-cases.
>>
>> My opinion is that the requirements should be documented separately to the
>> solutions. I don't currently have a strong opinion about whether they should
>> be documented in draft-jenkins-alto-cdn-use-cases or a separate draft.
>>
>> Ben
>>
>
>