Subject: Re: [alto] New draft on use cases for ALTO & CDNs

From: "Bitar, Nabil N" <[email-masked]>
Date: Tue, 3 May 2011 03:17:10 -0400

Hi,
Consolidating the use cases in one document is a good suggestion and it is naturally needed.
However, I feel having the requirements in the same document as the use cases provides better context to the requirements in one document.
If the consensus is to separate the two, it is fine too. I has been done both ways.

Thanks,
Nabil

On 4/30/11 11:30 AM, "Richard Alimi" <[email-masked]> wrote:

On Thu, Apr 28, 2011 at 11:43 AM, stefano previdi <[email-masked]> wrote:
> Ben, Jan, Nabil, Grant, Richard, Richard, Reinaldo,
>
> thinking more about it, I believe the requirements will have to be put
> into a separate draft, for clarity.
>
> I agree with Jan about the duplication of text between alto-cdn and your
> draft so we should merge. Therefore, I'd propose the following plan:
>
> Co-authors of alto-cdn and jenkins draft meet and propose a unified
> use cases description draft. At this stage most of the work will be just
> editorial (cut/paste) as we clearly agree on the content (i.e.: use case
> description).
>
> It would be good to come reasonably soon with a proposal to the WG.
>
> How does it sound ?

This sounds great to me.

Rich

>
> s.
>
>
> On Apr 28, 2011, at 8:27 PM, Ben Niven-Jenkins wrote:
>
>> Jan, Stefano, Colleagues,
>>
>> On 28 Apr 2011, at 16:30, Jan Medved wrote:
>>>
>>> On 4/28/11 2:58 AM, "stefano previdi" <[email-masked]> wrote:
>>>>
>>>> splitting the current alto-cdn document makes sense to me and we
>>>> need to define:
>>>> a. use cases
>>>> b. requirements
>>>> c. proposed solutions
>>>
>>> This seems to be most logical split.
>>>
>>
>> Agreed.
>>
>>>>
>>>> your draft addresses the use cases and you may want to merge the
>>>> use cases sections we currently have in the alto-cdn draft so to
>>>> focus that one only on the proposed solution(s).
>>>
>>> The first two uses cases in draft-jenkins-cdn-use-cases are described in
>>> draft-penno-alto-cdn. Agreed that the text from draft-penno-alto-cdn
>>> should be merged into the appropriate sections of
>>> draft-jenkins-cdn-use-cases.
>>
>> I'm OK with that. When I read draft-penno-alto-cdn I found it hard to
>> extract text that is pure use case though but if you could provide text or
>> pointers to sections I'm happy to start discussing how we could merge the
>> use case text in draft-penno-alto-cdn with that in
>> draft-jenkins-alto-cdn-use-cases.
>>
>>>> The question is about requirements: do we want to include them
>>>> in one of the two drafts or into a separate document ?
>>
>> My opinion is that the requirements should be documented separately to the
>> solutions. I don't currently have a strong opinion about whether they should
>> be documented in draft-jenkins-alto-cdn-use-cases or a separate draft.
>>
>> Ben
>>
>
>

---------------------------------------------
Nabil Bitar, PhD
Principal Member of Technical Staff
Packet Network Technology
Verizon Corporate Network and Technology

60 Sylvan Road
Waltham, MA 02451
Office Phone: (781) 466-2161

---

From: <[email-masked]>
Date: Tue, 3 May 2011 09:02:20 +0100

ditto

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Richard Alimi
Sent: 30 April 2011 16:30
To: stefano previdi
Cc: Jan Medved; Ben Niven-Jenkins; Watson,G,Grant,DMK5 R; Nabil N Bitar; [email-masked]; YR Yang; Reinaldo Penno
Subject: Re: [alto] New draft on use cases for ALTO & CDNs

This sounds great to me.

Rich