Subject: Re: [alto] Problem with endpoint property response in draft 11

From: Richard Alimi <[email-masked]>
Date: Sun, 1 Jul 2012 21:50:54 -0700

On Wed, Jun 6, 2012 at 10:01 AM, Bill Roome <[email-masked]> wrote:
> {7.7.3.1.5} -- Endpoint Property Response -- says
>
> The ALTO Server MAY include the Version Tag (Section 5.3) of the
> Network Map used to generate the response (if desired and applicable)
> as the 'map-vtag' member in the response. If the 'pid' property is
> returned for any endpoints in the response, the 'map-vtag' member is
> REQUIRED instead of OPTIONAL.
>
>
> However the example in {7.7.3.1.6} doesn't follow that rule. It's
>
>   {
>     "meta" : {},
>     "data": {
>       "ipv4:192.0.2.34"    : { "pid": "PID1" },
>       "ipv4:203.0.113.129" : { "pid": "PID3" }
>     }
>   }
>
>
> where it should be
>
>   {
>     "meta" : {},
>     "data": {
>       "map-vtag" : "1266506139",
>       "ipv4:192.0.2.34"    : { "pid": "PID1" },
>       "ipv4:203.0.113.129" : { "pid": "PID3" }
>     }
>   }
>
>
> But that has an unfortunate complication. Before, all the keys in the "data"
> object were endpoints.
> But now, a key is an endpoint address UNLESS it's "map-vtag". Granted,
> that's not ambiguous, because
> "map-vtag" can't possibly be an endpoint address.
>
> But still it's annoying. Compare that with the a filtered network-map
> response:
>
>    {
>      "meta" : {},
>      "data" : {
>        "map-vtag" : "1266506139",
>        "map" : {
>          "PID1" : {
>            "ipv4" : [ "192.0.2.0/24", "198.51.100.0/24" ]
>          },
>          "PID2" : {
>            "ipv4": [ "198.51.100.128/24" ]
>          }
>        }
>      }
>    }
>
> There the PID name keys are all in a "map" object. So for consistency,
> the properties in an endpoint prop response should also be under a "map":
>
>   {
>
>     "meta" : {},
>     "data": {
>       "map-vtag" : "1266506139",
>       "map" : {
>          "ipv4:192.0.2.34"    : { "pid": "PID1" },
>          "ipv4:203.0.113.129" : { "pid": "PID3" }
>       }
>     }
>   }
>
>
> Comments?

Thanks for catching this.  I completely agree with the suggested
approach of putting all of of the properties within a 'map' object.
That seems to be a much cleaner approach.

Thanks,
Rich

>
> - Bill Roome
>
>
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>

---

From: "Y. Richard Yang" <[email-masked]>
Date: Mon, 2 Jul 2012 13:26:52 +0800

On Monday, July 2, 2012, Richard Alimi wrote:

> On Wed, Jun 6, 2012 at 10:01 AM, Bill Roome <[email-masked]<javascript:;>>
> wrote:
> I like this revision too. Here the "map" really means the specific
"mapping" from
 key(s) to value(s). It is consistent.

- yry

> > [email-masked] <javascript:;>
> [email-masked] <javascript:;>