Subject: Re: [alto] Constraints results in E_SYNTAX

From: Bill Roome <[email-masked]>
Date: Wed, 07 Nov 2012 16:19:24 -0500

>Message: 4
>Date: Wed, 7 Nov 2012 11:39:03 -0800
>From: Richard Alimi <[email-masked]>
>..........
>
>The ALTO protocol used to have a reason that was free-form text.  Ted
>Hardie suggested in his review that we drop this to avoid multi-language
>issues (as Richard Yang pointed out).  We then removed the reason field.

I wondered why the reason field was removed! However, that begs the
question of whether a generic "Something's Wrong!" error code is better
than a detailed description in a language that the ALTO user might not
understand.

I suggest restoring the "reason" string. If nothing else, a client
implementer can send it to the ALTO service provider and ask them to
translate it.

	- Bill Roome

---

From: Richard Alimi <[email-masked]>
Date: Wed, 7 Nov 2012 14:55:27 -0800

> implementer can send it to the ALTO service provider and ask them to

I'll leave this up to the WG.  I'd prefer to not go back and forth with
this.  I personally have no strong feelings one way or the other.

Rich

>
>         - Bill Roome
>
>
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>