Subject: [alto] draft-ietf-alto-deployments-13

From: "SCHARF, Michael (Michael)" <[email-masked]>
Date: Wed, 20 Jan 2016 08:21:53 +0000

Hi all,

Based on a suggestion of the chairs I have looked into how to include parts of draft-seidel-alto-map-calculation in draft-ietf-alto-deployments.

In general, draft-seidel-alto-map-calculation contains a useful and comprehensive deployment example as well as some lessons learnt. As far as I can tell, the example described in draft-seidel-alto-map-calculation seems realistic, and the resulting recommendations for ALTO deployments could be backed by other solutions to calculate ALTO maps. Thus, I think it would be useful to add significant parts of draft-seidel-alto-map-calculation to draft-ietf-alto-deployments, even if that document has already passed WGLC.

The new version  draft-ietf-alto-deployments-13 has three main changes:

* There is a new Section 3.6. "Comprehensive Example for Map Calculation" taken from draft-seidel-alto-map-calculation with only minor editorial modifications

* Section 3.2 has been updated in various paragraphs with additional material from draft-seidel-alto-map-calculation, as far as applicable

* Hans Seidel has been added as co-author

Please have a look at the new version -13 and let us know any feedback on the changes.

I would like to ask the chairs to run a new WGLC in order to finally move this document forward.

Thanks

Michael

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of EXT [email-masked]
Sent: Wednesday, January 20, 2016 9:00 AM
To: [email-masked]
Cc: [email-masked]
Subject: I-D Action: draft-ietf-alto-deployments-13.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Application-Layer Traffic Optimization Working Group of the IETF.

        Title           : ALTO Deployment Considerations
        Authors         : Martin Stiemerling
                          Sebastian Kiesel
                          Michael Scharf
                          Hans Seidel
                          Stefano Previdi
	Filename        : draft-ietf-alto-deployments-13.txt
	Pages           : 75
	Date            : 2016-01-19

Abstract:
   Many Internet applications are used to access resources such as
   pieces of information or server processes that are available in
   several equivalent replicas on different hosts.  This includes, but
   is not limited to, peer-to-peer file sharing applications.  The goal
   of Application-Layer Traffic Optimization (ALTO) is to provide
   guidance to applications that have to select one or several hosts
   from a set of candidates, which are able to provide a desired
   resource.  This memo discusses deployment related issues of ALTO.  It
   addresses different use cases of ALTO such as peer-to-peer file
   sharing and CDNs and presents corresponding examples.  The document
   also includes recommendations for network administrators and
   application designers planning to deploy ALTO, such recommendations
   how to generate ALTO map information.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-alto-deployments/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-alto-deployments-13

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-alto-deployments-13

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 20 Jan 2016 10:19:18 -0600

> Hi all,
>
> Based on a suggestion of the chairs I have looked into how to include
> parts of draft-seidel-alto-map-calculation in
> draft-ietf-alto-deployments. [...]

Folks: Happy new year to all of you.

Version -13 is a culmination of the effort to merge 
draft-ietf-alto-deployments and the individual effort of 
draft-seidel-alto-map-calculation as we have discussed in the past.

Given the changes in the merged draft, Jan and I will issue a new WGLC.
We will follow this up in a separate email, in the meantime, please
consider spending some cycles to go through -13.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Nokia
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq