Subject: [alto] New ALTO I-D: draft-bertz-alto-sdnnfvalto

From: Lyle Bertz <[email-masked]>
Date: Wed, 6 Jul 2016 12:14:58 -0500

All,

I have submitted a new I-D for consideration.  It describes how SDN and NFV
can be loosely coupled through use of ALTO.  As part of the description an
Orchestration algorithm is proposed and several features are discussed that
impact ALTO and require a new set of technology to initiate, negotiate,
delete and control the rate of measurements.

This work supports self organizing CDN, IP Mobility Core (LTE EPC) and
NFV/SDN features to match the self organizing features mobile carriers have
in the latest generation of their radio networks.

It can be found at
https://datatracker.ietf.org/doc/draft-bertz-alto-sdnnfvalto/

Thanks

Lyle

---

From: wang xin <[email-masked]>
Date: Thu, 7 Jul 2016 19:10:46 +0000

Dear Lyle,

It's a good use case of ALTO in NFV/SDN since both the interface between VIM and NFVI (These two components are the main focus of OPNFV Organization) and Orchestrator are key parts in NFV-O. My first thinking of using ALTO in NFV-O is that it's important to decide which components are ALTO Clients in the architecture. Here can be two roles for ALTO: 1. Used by VIM to get metrics in the network; 2. Used by Resource/Service Orchestrator to set the cost values for VNF FG. Of course, these two roles can be mixed. A key difference between two roles is whether ALTO can be aware of VNF.

For role1, it's quite simple since there is no VNF concept in ALTO. For role2, ALTO server should get VNF data as well as the performance constraints, and also involve an aggregator to provide a consistent interface, which makes the whole design more complicated than the former one. Getting VNF data from NFVO seems like an interesting idea but I am thinking about if this part can be separated out from NFVO since in future there might be multiple orchestrators with a common VNF FG.

It looks interesting to me, and I will still think about that.

Thanks,

Xin

<https://www.opnfv.org/><https://www.opnfv.org/>

<https://www.opnfv.org/>

________________________________
From: alto <[email-masked]> on behalf of Lyle Bertz <[email-masked]>
Sent: Thursday, July 7, 2016 1:14:58 AM
To: IETF ALTO
Subject: [alto] New ALTO I-D: draft-bertz-alto-sdnnfvalto

All,

I have submitted a new I-D for consideration.  It describes how SDN and NFV can be loosely coupled through use of ALTO.  As part of the description an Orchestration algorithm is proposed and several features are discussed that impact ALTO and require a new set of technology to initiate, negotiate, delete and control the rate of measurements.

This work supports self organizing CDN, IP Mobility Core (LTE EPC) and NFV/SDN features to match the self organizing features mobile carriers have in the latest generation of their radio networks.

It can be found at

Thanks

Lyle

---

From: Lyle Bertz <[email-masked]>
Date: Fri, 8 Jul 2016 11:09:08 -0500

All,

I've updated the spec to version 02 to correct an error in Figure 5 as well
as the corresponding text.

Lyle

On Wed, Jul 6, 2016 at 12:14 PM, Lyle Bertz <[email-masked]> wrote:

> All,
>
> I have submitted a new I-D for consideration.  It describes how SDN and
> NFV can be loosely coupled through use of ALTO.  As part of the description
> an Orchestration algorithm is proposed and several features are discussed
> that impact ALTO and require a new set of technology to initiate,
> negotiate, delete and control the rate of measurements.
>

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Wed, 13 Jul 2016 16:51:58 -0300

Dear Lyle et al.,

I am glad to see this draft targeting application scenarios in the
context of NFV/SDN. I believe we may increasingly see new proposals to
ideas to map PIDs to collections of other types of endpoints beyond
host identifiers/locators such as VNFs or NFVI POPs.

I liked very much the idea of exposing performance measurements via ALTO.

We have been making the case for such dynamic "benchmarking" methods
to assist different aspects of the lifecycles of VNFs:

-  R. Rosa, C. Rothenberg, R. Szabo. "VNF Benchmark-as-a-Service".
IRTF NFVRG Internet-Draft draft-rorosz-nfvrg-vbaas. Oct. 2015.
https://www.ietf.org/proceedings/94/slides/slides-94-nfvrg-18.pdf

-  R. Rosa, C. Rothenberg, R. Szabo. "VNF Benchmarking Methodology".
IETF BMWG Internet-Draft draft-rosa-bmwg-vnfbench . Mar. 2016.

In our VBaaS framework, an ALTO-based interface from the Orchestrator
to clients to expose performance/benchmark metrics looks like a nice
fit.

I will get back with further comments on the draft, I just wanted to
share at this point in time my positive feelings about it.

Cheers,
Christian

On Fri, Jul 8, 2016 at 1:09 PM, Lyle Bertz <[email-masked]> wrote:
>> that impact ALTO and require a new set of technology to initiate, negotiate,
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>