Subject: [alto] Draft: Alto for the blockchain

From: Stefan HOMMES <[email-masked]>
Date: Thu, 7 Jul 2016 15:36:57 +0000

Dear ALTO group,

I am a research associate from the University of Luxembourg, and we have submitted a draft that is using ALTO for the blockchain:
https://datatracker.ietf.org/doc/draft-hommes-alto-blockchain/

We are very curious and interested to receive some feedback about this draft. Please feel free to send us your comments. We highly appreciate your opinion and looking forward to the IETF meeting in Berlin.

Kind Regards,
Stefan

-------------------------------------------------------------------------
Dr. Stefan Hommes
Research Associate, SEDAN team, Room C003
Mail: [email-masked]<mailto:[email-masked]>
Phone: (+352) 46 66 44 5834
University of Luxembourg
Interdisciplinary Centre on Security Reliability and Trust (SnT)
4, Rue Alphonse Weicker, L2721 Luxembourg
-------------------------------------------------------------------------

---

From: wang xin <[email-masked]>
Date: Fri, 8 Jul 2016 12:24:34 +0000

Dear Stefan and other authors,

I am not an expert of Bitcoin or any virtual currency, but I do learn a lot from your draft. I realize that network communication also plays an important role in the blockchain architecture besides the computation of mining. It's great that ALTO has a potential to accelerate the development of that.

I am also interested in how ALTO can be used for broadcasting mechanism in blockchain. I can imagine how ALTO works by selecting reply nodes, but I am not sure this is the only location for ALTO. I find that I am not familiar with blockchain networking architecture, and it should be the starting point for the whole integration. Finally I hope ALTO can contribute a lot for the development of blockchain.

Thanks,

Xin

________________________________
From: alto <[email-masked]> on behalf of Stefan HOMMES <[email-masked]>
Sent: Thursday, July 7, 2016 11:36:57 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; Mathis STEICHEN
Subject: [alto] Draft: Alto for the blockchain

Dear ALTO group,

Kind Regards,
Stefan

---

From: Shenshen Chen <[email-masked]>
Date: Mon, 11 Jul 2016 20:52:06 +0800

Dear authors,

I read your draft and get interested in utilizing ALTO for block chain. I
have considered about it over the past few days. Here are some comments:

1. Be more general-purpose for block chain

I noticed that there’re some parts of introduction about bitcoin have been
removed from the first version and believed this draft is not specified for
bitcoin. Also mentioned in title, this draft is about block chain. But it
only mentioned bitcoin as use case of block chain.

In bitcoin wiki, it said “Block chains were invented specifically for the
Bitcoin project but they can be applied anywhere a distributed consensus
needs to be established in the presence of malicious or untrustworthy
actors.”

Despite it may cost too much to implement block chain for non-financial
cases, mentioning some other use cases (e.g. alternative chain) could make
the draft looks more general-purpose for block chain.

2. Consider about security

Compare to traditional data base, I thought the block chain was invented to
solve the security problem.  So, it is necessary to consider about security
which is much more important than efficiency. For example, ALTO server may
accept some suboptimal results to improve the randomness and avoid the
prediction mentioned in section 7.

3. Let applications aware of the different roles

In section 6, it said “This requires that the ALTO server is aware of the
different roles”. But roles like wallet, miner and relay nodes are
specified for bitcoin, it may have different roles in other use cases of
block chain. Including such information in ALTO protocol is not
general-purpose for block chain.

By the other hand, ALTO is invented to provide low-level network
information which application can’t get before. Since the information about
different roles is not low-level, it could be more appropriate for ALTO to
let applications maintain the map relationship between each node and its
role.

Hope these helps. :)

Best Regards,
Shenshen Chen

2016-07-07 23:36 GMT+08:00 Stefan HOMMES <[email-masked]>:

> Dear ALTO group,
>
>
>
> I am a research associate from the University of Luxembourg, and we have
> submitted a draft that is using ALTO for the blockchain:
>
> We are very curious and interested to receive some feedback about this
> draft. Please feel free to send us your comments. We highly appreciate your
> opinion and looking forward to the IETF meeting in Berlin.
>
>
>
> Kind Regards,
>
> Stefan
>
>
>
> Mail: [email-masked]
>
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>
>

---

From: Stefan HOMMES <[email-masked]>
Date: Tue, 12 Jul 2016 08:20:58 +0000

Hello Xin,

thanks a lot for providing us a feedback to our draft.

In the bitcoin network, the broadcasting of the availability of new blocks and transactions to other peers (inv message) consumes a lot of traffic, since peers receive such messages from all neighbor peers that they are connected with. Our idea was to use ALTO in order to optimize the population of those messages. We are interested to use ALTO in a way that it is not centralising too much of the Bitcoin peer-to-peer protocol, which would be against the idea of having a decentralized architecture, but is nevertheless improving the current network protocol.

Kind Regards,
Stefan

From: wang xin [mailto:[email-masked]]
Sent: 08 July 2016 14:25
To: Stefan HOMMES <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]; Mathis STEICHEN <[email-masked]>
Subject: Re: Draft: Alto for the blockchain

Thanks,

Xin

________________________________
From: alto <[email-masked]<mailto:[email-masked]>> on behalf of Stefan HOMMES <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, July 7, 2016 11:36:57 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Mathis STEICHEN
Subject: [alto] Draft: Alto for the blockchain

Dear ALTO group,

Kind Regards,
Stefan

---

From: Stefan HOMMES <[email-masked]>
Date: Tue, 12 Jul 2016 09:24:50 +0000

Hello Chen,

thanks a lot for providing us a feedback to our draft. Here my comments to your mail:

1.       “Be more general-purpose for block chain”: That’s a good point. Indeed, the draft should not focus only on the Bitocin network but on blockchain in general, which was the reason why I have removed the Bitcoin part from the introduction and described it in a more general way. We will have a look on other chains as well.

2.       “Consider about security”: A good point as well. I am not sure how we should tackle this issue for the moment.

3.       “Let applications aware of the different roles”: In my opinion, there are two ways on how ALTO could answer to a request from a peer: (1) Either ALTO sends an information that is specific to the role of the peer that send the request, or (2) it proposes an answer that is independent of the role, meaning the answer can be used by all types of peers and the peer decides further based on his role. The second way reduces also the information that is provided to ALTO, which might be an advantage with regards to privacy. But I think that ALTO should have some information about the roles, in order to propose different routes by applying different kind of metrics. Of course the roles should be as general as possible, and not be linked to the Bitcoin networks since it is only one example of such a network. Is it foreseen to have such a functionality in ALTO?

Kind Regards,
Stefan

From: Shenshen Chen [mailto:[email-masked]]
Sent: 11 July 2016 14:52
To: Stefan HOMMES <[email-masked]>
Cc: [email-masked]
Subject: Re: [alto] Draft: Alto for the blockchain

Dear authors,

I read your draft and get interested in utilizing ALTO for block chain. I have considered about it over the past few days. Here are some comments:

I noticed that there’re some parts of introduction about bitcoin have been removed from the first version and believed this draft is not specified for bitcoin. Also mentioned in title, this draft is about block chain. But it only mentioned bitcoin as use case of block chain.

In bitcoin wiki, it said “Block chains were invented specifically for the Bitcoin project but they can be applied anywhere a distributed consensus needs to be established in the presence of malicious or untrustworthy actors.”

Despite it may cost too much to implement block chain for non-financial cases, mentioning some other use cases (e.g. alternative chain) could make the draft looks more general-purpose for block chain.

Compare to traditional data base, I thought the block chain was invented to solve the security problem.  So, it is necessary to consider about security which is much more important than efficiency. For example, ALTO server may accept some suboptimal results to improve the randomness and avoid the prediction mentioned in section 7.

In section 6, it said “This requires that the ALTO server is aware of the different roles”. But roles like wallet, miner and relay nodes are specified for bitcoin, it may have different roles in other use cases of block chain. Including such information in ALTO protocol is not general-purpose for block chain.

By the other hand, ALTO is invented to provide low-level network information which application can’t get before. Since the information about different roles is not low-level, it could be more appropriate for ALTO to let applications maintain the map relationship between each node and its role.

Hope these helps. :)

Best Regards,
Shenshen Chen

2016-07-07 23:36 GMT+08:00 Stefan HOMMES <[email-masked]<mailto:[email-masked]>>:
Dear ALTO group,

Kind Regards,
Stefan

Phone: (+352) 46 66 44 5834<tel:%28%2B352%29%2046%2066%2044%205834>

_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/alto

---

From: Shenshen Chen <[email-masked]>
Date: Tue, 12 Jul 2016 19:32:00 +0800

Dear authors,

  I agree with Wendy's opinion about "Let applications be aware of the
different roles" in the bottom of her review. I think it could be concluded
into:

  1. ALTO should support several cost metrics

  2. client should send different request, which determines the cost
metric, based on its role

  I think ALTO is mainly about low-level network information and should not
have such functionality.

Best Regards,
Shenshen Chen

2016-07-12 17:24 GMT+08:00 Stefan HOMMES <[email-masked]>:

> 1.       “Be more general-purpose for block chain”: That’s a good point.
> Indeed, the draft should not focus only on the Bitocin network but on
> blockchain in general, which was the reason why I have removed the Bitcoin
> part from the introduction and described it in a more general way. We will
> have a look on other chains as well.
>
>
>
> 2.       “Consider about security”: A good point as well. I am not sure
> how we should tackle this issue for the moment.
>
>
>
> 3.       “Let applications aware of the different roles”: In my opinion,
> there are two ways on how ALTO could answer to a request from a peer: (1)
> Either ALTO sends an information that is specific to the role of the peer
> that send the request, or (2) it proposes an answer that is independent of
> the role, meaning the answer can be used by all types of peers and the peer
> decides further based on his role. The second way reduces also the
> information that is provided to ALTO, which might be an advantage with
> regards to privacy. But I think that ALTO should have some information
> about the roles, in order to propose different routes by applying different
> kind of metrics. Of course the roles should be as general as possible, and
> not be linked to the Bitcoin networks since it is only one example of such
> a network. Is it foreseen to have such a functionality in ALTO?
>
>
>
> Kind Regards,
>
> Stefan
>
>
>
>
>
> *From:* Shenshen Chen [mailto:[email-masked]]
> *Sent:* 11 July 2016 14:52
> *To:* Stefan HOMMES <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [alto] Draft: Alto for the blockchain
>
>
>
> Dear authors,
>
>
>
> Compare to traditional data base, I thought the block chain was invented
> to solve the security problem.  So, it is necessary to consider about
> security which is much more important than efficiency. For example, ALTO
> server may accept some suboptimal results to improve the randomness and
> avoid the prediction mentioned in section 7.
>
>
>