Subject: Re: [alto] Metric redefintion issue in ALTO TE Metric draft

From: "Randriamasy, Sabine (Nokia - FR)" <[email-masked]>
Date: Wed, 6 Jul 2016 13:49:02 +0000

Hi all,

To resume the discussions on ALTO TE metrics: applications want to have a sense of the network capabilities in terms of e.g. bandwidth, latency or  hop count. ALTO could provide them in an e2e, space and time aggregated form and differs from what eg I2RS provides.

One feature to specify carefully is the measurement time intervals: on one hand the server may indicate it to hint the accuracy of the data but if a metric comes from multiple sources with multiple measurement configurations it may be problematic. The only thing the ALTO Server may expose to the Client is the validity period of such a metric, either "constant" until the next update or calendared. The client will have to rely on that indication and trust the Server.

Are there any thoughts on this matter in the WG?

Thanks,
Sabine

De : alto [mailto:[email-masked]] De la part de EXT Qin Wu
Envoyé : samedi 26 mars 2016 04:42
À : IETF ALTO
Objet : [alto] Metric redefintion issue in ALTO TE Metric draft

In IETF90 Toronto meeting, one question was raised on draft-wu-alto-te-metrics
https://tools.ietf.org/html/draft-wu-alto-te-metrics-06
is whether we redefine metric defined somewhere else.
Here is the clarification:
I think this is not metric redefinition and what we do is to feed TE metric gathered using routing protocol into ALTO server and provide such TE metric to ALTO client.
ALTO server may aggregate metric data gathered using various routing protocols. But the purpose is to normalize the data and provide it to ALTO client in more useful way,
e.g., calculate end to end metric based on hop by hop metric and expose it to the ALTO client.

-Qin

---

From: Qin Wu <[email-masked]>
Date: Thu, 7 Jul 2016 03:49:30 +0000

发件人: Randriamasy, Sabine (Nokia - FR) [mailto:[email-masked]]
发送时间: 2016年7月6日 21:49
收件人: Qin Wu; IETF ALTO
主题: RE: Metric redefintion issue in ALTO TE Metric draft

Hi all,

[Qin]: Good point, I think the metrics we defined in this draft should not limited to TE metrics, we should extend it to any performance metrics we can get from various different data source.
Another difference we can make is ALTO cost metrics can more focus on end to end path while I2RS not.

[Qin]: Agree, I can add some text in the introduction to clarify this. Thanks!

Thanks,
Sabine

-Qin

---

From: Qin Wu <[email-masked]>
Date: Fri, 8 Jul 2016 05:54:54 +0000

Here is the update of ALTO TE metric draft based on discussion on the list and Fred’s comments on IPv6 example.
https://tools.ietf.org/html/draft-wu-alto-te-metrics-08

-Qin
发件人: alto [mailto:[email-masked]] 代表 Qin Wu
发送时间: 2016年7月7日 11:50
收件人: Randriamasy, Sabine (Nokia - FR); IETF ALTO
主题: Re: [alto] Metric redefintion issue in ALTO TE Metric draft

Hi all,

Thanks,
Sabine

-Qin