Subject: Re: [alto] IETF 96 agenda requests

From: "Y. Richard Yang" <[email-masked]>
Date: Mon, 4 Jul 2016 19:06:27 -0400

Vijay, Jan, all,

I am replying this email publicly so that all of us can engage more in
shaping the agenda in about three weeks.

A key item that the WG needs to discuss, in the potentially more
productive f2f-meeting setting in Berlin, is how the WG should move
forward. Can we allocate a slot, say at least 20 min, for this discussion?

Besides the general discussions, here are some comments on specific agenda
items and the mission of the WG:

- Despite the substantial change of the networking landscape, I still
believe that the foundational services of ALTO are sound: providing
abstract network information to applications. I believe that this is also
what many others see ALTO; for example see [1]. The key is what we do to go
beyond the initial network abstractions.

- The first I see is Endpoint Cost Service (ECS), which is the foundation.
It provides an interface to allow applications to know the routing costs.
However, current ALTO is defined pre-SDN, and the emerging trend of SDN is
going beyond simple destination routing, to be more application dependent.
Hence, I see that we need to go beyond Endpoint Cost Service, to say Flow
Cost Service. There is an extension draft [2], and I suggest that the WG
finishes this to make the ALTO protocol complete. Make sense?

-  The next I see is network graph (path vector) abstraction. The more I
think about it, the more I am convinced that this is the way we go. I am an
author of the draft and multiple versions are evolving [3, 4, 5], but we
are relatively slow in convergence. I suggest that the WG gets a set of
active participants to finish this draft, so that we have a relatively
complete set of ALTO services.

Cheers,
Richard

[1] https://www.opendaylight.org/file/odl-beryllium-diagram02
[2] https://datatracker.ietf.org/doc/draft-wang-alto-ecs-flows/
[3]
https://datatracker.ietf.org/doc/draft-gao-alto-routing-state-abstraction/
[4] https://tools.ietf.org/html/draft-yang-alto-topology-06
[5] https://tools.ietf.org/html/draft-scharf-alto-topology-00

On Wednesday, June 29, 2016, Vijay K. Gurbani <[email-masked]> wrote:

> Folks: Please send me and Jan agenda requests for the ALTO WG meeting
> in IETF.  We have a 2 hour slot on Thu afternoon (July 21).
>
> Specifically:
>
>   - Presenter name
>   - Time requested (in minutes)
>   - Internet-Draft to be discussed
>
> As usual, drafts that have seen list discussions will be given
> precedence when scheduling the agenda.
>
> As you are all aware, the deployment draft is now with the IESG.
> As per our last meeting (virtual interm [1]), we need to move two
> drafts ahead: (1) draft-ietf-alto-multi-cost-01 needs to be scheduled
> for a WGLC, and (2) draft-randriamasy-alto-cost-calendar-05 needs to be
> open up to being adopted as a WG item.  Jan and I will like to start
> proceeding on this perhaps as early as next week.
>
> [1]
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_proceedings_interim_2015_10_27_alto_minutes_minutes-2Dinterim-2D2015-2Dalto-2D1&d=CwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=ASHRozEgZvFCzydTsT-P7fLIy1RVC6ciNuTtWDmqNtM&s=ghe2Ca7B5zd4u_ZWbLeZZ5oexLFxV07x-MYfkipmAk4&e=
> Thank you,
>
> - vijay
> --
> Vijay K. Gurbani, Bell Laboratories, Nokia Networks
> 1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
> Email: [email-masked] / [email-masked]
> Web:
> https://urldefense.proofpoint.com/v2/url?u=http-3A__ect.bell-2Dlabs.com_who_vkg_&d=CwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=ASHRozEgZvFCzydTsT-P7fLIy1RVC6ciNuTtWDmqNtM&s=TgjoQbo9aR1PTVWRY6Ydlw_khODlDN6l8OaFh4fS1ZA&e=
>  | Calendar:
> https://urldefense.proofpoint.com/v2/url?u=http-3A__goo.gl_x3Ogq&d=CwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=ASHRozEgZvFCzydTsT-P7fLIy1RVC6ciNuTtWDmqNtM&s=1Q7R5p_enzJxoGM_E41qNrEhCWmfOrjLsuv6jL-Sw64&e=
> _______________________________________________
> alto mailing list
> [email-masked]
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=CwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=ASHRozEgZvFCzydTsT-P7fLIy1RVC6ciNuTtWDmqNtM&s=M5Nv0WdiAJeh_iGLcglzHuJQVxMDz5gxGw32JXEFCf8&e=

---

From: Greg Bernstein <[email-masked]>
Date: Tue, 5 Jul 2016 09:49:19 -0700

Hi Richard and all, for the last few years I've been teaching and 
working in the SDN space and mostly agree with Richard's assessment. The 
only disagreement is with his assessment of "slow" convergence of the 
network graph/(path vector) drafts. These drafts are basically in 
conceptual agreement and have been for quite some time (2012 Vancouver 
meeting). The exact encoding details were not worked out at the time, 
but could be quickly converged based on examples that have been given in 
the more recent drafts.

The applicability of such a feature to SDN virtualized networks 
hopefully should be clear but we can easily add it as another 
application/motivation.

On 7/4/2016 4:06 PM, Y. Richard Yang wrote:
> Besides the general discussions, here are some comments on specific 
> agenda items and the mission of the WG:
>
> abstract network information to applications. I believe that this is 
> also what many others see ALTO; for example see [1]. The key is what 
> we do to go beyond the initial network abstractions.
>
> - The first I see is Endpoint Cost Service (ECS), which is the 
> foundation. It provides an interface to allow applications to know the 
> routing costs. However, current ALTO is defined pre-SDN, and the 
> emerging trend of SDN is going beyond simple destination routing, to 
> be more application dependent. Hence, I see that we need to go beyond 
> Endpoint Cost Service, to say Flow Cost Service. There is an extension 
> draft [2], and I suggest that the WG finishes this to make the ALTO 
> protocol complete. Make sense?
>
> -  The next I see is network graph (path vector) abstraction. The more 
> I think about it, the more I am convinced that this is the way we go. 
> I am an author of the draft and multiple versions are evolving [3, 4, 
> 5], but we are relatively slow in convergence. I suggest that the WG 
> gets a set of active participants to finish this draft, so that we 
> have a relatively complete set of ALTO services.
>
> Cheers,
> Richard
>
> On Wednesday, June 29, 2016, Vijay K. Gurbani <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
> https://www.ietf.org/mailman/listinfo/alto

---

From: "Y. Richard Yang" <[email-masked]>
Date: Tue, 5 Jul 2016 13:17:15 -0400

Greg,

On Tue, Jul 5, 2016 at 12:49 PM, Greg Bernstein <[email-masked]
> wrote:

> Hi Richard and all, for the last few years I've been teaching and working
> in the SDN space and mostly agree with Richard's assessment. The only
> disagreement is with his assessment of "slow" convergence of the network
> graph/(path vector) drafts. These drafts are basically in conceptual
> agreement and have been for quite some time (2012 Vancouver meeting). The
> exact encoding details were not worked out at the time, but could be
> quickly converged based on examples that have been given in the more recent
> drafts.
>

It indeed is a good time to quickly converge on the exact encoding details
so that we can move forward. This should be a high priority item and let's
work out the details during this IETF. I will focus on it and propose an
encoding shortly.

Richard

>
> The applicability of such a feature to SDN virtualized networks hopefully
> should be clear but we can easily add it as another application/motivation.
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.opendaylight.org_file_odl-2Dberyllium-2Ddiagram02&d=CwMD-g&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=5sw_YxsxtW9F-vu0hFORg5c2EhTUbPW4riB7Mmw7N7w&s=4BIJy1a-w7oLopKYs7CvZ9YGi2KlP0GR1oItneA6dss&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dwang-2Dalto-2Decs-2Dflows_&d=CwMD-g&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=5sw_YxsxtW9F-vu0hFORg5c2EhTUbPW4riB7Mmw7N7w&s=76e9QG_RFB0XcFTvC0kl4jkFnYL-NhKmRqAKjMiK06w&e=>
> [3]
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dgao-2Dalto-2Drouting-2Dstate-2Dabstraction_&d=CwMD-g&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=5sw_YxsxtW9F-vu0hFORg5c2EhTUbPW4riB7Mmw7N7w&s=rrFCRPrfnqM1oEKOUBvyUMjAZilg_6RHhGopCzYuIWk&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dyang-2Dalto-2Dtopology-2D06&d=CwMD-g&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=5sw_YxsxtW9F-vu0hFORg5c2EhTUbPW4riB7Mmw7N7w&s=AVQTVYzV2NAadD9v8Dv0GlHKWMykNPJIGd_V43GQh5Q&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dscharf-2Dalto-2Dtopology-2D00&d=CwMD-g&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=5sw_YxsxtW9F-vu0hFORg5c2EhTUbPW4riB7Mmw7N7w&s=svwYVIutwfuVb9YbDbTGc2dBvf5jQ_B6QWcwQli_MY8&e=>
>
> On Wednesday, June 29, 2016, Vijay K. Gurbani < <[email-masked]>
> [email-masked]> wrote:
>
> alto mailing [email-masked]
> https://www.ietf.org/mailman/listinfo/alto <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=CwMD-g&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=5sw_YxsxtW9F-vu0hFORg5c2EhTUbPW4riB7Mmw7N7w&s=tk4J8ID6Yziw0coNvrkTsrR41sl9drsuae2z0B5W0ns&e=>
>
>
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=CwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=5sw_YxsxtW9F-vu0hFORg5c2EhTUbPW4riB7Mmw7N7w&s=tk4J8ID6Yziw0coNvrkTsrR41sl9drsuae2z0B5W0ns&e=
>
>

-- 
-- 
 =====================================
| Y. Richard Yang <[email-masked]>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 5 Jul 2016 12:22:33 -0500

On 07/05/2016 12:17 PM, Y. Richard Yang wrote:
> It indeed is a good time to quickly converge on the exact encoding
> details so that we can move forward. This should be a high priority item
> and let's work out the details during this IETF. I will focus on it and
> propose an encoding shortly.

Excellent.  This will go a long way to convergence and uniform
understanding.

Cheers,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Nokia Networks
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: [email-masked] / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: Qiao Xiang <[email-masked]>
Date: Fri, 8 Jul 2016 19:48:59 -0400

Hi Vijay,

We have submitted a new I-D for consideration. It describes a dataset
transfer orchestrator for exascale science networks.

It can be found at
https://datatracker.ietf.org/doc/draft-xiang-alto-exascale-network-optimization/

Can we request a slot for this draft:
- Presenter name: Qiao Xiang
- Time required: 10 min
- Draft: draft-xiang-alto-exascale-network-optimization-00

Thank you very much.

Best
Qiao

On Wed, Jun 29, 2016 at 10:40 AM, Vijay K. Gurbani <[email-masked]>
wrote:

> https://www.ietf.org/proceedings/interim/2015/10/27/alto/minutes/minutes-interim-2015-alto-1
>
> Thank you,
>
> - vijay
> --

-- 
Qiao Xiang
Postdoctoral Fellow,
Department of Computer Science,
Yale University