Subject: [alto] A summary on active drafts

From: Gao Kai <[email-masked]>
Date: Tue, 19 Jul 2016 16:13:15 +0800

Hello everyone,

With the IETF meeting getting closer, it might be a good time we discuss
about the future steps the working group should take and how we can all
collaborate.  The active drafts are listed below in different
categories, with some initial proposals on how to proceed.  Your
feedbacks and opinions are highly appreciated.

-   Current WG drafts
    -   draft-ietf-alto-deployments-15 [1]
    -   draft-ietf-alto-incr-update-sse-02 [2]
    -   draft-ietf-alto-multi-cost-02 [3]

The target of the three drafts listed here is to become RFCs.

The deployment draft is already submitted to the IESG and according to
my understanding it is beyond our concern at the moment.

Wendy has confirmed that the incremental update draft needs some
cosmetic changes but otherwise is ready to proceed.

The chairs have issued a working group Last-Call on
draft-ietf-alto-multi-cost.  According to Sabine, it has received some
comments and a new version will be proposed after the IETF meeting.

-   Discovery
    -   draft-kiesel-alto-xdom-disc-02 [9]

The procedure of XDOM-DISC is pretty clear and can target a working
group draft.  There are some concerns about the aggregation of ALTO
queries, mostly due to the missing of routing cost standards.  However,
as some of the drafts to be mentioned later are proposing standard cost
types, they may throw light upon the aggregation problem.

-   Update and synchronization
    -   draft-ietf-alto-incr-update-sse-02 [2]
    -   draft-wang-alto-dist-sync-00 [12]

-   Extending cost types
    -   draft-ietf-alto-multi-cost-02 [3]
    -   draft-randriamasy-alto-cost-calendar-06 [10]
    -   draft-wu-alto-te-metrics-08 [14]
    -   draft-yang-alto-path-vector-03 [16]

draft-wu-alto-te-metrics proposes several standard cost metrics in the
context of traffic engineering, most of which are compatible with the
current ALTO services.

Richard has started a thread discussing whether we should design a
unified mechanism to handle extensions like multi-cost, cost-calendar,
path-vector and other future drafts on cost type and how we can do that.

-   Extending services
    -   draft-gao-alto-fcs-00 [6]
    -   draft-gao-alto-routing-state-abstraction-03 [7]
    -   draft-roome-alto-unified-props-01 [11]
    -   draft-wang-alto-ecs-flows-01 [13]

draft-roome-alto-unified-props is pretty mature and is ready to be
promoted as a working group draft.  The others are more experimental and
require more reviews.

draft-gao-alto-fcs/draft-wang-alto-ecs-flows both extend the
representation of an endpoint, to enable more fine-grained queries in
the context of SDN.  ECS-flow is more backward compatible while FCS is
more similar with the OpenFlow protocol.

-   Graph representation
    -   draft-gao-alto-routing-state-abstraction-03 [7]
    -   draft-yang-alto-path-vector-03 [16]
    -   Greg et. al have also submitted some drafts on this issue (outdated)

The graph representation is one topic in the working group charter.  A
good start might be a draft clarifying the motivations, which should
target becoming a working group draft in the next meeting, hopefully
with some initial proposals too.

-   Modelling
    -   draft-zhang-alto-opendaylight-impl-01 [17]
    -   Shi et. al have also submitted some drafts on this issue (outdated)

Many other working groups are using YANG to model their protocols, which
unfortunately is not compatible with the current ALTO format.  There was
a draft proposing basic YANG models for ALTO services but needs some
refinement to become a working group draft.

-   Application
    -   draft-bertz-alto-sdnnfvalto-02 [4]
        (Christian et. al have also submitted some related drafts to
other working groups)
    -   draft-chen-alto-ethernet-optical-converged-network-00 [5]
    -   draft-hommes-alto-blockchain-01 [8]
    -   draft-xiang-alto-exascale-network-optimization-00 [15]

draft-bertz-alto-sdnnfvalto has highlighted how ALTO can be used with
SDN/NFV.  The draft discusses how an ALTO server can aggregate
information from different system components, such as SDN controller,
the NFV Orchestrator, etc., and also some general topics such as dynamic
measurement.

draft-chen-alto-ethernet-optical-converged-network describes how ALTO
can be used in an optical converged network.

draft-hommes-alto-blockchain discusses how ALTO can be used for
different blockchains (private, consortium and public), especially the
Bitcoin network.

draft-xiang-alto-exasaacle-network-optimization introduces the framework
of handling data transfers of large volume with the assistance of ALTO,
with graph representations.

These draft can target becoming informational working group drafts. 
Meanwhile, they may also propose to add new endpoint properties in
specific domains, for example, "vnf:load-balancer", "bitcoin:wallet", etc.

Regards,
Kai

[ 1] https://datatracker.ietf.org/doc/draft-ietf-alto-deployments/
[ 2] https://datatracker.ietf.org/doc/draft-ietf-alto-incr-update-sse/
[ 3] https://datatracker.ietf.org/doc/draft-ietf-alto-multi-cost/
[ 4] https://datatracker.ietf.org/doc/draft-bertz-alto-sdnnfvalto/
[ 5]
https://datatracker.ietf.org/doc/draft-chen-alto-ethernet-optical-converged-network/
[ 6] https://datatracker.ietf.org/doc/draft-gao-alto-fcs/
[ 7]
https://datatracker.ietf.org/doc/draft-gao-alto-routing-state-abstraction/
[ 8] https://datatracker.ietf.org/doc/draft-hommes-alto-blockchain/
[ 9] https://datatracker.ietf.org/doc/draft-kiesel-alto-xdom-disc/
[10] https://datatracker.ietf.org/doc/draft-randriamasy-alto-cost-calendar/
[11] https://datatracker.ietf.org/doc/draft-roome-alto-unified-props/
[12] https://datatracker.ietf.org/doc/draft-wang-alto-dist-sync/
[13] https://datatracker.ietf.org/doc/draft-wang-alto-ecs-flows/
[14] https://datatracker.ietf.org/doc/draft-wu-alto-te-metrics/
[15]
https://datatracker.ietf.org/doc/draft-xiang-alto-exascale-network-optimization/
[16] https://datatracker.ietf.org/doc/draft-yang-alto-path-vector/
[17] https://datatracker.ietf.org/doc/draft-zhang-alto-opendaylight-impl/

---

From: "Y. Richard Yang" <[email-masked]>
Date: Tue, 19 Jul 2016 16:25:59 -0400

Hi Kai,

Thank you so much for giving a nice summary and sharing your personal view
on the active drafts. The WG sure has many remaining issues to solve and
many drafts to go through. I will try to use some of your comments below in
the discussion slot :-). I am sure the WG chairs and other members have
many considerations/inputs as well. I understand that you will not attend
in person. Are you able to call in during the session, or use jabber to
give comments.

Thanks!
Richard

On Tuesday, July 19, 2016, Gao Kai <[email-masked]> wrote:

> collaborate.  The active drafts are listed below in different categories,
> with some initial proposals on how to proceed.  Your feedbacks and opinions
> are highly appreciated.
>
> -   Current WG drafts
> The deployment draft is already submitted to the IESG and according to my
> understanding it is beyond our concern at the moment.
>
> Wendy has confirmed that the incremental update draft needs some cosmetic
> changes but otherwise is ready to proceed.
>
> The procedure of XDOM-DISC is pretty clear and can target a working group
> draft.  There are some concerns about the aggregation of ALTO queries,
> mostly due to the missing of routing cost standards.  However, as some of
> the drafts to be mentioned later are proposing standard cost types, they
> may throw light upon the aggregation problem.
>
> Richard has started a thread discussing whether we should design a unified
> mechanism to handle extensions like multi-cost, cost-calendar, path-vector
> and other future drafts on cost type and how we can do that.
>
> -   Extending services
> representation of an endpoint, to enable more fine-grained queries in the
> context of SDN.  ECS-flow is more backward compatible while FCS is more
> similar with the OpenFlow protocol.
>
> -   Graph representation
> good start might be a draft clarifying the motivations, which should target
> becoming a working group draft in the next meeting, hopefully with some
> initial proposals too.
>
> -   Modelling
> unfortunately is not compatible with the current ALTO format.  There was a
> draft proposing basic YANG models for ALTO services but needs some
>         (Christian et. al have also submitted some related drafts to other
> working groups)
> SDN/NFV.  The draft discusses how an ALTO server can aggregate information
> from different system components, such as SDN controller, the NFV
> Orchestrator, etc., and also some general topics such as dynamic
> measurement.
>
> draft-chen-alto-ethernet-optical-converged-network describes how ALTO can
> be used in an optical converged network.
>
> draft-hommes-alto-blockchain discusses how ALTO can be used for different
> blockchains (private, consortium and public), especially the Bitcoin
> network.
>
> Meanwhile, they may also propose to add new endpoint properties in specific
> domains, for example, "vnf:load-balancer", "bitcoin:wallet", etc.
>
> Regards,
> Kai
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dalto-2Ddeployments_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=nhaJhgDM1Dlp6YZ_4psILVJZiOzMFhljwhAlrmINBbk&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dalto-2Dincr-2Dupdate-2Dsse_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=U5SJH6UAPuqojzbR4gZ7reuqk4DkovMSGw1fxeQtXC0&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dalto-2Dmulti-2Dcost_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=HeBNsCxUNO-3bM40AjCnKxitUXvQkQowHmaU9B0XEaQ&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dbertz-2Dalto-2Dsdnnfvalto_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=OwxOxQc28DgfkRVZRyyZ8U39nmUGFGNqyY3wQgkFN08&e=>
> [ 5]
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dchen-2Dalto-2Dethernet-2Doptical-2Dconverged-2Dnetwork_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=n7L20UR8AOd24bbNhlYQumxmBfZB-8kk_7n6ymWLSMM&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dgao-2Dalto-2Dfcs_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=VfoyOvO4MVeWzHJhN0jq__gUh_arlj2ShHoaKlL4mZo&e=>
> [ 7]
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dgao-2Dalto-2Drouting-2Dstate-2Dabstraction_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=0ogP-PWmhtqB1I6ElDbd-8iwVyjXxgGYlHh7t0NNwmU&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dhommes-2Dalto-2Dblockchain_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=ae33A7rLLRHGRN7SwVzdNTpM2D8jY21T3ns2w19wIOQ&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dkiesel-2Dalto-2Dxdom-2Ddisc_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=oxRp2kUU8jOOYMKksEcp9qAe0JD2cpzHrn55cHG1SB4&e=>
> [10]
> https://datatracker.ietf.org/doc/draft-randriamasy-alto-cost-calendar/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Drandriamasy-2Dalto-2Dcost-2Dcalendar_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=2tyAzCma_xxzeZgUM-nJOxHurVJHHbC_F0aHIW57ifA&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Droome-2Dalto-2Dunified-2Dprops_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=a_hyIt4pJA78h8cCutGOlln7NkSUYE2PxnMDoDV5lVA&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dwang-2Dalto-2Ddist-2Dsync_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=SV0NpS-egTYopr4uhy_RVqJI8HUn2nz6oqR1tj-zE10&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dwang-2Dalto-2Decs-2Dflows_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=buPaDIfZlE4MU5OCLHVRafs7tafQ4tOFFloISbLG4rc&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dwu-2Dalto-2Dte-2Dmetrics_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=RHbAny3tbefcmItfHTE6NAOoDRHifSHVTyDXEsD3Fgk&e=>
> [15]
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dxiang-2Dalto-2Dexascale-2Dnetwork-2Doptimization_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=Lv0lKeekO6cumIkSz8in8h333h58gOBvzP9Tfji5GyQ&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dyang-2Dalto-2Dpath-2Dvector_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=EFP5Almo0PovjNnVjll006pJllVfOOE6Rnrd5wcVob4&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dzhang-2Dalto-2Dopendaylight-2Dimpl_&d=CwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=506VcsQzlkB9X60xV_7Lz0LFBFpBTY2zmiYTbwSLcqI&s=UDHWNhqx1P81tmkF__7GJj0boRDwShLi0122b1DSWSQ&e=>
>
>

-- 
Richard