Subject: Re: [alto] TR: I-D Action: draft-ietf-alto-multi-cost-03.txt

From: Jan Seedorf <[email-masked]>
Date: Fri, 2 Sep 2016 12:19:40 -0700

Dear Sabine,

thank you for addressing the comments and moving this ahead. This draft 
is now pretty much ready for being moved out of the WG.

> We still need to finalize the consistency check for E/endpoints, C/client and S/server.
Can you do that sometime soon, so that we can move this ahead before the 
next IETF meeting?

> Can the comment authors please take a look and check whether their other comments were correctly addressed?
Indeed, can the reviewers please briefly confirm that the comments have 
all been addressed adequately? (From looking at Sabine's comments below, 
I think they have, but better if the reviewers confirm themselves).

Thanks,

Jan

On 10/08/16 13:38, Randriamasy, Sabine (Nokia - FR) wrote:
> Hello,
>
> A new version draft-ietf-alto-multi-cost-03 has been submitted.
>
> This version addresses WG comments from Hans, Xin and Richard.
> We still need to finalize the consistency check for E/endpoints, C/client and S/server.
>
> Can the comment authors please take a look and check whether their other comments were correctly addressed?
>
> Thanks again for your feedback,
> Sabine
>
>
> The updates summary is as follows
> ----------------------------------------------------------------------
> *** Abstract
> Rephrased according to comments.
>
> *** Section "1. Introduction"
> Rephrased paragraphs 2,3,4 according to comments
>
> *** Section "2. Terminology"
> Added terms "Client" and "Server" to solve ambiguities on client and Client"
> Whole text: updated according to these rules.
>
> *** Section "4.1.2.  Accept Input Parameters"
> - transferred the text introducing extended predicates from the "or-constraint" to the "constraints" paragraph.
> - stressed that "If this resource's "max-cost-types" capability has a value greater than 0, then this parameter is an array of extended constraint predicates as defined below and related to each other by a logical AND".
> - in or-constraints:
> (i) added "This parameter MUST NOT contain any empty array of AND predicates" and (ii) added an example interpretation of an or-constraint
>
> *** Section "4.1.2.  Accept Input Parameters"
> *** Section "4.2.2.  Accept Input Parameters"
> updated the or-constraint member to: JSONString or-constraints<1..*><1..*> + added sentence explaining why
>
>
> ****** Updates on ALTO response meta
> Section: 3.1,
> Section: 5.2 .. example 1,
> Section: 5.3 .. example 2,
> Section: 5.5 .. example 4
> added "cost-type :  {}" in the meta
>
> Section: 4.1.3 Response
> Section: 4.2.3 Response
> updated description of the meta response accordingly
> ----------------------------------------------------------------------
>
>>> -----Message d'origine-----
>>> De : alto [mailto:[email-masked]] De la part de internet-
>>> [email-masked]
>>> Envoyé : mercredi 10 août 2016 22:32
>>> À : [email-masked]
>>> Cc : [email-masked]
>>> Objet : [alto] I-D Action: draft-ietf-alto-multi-cost-03.txt
>>>
>>>
>>> A New Internet-Draft is available from the on-line Internet-Drafts
>>> directories.
>>> This draft is a work item of the Application-Layer Traffic Optimization
>>> of the IETF.
>>>
>>>         Title           : Multi-Cost ALTO
>>>         Authors         : Sabine Randriamasy
>>>                           Wendy Roome
>>>                           Nico Schwan
>>> 	Filename        : draft-ietf-alto-multi-cost-03.txt
>>> 	Pages           : 29
>>> 	Date            : 2016-08-10
>>>
>>> Abstract:
>>>    The ALTO (Application Layer-Traffic Optimization) Protocol
>>>    ([RFC7285]) defines several services that return various metrics
>>>    describing the costs between network endpoints.  An ALTO Server may
>>>    offer a variety of cost metrics, based on latency,bandwidth, hop
>>>    count, jitter, or whatever else the ALTO Server deems useful.  For
>>>    example, when downloading a file that is mirrored on several sites,
>>> a
>>>    user application may consider more than one metric, perhaps trading
>>>    bandwidth for latency to determine the most efficient mirror site.
>>>
>>>    While the base ALTO Protocol allows a client to use more than one
>>>    cost metric, to do so, the client must request each metric
>>>    separately.  This document defines a new service that allows a
>>> client
>>>    to retrieve several cost metrics with one request, which is
>>>    considerably more efficient.  In addition, this document extends the
>>>    ALTO constraint tests to allow a user to specify an arbitrary
>>> logical
>>>    combination of tests on several cost metrics.
>>>
>>>
>>>
>>> The IETF datatracker status page for this draft is:
>>> https://datatracker.ietf.org/doc/draft-ietf-alto-multi-cost/
>>>
>>> There's also a htmlized version available at:
>>> https://tools.ietf.org/html/draft-ietf-alto-multi-cost-03
>>>
>>> A diff from the previous version is available at:
>>> https://www.ietf.org/rfcdiff?url2=draft-ietf-alto-multi-cost-03
>>>
>>>
>>> Please note that it may take a couple of minutes from the time of
>>> submission until the htmlized version and diff are available at
>>> tools.ietf.org.
>>>
>>> Internet-Drafts are also available by anonymous FTP at:
>>> ftp://ftp.ietf.org/internet-drafts/
>>>
>>> _______________________________________________
>>> alto mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/alto
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto

-- 
****************************
Prof. Dr. Jan Seedorf
[email-masked]
****************************
Hochschule für Technik Stuttgart
Fakultät Vermessung, Informatik und Mathematik
Schellingstr. 24
D-70174 Stuttgart
www.hft-stuttgart.de
****************************

---

From: "Randriamasy, Sabine (Nokia - FR)" <[email-masked]>
Date: Mon, 5 Sep 2016 12:31:23 +0000

Hi Jan,

The consistency check will be finalized by the end of the week.
Thanks, 
Sabine

>>De : Jan Seedorf [mailto:[email-masked]]
>>Envoyé : vendredi 2 septembre 2016 21:20
>>À : Randriamasy, Sabine (Nokia - FR); IETF ALTO
>>Objet : Re: [alto] TR: I-D Action: draft-ietf-alto-multi-cost-03.txt
>>
>>Dear Sabine,
>>
>>Can you do that sometime soon, so that we can move this ahead before
>>the next IETF meeting?
>>
>>all been addressed adequately? (From looking at Sabine's comments
>>below, I think they have, but better if the reviewers confirm
>>themselves).
>>
>>Thanks,
>>
>>Jan
>>
>>
>>> - transferred the text introducing extended predicates from the "or-
>>constraint" to the "constraints" paragraph.
>>> - stressed that "If this resource's "max-cost-types" capability has a
>>value greater than 0, then this parameter is an array of extended
>>constraint predicates as defined below and related to each other by a
>>logical AND".
>>> - in or-constraints:
>>> (i) added "This parameter MUST NOT contain any empty array of AND
>>> predicates" and (ii) added an example interpretation of an
>>> or-constraint
>>>
>>> updated the or-constraint member to: JSONString
>>> or-constraints<1..*><1..*> + added sentence explaining why
>>>
>>>
>>>>> [email-masked] Envoyé : mercredi 10 août 2016 22:32 À :
>>>>> [email-masked] Cc : [email-masked] Objet : [alto] I-D Action:
>>>>> draft-ietf-alto-multi-cost-03.txt
>>>>>
>>>>>
>>>>> This draft is a work item of the Application-Layer Traffic
>>>>> Optimization of the IETF.
>>>>>
>>>>>         Title           : Multi-Cost ALTO
>>>>>    example, when downloading a file that is mirrored on several
>>>>> sites, a
>>Fakultät Vermessung, Informatik und Mathematik Schellingstr. 24
>>D-70174 Stuttgart
>>www.hft-stuttgart.de