Subject: [ANCP] draft-moustafa-ancp-security-threats-00.txt to WG ID?

From: [email-masked]
Date: Thu, 9 Nov 2006 23:23:02 +0000

During the ANCP meeting in San Diego we asked whether the ANCP Security
Threats Analysis draft (draft-moustafa-ancp-security-threats-00.txt) should
become a working group ID.

Please review the draft and post comments to the list, also indicating
whether or not you support this draft becoming a working group ID.

Regards,

Matthew

_______________________________________________
ANCP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ancp

---

From: [email-masked]
Date: Mon, 13 Nov 2006 16:11:11 +0100

I support this draft becoming a WG ID.

---

From: [email-masked]
Date: Mon, 13 Nov 2006 17:44:54 +0100

Yes for a WG draft.

regards,
Stefaan

---

From: "Kim Hyldgaard \(ST/LMD\)" <[email-masked]>
Date: Tue, 14 Nov 2006 09:15:50 +0100

Hi,

I support this draft becomming a WG ID.

Br
Kim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 10. november 2006 00:23
To: [email-masked]
Subject: [ANCP] draft-moustafa-ancp-security-threats-00.txt to WG ID?

During the ANCP meeting in San Diego we asked whether the ANCP Security
Threats Analysis draft (draft-moustafa-ancp-security-threats-00.txt)
should become a working group ID.

Regards,

Matthew

---

From: "pavan_kurapati" <[email-masked]>
Date: Tue, 14 Nov 2006 14:43:42 +0530

Hi,
I have following comments on this draft.

1. Introduction: "Prevention again Impersonation". Change it to  'against'

2. Section 4 : The last bullet points of the 2 sections point to same thing. i.e changing QoS settings for gaining profit. What is the difference?

3. Section 5 seems to have lot of repeated information. For eg., 5.6 Man-in-the-Middle is discussed in previous sections as well (like DoS attack section). Also, 5.7 Network snooping is very similar to traffic analysis section. Both can be merged.

4.  6.1 one of the attacks mentions "man-in-the-middle attack causing access loop configuration data retrieval from the policy server by an illegitimate NAS". I see this as a security consideration between policy server and NAS. In the begininning of this section it was mentioned that this is out of scope and is not discussed. Just a minor comment on consistency

5. 6.2 Access loop Configuration :
first bullet point says that an onpath adversary on AN can change the access loop configuration. I would not see it as a ANCP threat. If there is an onpath adversay 'on' AN, the AN itself is compromised. So he would not wait for ANCP to change the access loop configuration isn't it?

6. I am not sure how a DSL user can be 'on path' adversary. I assume 'on path' adversary as someone residing between NAS and AN (As defined in section 3). Bullet 4 of section 6.2 says that an on path adversary  can configure his "own" profile with some other privileged client's profile. I think it is possible only by someone  sitting between AN and NAS . He does not have a user profile of his own. More explanation is required as to how it can be possible?

7. 6.4 also talks about modifying parameters to adversary benefit. I do not think an onpath adversary can do something for his own benefit. I see a DSL user as an off path adversary who can do certain limited things w.r.to loopback tests etc. How can he change profiles of his own or someone else using ANCP?

Pavan Kumar Kurapati
Infosys Technologies Ltd,
Bangalore

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message. Further, you are not to copy, disclose, or distribute this e-mail or its contents to any other person and any such actions are unlawful. This e-mail may contain viruses. Infosys has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Infosys reserves the right to monitor and review the content of all messages sent to or from this e-mail address. Messages sent to or from this e-mail address may be stored on the Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

---

From: "Voigt, Norbert" <[email-masked]>
Date: Tue, 14 Nov 2006 14:09:53 +0100

Norbert.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Freitag, 10. November 2006 00:23
To: [email-masked]
Subject: [ANCP] draft-moustafa-ancp-security-threats-00.txt to WG ID?

should

Regards,

Matthew

---

From: "Peter Arberg" <[email-masked]>
Date: Tue, 14 Nov 2006 21:15:02 -0800

Peter 

> Sent: 9. november 2006 15:23
> To: [email-masked]
> Threats Analysis draft 
> (draft-moustafa-ancp-security-threats-00.txt) should