Subject: [ANCP] OAM-Loopback-Test-Parameters

From: Jakob Heitz <[email-masked]>
Date: Wed, 07 Feb 2007 16:54:40 -0800

In draft-wadhwa-gsmp-l2control-configuration-02,
for OAM-Loopback-Test-Parameters = 0x07, it says:

           Length: 4 bytes

           Value  : two 1 byte numbers (listed in order of most to least 
           significant) 

also:

        The Length field in each TLV contains
        the actual number of bytes in the TLV (not including the padding if
        present).

So, how is the length of "two 1 byte numbers" equal to "4 bytes" ?
Where are the two one byte numbers in the field of 4?
What are the other two bytes to make the total of 4? Are they padding?

Suppose the count is 5 and the timeout is 3.
Is the hex representation like this ?

00 07 00 04 05 03 00 00

or like this?

00 07 00 04 00 00 05 03

or should it be like this?

00 07 00 02 05 03 00 00

or is it something else?

_______________________________________________
ANCP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ancp

---

From: "Kim Hyldgaard \(ST/LMD\)" <[email-masked]>
Date: Thu, 8 Feb 2007 13:52:39 +0100

Hi Jakob,

This is how I interpret it:

00 07 00 04 05 03 00 00

The value itself is defined as 4 bytes, so there's no padding,
eventhough only 1+1 bytes are in use.

One could argue that the specification is a bit vague in the
description of this parameter... :-)

Kim

-----Original Message-----
From: Jakob Heitz [mailto:[email-masked]] 
Sent: 8. februar 2007 01:55
To: [email-masked]
Subject: [ANCP] OAM-Loopback-Test-Parameters

           Length: 4 bytes

           significant) 

also:

        The Length field in each TLV contains
        the actual number of bytes in the TLV (not including the padding
if
        present).

00 07 00 04 05 03 00 00

or like this?

00 07 00 04 00 00 05 03

00 07 00 02 05 03 00 00

or is it something else?

---

From: "Busser, M" <[email-masked]>
Date: Fri, 9 Feb 2007 09:45:40 +0100

Hi Kim, Jakob

This is also what i found in different traces.
If TLV Length is set to 4 (according to draft-wadhwa-gsmp-l2control-configuration-02) i found:
  00 07 00 04 05 03 00 00

Michael

-----Ursprüngliche Nachricht-----
Von: Kim Hyldgaard (ST/LMD) [mailto:[email-masked]] 
Gesendet: Donnerstag, 8. Februar 2007 13:53
An: Jakob Heitz; [email-masked]
Betreff: RE: [ANCP] OAM-Loopback-Test-Parameters

Hi Jakob,

00 07 00 04 05 03 00 00

The value itself is defined as 4 bytes, so there's no padding, eventhough only 1+1 bytes are in use.

One could argue that the specification is a bit vague in the description of this parameter... :-)

Kim

-----Original Message-----
From: Jakob Heitz [mailto:[email-masked]] 
Sent: 8. februar 2007 01:55
To: [email-masked]
Subject: [ANCP] OAM-Loopback-Test-Parameters

           Length: 4 bytes

           significant) 

also:

So, how is the length of "two 1 byte numbers" equal to "4 bytes" ? Where are the two one byte numbers in the field of 4? What are the other two bytes to make the total of 4? Are they padding?

00 07 00 04 05 03 00 00

or like this?

00 07 00 04 00 00 05 03

00 07 00 02 05 03 00 00

or is it something else?

---

From: [email-masked]
Date: Thu, 08 Feb 2007 09:00:35 +0100

Hi,

Jakob Heitz wrote:

>           Value  : two 1 byte numbers (listed in order of most to 
> least           significant)
> also:
>

We support this format.
We also support the "December draft 2005" format where length=8

Regards,
Filip

---

From: [email-masked]
Date: Thu, 08 Feb 2007 09:00:35 +0100

Hi,

We support this format.

Regards,
Filip

---

From: Jakob Heitz <[email-masked]>
Date: Thu, 08 Feb 2007 09:52:18 -0800

Oops, no. This will change the length byte from 4 to 2.
I change my proposal.
I propose to change this:

to this
           Value  : 4 bytes comprising 1 byte Count, followed by
           one byte Timeout, followed by two bytes of zero.

Jakob Heitz wrote:
> In order to make the words less vague and to conform
> to our interpretation of them,
> I propose to change it to 2 bytes and to change
> "listed in order of most to least significant"
> to
> "listed in the order transmitted"
>
> ie, this:
>        o  Type (OAM-Loopback-Test-Parameters = 0x07): Parameters 
> related to           loopback test. This is an optional TLV. If this 
> TLV is not present
>           in the request message, the DSLAM SHOULD use locally determined
>           default values for the test parameters.
>           Length: 4 bytes
>
> to this:
>        o  Type (OAM-Loopback-Test-Parameters = 0x07): Parameters 
> related to           loopback test. This is an optional TLV. If this 
> TLV is not present
>           in the request message, the DSLAM SHOULD use locally determined
>           default values for the test parameters.
>           Length: 2 bytes
>
>           Value  : two 1 byte numbers (listed in the order transmitted)
>
> The last two zero bytes are there due to the padding rule stated
> elsewhere in the document.
>
> Kim Hyldgaard (ST/LMD) wrote:
>> Hi Jakob,
>>
>> One couldFrom [email-masked] Sat Feb 10 08:20:06 2007
Date: Thu, 08 Feb 2007 09:00:35 +0100
From: [email-masked]
To: Jakob Heitz <[email-masked]>
Subject: Re: [ANCP] OAM-Loopback-Test-Parameters
Cc: [email-masked], filip <[email-masked]>

Hi,

We support this format.

Regards,
Filip

---

From: Jakob Heitz <[email-masked]>
Date: Thu, 08 Feb 2007 09:52:18 -0800

to this

Jakob Heitz wrote:
>> From: Jakob Heitz [mailto:[email-masked]] Sent: 8. februar 
>> 2007 01:55
>> To: [email-masked]
>> In draft-wadhwa-gsmp-l2control-configuratioorg; Thu, 08 Feb 2007 12:52:23 -0500
Date: Thu, 08 Feb 2007 09:52:18 -0800
From: Jakob Heitz <[email-masked]>
To: [email-masked]
Subject: Re: [ANCP] OAM-Loopback-Test-Parameters

to this

Jakob Heitz wrote:
>> From: Jakob Heitz [mailto:[email-masked]] Sent: 8. februar 
>> 2007 01:55
>> To: [email-masked]
>> In draft-wadhwa-gsmp-l2control-configuratio argue that the specification is a bit vague in the
>> From: Jakob Heitz [mailto:[email-masked]] Sent: 8. februar 
>> 2007 01:55
>> To: [email-masked]

-- 
Jakob Heitz. x5475. 510-566-2901

---

From: Jakob Heitz <[email-masked]>
Date: Thu, 08 Feb 2007 09:27:13 -0800

ie, this:
        o  Type (OAM-Loopback-Test-Parameters = 0x07): Parameters 
related to 
           loopback test. This is an optional TLV. If this TLV is not 
present
       n-02,

---

From: Jakob Heitz <[email-masked]>
Date: Thu, 08 Feb 2007 09:27:13 -0800

ie, this:

           Length: 4 bytes

to this:

---

From: Jakob Heitz <[email-masked]>
Date: Thu, 08 Feb 2007 09:27:13 -0800

ie, this:

           Length: 4 bytes

to this:

           Length: 2 bytes

-- 
Jakob Heitz.

           Length: 4 bytes

to this:

           Length: 2 bytes

-- 
Jakob Heitz.

           Length: 2 bytes

-- 
Jakob Heitz.

---

From: "Kim Hyldgaard \(ST/LMD\)" <[email-masked]>
Date: Sun, 11 Feb 2007 22:10:58 +0100

Hi Jakob,

This will clearify things a great deal -
I think it's a good suggestion.

Br
Kim 

-----Original Message-----
From: Jakob Heitz [mailto:[email-masked]] 
Sent: 8. februar 2007 18:52
To: [email-masked]
Subject: Re: [ANCP] OAM-Loopback-Test-Parameters

           significant) 

to this

Jakob Heitz wrote:
> In order to make the words less vague and to conform to our 
> interpretation of them, I propose to change it to 2 bytes and to 
> change "listed in order of most to least significant"
> to
>> least

---

From: "Busser, M" <[email-masked]>
Date: Tue, 20 Feb 2007 11:20:49 +0100

Hi all.

I also think, that this is a good suggestion. 

Best Regards; Freundliche Grüße 

Michael Busser
T-Systems Enterprise Services GmbH

-----Ursprüngliche Nachricht-----
Von: Kim Hyldgaard (ST/LMD) [mailto:[email-masked]] 
Gesendet: Sonntag, 11. Februar 2007 22:11
An: Jakob Heitz; [email-masked]
Betreff: RE: [ANCP] OAM-Loopback-Test-Parameters

Hi Jakob,

Br
Kim 

-----Original Message-----
From: Jakob Heitz [mailto:[email-masked]] 
Sent: 8. februar 2007 18:52
To: [email-masked]
Subject: Re: [ANCP] OAM-Loopback-Test-Parameters

           significant) 

to this

Jakob Heitz wrote:
>> Where are the two one byte numbers in the field of 4? What are the 
>> other two bytes to make the total of 4? Are they
padding?