Subject: [ANCP] ANCP MIB

From: Mark Townsley <[email-masked]>
Date: Fri, 14 Mar 2008 08:41:46 -0400

I spoke with Dan this morning. He tells me that there is no need to 
import the entire GSMP MIB if ANCP doesn't need it. There are ways to 
"pick and choose" what ANCP needs from GSMP for the baseline to work. 
So, I'd like to ask Dan to continue to advise us here on what the WG 
needs to do.

Thanks,

- Mark
_______________________________________________
ANCP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ancp

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 14 Mar 2008 13:47:34 +0100

Sure, using MODULE-COMPLIANCE clauses we can point to what groups or
objects in the GSMP MIB an ANCP device needs to support. Can somebody
send me a short mail pointing to what out of the current GSMP MIB is
considered useful and what not, and what is the new information that
needs to be modeled in the new ANCP MIB? 

We can also arrange for a short call next week to chat about this,
talking this week face-to-face would have been better, but I need to run
to the train and plane immediately after the meeting. 

Dan

> -----Original Message-----
> From: Mark Townsley [mailto:[email-masked]] 
> Sent: Friday, March 14, 2008 2:42 PM
> To: [email-masked]; Romascanu, Dan (Dan)
> Subject: ANCP MIB
> 
> 
> I spoke with Dan this morning. He tells me that there is no 
> need to import the entire GSMP MIB if ANCP doesn't need it. 
> There are ways to "pick and choose" what ANCP needs from GSMP 
> for the baseline to work. 
> So, I'd like to ask Dan to continue to advise us here on what 
> the WG needs to do.
> 
> Thanks,
> 
> - Mark
>

---

From: "DE CNODDER Stefaan" <[email-masked]>
Date: Mon, 17 Mar 2008 17:47:19 +0100

Hi Dan,

The ANCP MIB only uses some textual conventions defined in the GSMP MIB.
Only 3 TCs in the GSMP MIB are used in the ANCP MIB: GsmpVersion,
GsmpNameType, and GsmpPartitionIdType.  Nothing else from the GSMP MIB
is used.

The current ANCP MIB is the ANCP MIB for Access Nodes (AN).  This MIB
also defines 2 TCs in addition to the TCs in the GSMP MIB.

These TCs from the GSMP MIB can also be useful for other ANCP MIBs like
the ANCP MIB for Network Access Servers (NASs), which also needs the 2
TCs defined for ANCP MIB for AN.

So would it therefore be better to make a separate MIB module with only
TCs to be imported by all ANCP MIBs, and also put the 3 TCs of the GSMP
MIB in this MIB module, or is it just fine to IMPORT the GSMP MIB as
currently done?

Regards,
Stefaan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Romascanu, Dan (Dan)
Sent: vrijdag 14 maart 2008 13:48
To: Mark Townsley; [email-masked]
Subject: Re: [ANCP] ANCP MIB

Dan

> import the entire GSMP MIB if ANCP doesn't need it.
> There are ways to "pick and choose" what ANCP needs from GSMP for the 
> baseline to work.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 17 Mar 2008 17:56:54 +0100

It is even simpler than I thought. You just need to IMPORT the three TCs
from the GSMP MIB (not the whole MIB, only the TCs). 

Disclaimer - I did not yet fully review the ANCP MIB so other things may
pop up at the time of the review. 

Dan

> From: DE CNODDER Stefaan 
> [mailto:[email-masked]] 
> Sent: Monday, March 17, 2008 6:47 PM
> To: Romascanu, Dan (Dan); Mark Townsley; [email-masked]
> Subject: RE: [ANCP] ANCP MIB
> 
> 
> Hi Dan,
> 
> Only 3 TCs in the GSMP MIB are used in the ANCP MIB: 
> GsmpVersion, GsmpNameType, and GsmpPartitionIdType.  Nothing 
> else from the GSMP MIB is used.
> 
> The current ANCP MIB is the ANCP MIB for Access Nodes (AN).  
> This MIB also defines 2 TCs in addition to the TCs in the GSMP MIB.
> 
> These TCs from the GSMP MIB can also be useful for other ANCP 
> MIBs like the ANCP MIB for Network Access Servers (NASs), 
> which also needs the 2 TCs defined for ANCP MIB for AN.
> 
> So would it therefore be better to make a separate MIB module 
> with only TCs to be imported by all ANCP MIBs, and also put 
> the 3 TCs of the GSMP MIB in this MIB module, or is it just 
> fine to IMPORT the GSMP MIB as currently done?
> 
> Regards,
> Stefaan
> 
> 
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Romascanu, Dan (Dan)
> Sure, using MODULE-COMPLIANCE clauses we can point to what 
> groups or objects in the GSMP MIB an ANCP device needs to 
> support. Can somebody send me a short mail pointing to what 
> out of the current GSMP MIB is considered useful and what 
> not, and what is the new information that needs to be modeled 
> in the new ANCP MIB? 
> 
> We can also arrange for a short call next week to chat about 
> this, talking this week face-to-face would have been better, 
> but I need to run to the train and plane immediately after 
> the meeting. 
> 
> Dan
> 
>

---

From: "DE CNODDER Stefaan" <[email-masked]>
Date: Tue, 18 Mar 2008 18:43:31 +0100

Hi Dan,

Then I think the current MIB is fine because currently we have in the
MIB:

IMPORTS
       GsmpVersion, GsmpNameType, GsmpPartitionIdType
            FROM GSMP-MIB                              -- [RFC3295] 

So that is exactly what you mean what should be done?

Regards,
Stefaan

-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: maandag 17 maart 2008 17:57
To: DE CNODDER Stefaan; Mark Townsley; [email-masked]
Subject: RE: [ANCP] ANCP MIB

Dan

> GsmpVersion, GsmpNameType, and GsmpPartitionIdType.  Nothing else from

> the GSMP MIB is used.
> These TCs from the GSMP MIB can also be useful for other ANCP MIBs 
> like the ANCP MIB for Network Access Servers (NASs), which also needs 
> the 2 TCs defined for ANCP MIB for AN.
> 
> So would it therefore be better to make a separate MIB module with 
> only TCs to be imported by all ANCP MIBs, and also put the 3 TCs of 
> the GSMP MIB in this MIB module, or is it just fine to IMPORT the GSMP

> MIB as currently done?
> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Romascanu, Dan (Dan)
> talking this week face-to-face would have been better, but I need to 
> run to the train and plane immediately after the meeting.
> 
> Dan
> 
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 18 Mar 2008 19:23:30 +0100

This looks fine. 

Again, I did not do a full review of the MIB, so I may discover other
things down the road. 

Dan

> Sent: Tuesday, March 18, 2008 7:44 PM
> It is even simpler than I thought. You just need to IMPORT 
> the three TCs from the GSMP MIB (not the whole MIB, only the TCs). 
> 
> Disclaimer - I did not yet fully review the ANCP MIB so other 
> things may pop up at the time of the review. 
> 
> Dan
> 
> 
>  
> 
> groups or