Subject: [ANCP] Fwd: ANCP Multicast I-D Changes

From: Francois Le Faucheur IMAP <[email-masked]>
Date: Wed, 24 Jun 2009 15:20:52 +0200

Folks,

I am drafting text to incorporate something based on the proposal  
below to support query by NAS about active multicast flows on AN.
Now would be a good time to provide comments on this topic if you have  
any.
I will propose using Message-Type 0x97 (since the earlier number are  
now allocated)

Aniruddha,
I don't quite see the role of the "Active-Flow-Req TLV" since it is  
always present in all "Request" messages from NAS and doe snot convey  
actual information. I am guessing this may have been included to  
distinguish the Request from the Response, but I think this can be  
easily inferred by the direction NAS-->AN vs AN-->NAS.
Somewhat similar to what is already done for the Delegated Bandwidth  
Query Request/Response of ancp-mc-extensions-01.
Is this TLV really needed?

Thanks

Francois

>
>
> Begin forwarded message:
>
>> From: "BOCCI Matthew" <[email-masked]>
>> Date: 31 March 2009 17:51:37 CEDT
>> To: "Aniruddha A (anira)" <[email-masked]>, <[email-masked]>
>> Subject: Re: [ANCP] ANCP messages for Multicast query and report
>>
>> This was discussed in San Francisco, and there seemed to be  
>> agreement in
>> principle, but we would appreciate feedback on this proposal on the  
>> list
>> from the WG.
>>
>> Matthew
>>
>>
>>> -----Original Message-----
>>> From: [email-masked] [mailto:[email-masked]] On
>>> Behalf Of Aniruddha A (anira)
>>> Sent: 06 March 2009 11:00
>>> To: [email-masked]
>>> Subject: Re: [ANCP] ANCP messages for Multicast query and report
>>>
>>>
>>>
>>> Hi All,
>>>
>>> I propose the following new ANCP message to get all ports on
>>> AN for a given Multicast flow (S,G) :
>>>
>>> - Request message from NAS to AN to get all the ports where a
>>> multicast
>>>  flow is active.
>>>  The Mandatory Active-Flow-Req TLV is followed by the Flow-ID TLV
>>>  which identifies which flow we are interested in.
>>>
>>>      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |        Type (0x88-0C)         |            
>>> Length              |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | Vers  |  Sub  |MsgType=0x92   | Res   |         
>>> Code           |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | Partition ID  |            Transaction  
>>> Identifier             |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |I|      SubMessage Number      |            
>>> Length              |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |     ActiveFlowReq TLV =0x103  |    ActiveFlow- 
>>> Length          |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |  Mcast Flow ID TLV = 0x107    |S|   Mcast Flow ID- 
>>> Length      |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | AddrFamily    | EncType       |  Mcast  
>>> source                 |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | AddrFamily    | EncType       |  Mcast  
>>> group                  |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>
>>> - Report message from AN to NAS to send all the ports for a
>>> particular flow.
>>>  The report uses a new TLV - 0x108
>>>
>>>      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |        Type (0x88-0C)         |            
>>> Length              |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | Vers  |  Sub  |MsgType=0x92    | Res   |         
>>> Code          |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | Partition ID  |            Transaction  
>>> Identifier             |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |I|      SubMessage Number      |            
>>> Length              |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |ActiveFlow Target Ports = 0x108|    ActiveFlow- 
>>> Length          |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |  Mcast Flow ID TLV = 0x107    |S|   Mcast Flow ID- 
>>> Length      |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | AddrFamily    | EncType       |  Mcast  
>>> source                 |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | AddrFamily    | EncType       |  Mcast  
>>> group                  |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>
>>> Followed by one or more Target-Type TLV which identifies the port
>>>
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |     Target-type-TLV=0x1000    |   Target-TLV- 
>>> Length           |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |            ID type            |   Circuit ID  
>>> Length           |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>      
>>> |                                                               |
>>>     ~                            Client- 
>>> ID                          ~
>>>      
>>> |                                                               |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>
>>>
>>> --
>>> Regards,
>>> Aniruddha. A
>>>
>>> -----Original Message-----
>>> From: Maglione Roberta [mailto:[email-masked]]
>>> Sent: Thursday, February 05, 2009 9:19 PM
>>> To: Aniruddha A (anira); [email-masked]
>>> Subject: RE: ANCP messages for Multicast query and report
>>>
>>> Hi Aniruddha,
>>>        your proposal seems interesting to me, but I have a comment:
>>> section 3.4.3 of the ancp-framework draft defines 3 different
>>> types of reporting function:
>>> - report for one Access Port;
>>> - report for one multicast flow;
>>> - a global report for one Access Node.
>>>
>>> If my understanding is correct, your proposal addresses 1 and
>>> 3, do you plan to extend it to cover also case 2?
>>>
>>> Thanks and best regards.
>>> Roberta
>>>
>>> -----Original Message-----
>>> From: [email-masked] [mailto:[email-masked]] On
>>> Behalf Of Aniruddha A (anira)
>>> Sent: Monday, January 12, 2009 6:46 PM
>>> To: [email-masked]
>>> Subject: [ANCP] ANCP messages for Multicast query and report
>>>
>>> Hi all,
>>>
>>> In the ANCP multicast extensions, there has to be a way For
>>> the NAS to query the AN for the state of active multicast flows on  
>>> it.
>>>
>>> We propose the following 2 new messages for this purpose:
>>> -  Active-Flow Request
>>> -  Active-Flow Report
>>>
>>> The query from the NAS can be for all flows on the AN or
>>> flows active on a single port. Message Type 0x92 is used.
>>>
>>> Description and message formats:
>>>
>>>  Active-Flow Request Message
>>>
>>>   The Active Flow Request message is sent by the NAS to the AN to
>>>   request multicast flow status on the AN.  The payload contains the
>>>   following TLVs:
>>>
>>>   o  The Active-Flow-Req TLV (0x103)
>>>      A Mandatory TLV.
>>>
>>>   o  The Target Type TLV.
>>>      Optional TLV, if present, request is for a single port.
>>>
>>>   On receiving the Active Flow Request message, the AN MUST respond
>>>   with the Active Flow Report containing the requested information  
>>> if
>>>   the Multicast capability has been negotiated.  The format of the
>>>   message is shown below:
>>>
>>>      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |        Type (0x88-0C)         |            
>>> Length              |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | Vers  |  Sub  |MsgType=0x92   | Res   |         
>>> Code           |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | Partition ID  |            Transaction  
>>> Identifier             |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |I|      SubMessage Number      |            
>>> Length              |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |     ActiveFlowReq TLV =0x103  |    ActiveFlow- 
>>> Length          |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |     Target-type-TLV=0x1000    |   Target-TLV- 
>>> Length           |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |            ID type            |   Circuit ID  
>>> Length           |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>      
>>> |                                                               |
>>>     ~                            Client- 
>>> ID                          ~
>>>      
>>> |                                                               |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>
>>>                                 Figure 1
>>>
>>>  Active-Flow Report Message
>>>
>>>   The Active Flow Report message is sent from the AN to the NAS in
>>>   response to the Active Flow Request message.  Active Flow Report
>>>   message contains information on the requested multicast flows.   
>>> The
>>>   report can be for a single port, or all ports depending on
>>> the Target
>>>   Type in the request.
>>>
>>>   o Single Port Report
>>>
>>>   If the Active Flow Request had a specific port (the presence of a
>>>   Target Type TLV), the response has the following format:
>>>
>>>      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |        Type (0x88-0C)         |            
>>> Length              |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | Vers  |  Sub  |MsgType=0x92    | Res   |         
>>> Code          |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | Partition ID  |            Transaction  
>>> Identifier             |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |I|      SubMessage Number      |            
>>> Length              |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | ActiveFlowPortEntryTLV =0x105 |    ActiveFlow- 
>>> Length          |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |     Target-type-TLV=0x1000    |   Target-TLV- 
>>> Length           |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |            ID type            |   Circuit ID  
>>> Length           |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>      
>>> |                                                               |
>>>     ~                            Client- 
>>> ID                          ~
>>>      
>>> |                                                               |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>
>>>                                 Figure 2
>>>
>>>   Followed by the Multicast Flow ID TLVs (0x107), one for
>>> each flow on
>>>   the port.  The format of the Flow ID TLV is:
>>>
>>>      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |  Mcast Flow ID TLV = 0x107    |S|  Mcast Flow ID- 
>>> Length       |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | AddrFamily    | EncType       |  Mcast  
>>> source                 |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | AddrFamily    | EncType       |  Mcast  
>>> group                  |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>
>>>                                 Figure 3
>>>
>>>   S is the source flag, if set, multicast source address MUST be
>>>   present (SSM).
>>>
>>>  o  Report for all ports
>>>
>>>   If the Active Flow Request did not specify a specific port
>>> (no Target
>>>   Type TLV), the response will have the following format:
>>>
>>>      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |        Type (0x88-0C)         |            
>>> Length              |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | Vers  |  Sub  |MsgType=0x92   | Res   |         
>>> Code           |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | Partition ID  |            Transaction  
>>> Identifier             |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |I|      SubMessage Number      |            
>>> Length              |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |ActiveFlowMcastEntryTLV =0x104 |    ActiveFlow- 
>>> Length          |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     |  Mcast Flow ID TLV = 0x107    |S|   Mcast Flow ID- 
>>> Length      |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | AddrFamily    | EncType       |  Mcast  
>>> source                 |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>     | AddrFamily    | EncType       |  Mcast  
>>> group                  |
>>>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
>>> +-+
>>>
>>>                                 Figure 4
>>>
>>>   Followed by the Target Type TLV.
>>>
>>>   A Multicast Entry TLV (0x104) determines the (flow, port),
>>> therefore
>>>   it will have a Flow ID TLV and a Target-Type TLV as its
>>> sub TLVs, and
>>>   there will be as many Multicast Entry TLVs as the number
>>> of flows on
>>>   the AN.
>>>
>>> We have an implementation running with these message types.
>>> --
>>> Regards,
>>> Aniruddha. A
>>> _______________________________________________
>>> ANCP mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/ancp
>>>
>>> Questo messaggio e i suoi allegati sono indirizzati
>>> esclusivamente alle persone indicate. La diffusione, copia o
>>> qualsiasi altra azione derivante dalla conoscenza di queste
>>> informazioni sono rigorosamente vietate. Qualora abbiate
>>> ricevuto questo documento per errore siete cortesemente
>>> pregati di darne immediata comunicazione al mittente e di
>>> provvedere alla sua distruzione, Grazie.
>>>
>>> This e-mail and any attachments is confidential and may
>>> contain privileged information intended for the addressee(s) only.
>>> Dissemination, copying, printing or use by anybody else is
>>> unauthorised.
>>> If you are not the intended recipient, please delete this
>>> message and any attachments and advise the sender by return
>>> e-mail, Thanks.
>>>
>>> _______________________________________________
>>> ANCP mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/ancp
>>>
>> _______________________________________________
>> ANCP mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ancp
>

---

From: "Aniruddha A (anira)" <[email-masked]>
Date: Thu, 25 Jun 2009 16:20:17 +0530

Hi Francois,
 
Active-Flow-Req TLV can be omitted, but then,  what will be the message
format for global report (for AN as a whole) ?
Message with header only ?
My initial proposal was to make Target-TLV optional, so in global report
case, there will be Active-Flow-Req TLV only.
 
--
Regards,
Aniruddha. A

________________________________

From: Francois Le Faucheur (flefauch) 
Sent: Wednesday, June 24, 2009 6:51 PM
To: [email-masked]; Aniruddha A (anira)
Cc: Francois Le Faucheur (flefauch); Maglione Roberta;
[email-masked] Taylor; Sanjay Wadhwa
Subject: Fwd: ANCP Multicast I-D Changes

Folks,

I am drafting text to incorporate something based on the proposal below
to support query by NAS about active multicast flows on AN.
Now would be a good time to provide comments on this topic if you have
any.
I will propose using Message-Type 0x97 (since the earlier number are now
allocated)

Aniruddha,

Thanks 

Francois

	Begin forwarded message:

		From: "BOCCI Matthew" <[email-masked]>
		Date: 31 March 2009 17:51:37 CEDT
		To: "Aniruddha A (anira)" <[email-masked]>,
<[email-masked]>
		Subject: Re: [ANCP] ANCP messages for Multicast query
and report

		This was discussed in San Francisco, and there seemed to
be agreement in
		principle, but we would appreciate feedback on this
proposal on the list
		from the WG.
		
		Matthew

			-----Original Message-----

			From: [email-masked]
[mailto:[email-masked]] On 

			To: [email-masked]

			Subject: Re: [ANCP] ANCP messages for Multicast
query and report

			Hi All,

			I propose the following new ANCP message to get
all ports on 

			- Request message from NAS to AN to get all the
ports where a 

			multicast

			 flow is active.

			 The Mandatory Active-Flow-Req TLV is followed
by the Flow-ID TLV

			 which identifies which flow we are interested
in.

			     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
2 3 4 5 6 7 8 9 0 1

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |        Type (0x88-0C)         |
Length              |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |I|      SubMessage Number      |
Length              |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |     ActiveFlowReq TLV =0x103  |
ActiveFlow-Length          |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |  Mcast Flow ID TLV = 0x107    |S|   Mcast
Flow ID-Length      |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			- Report message from AN to NAS to send all the
ports for a 

			particular flow.

			     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
2 3 4 5 6 7 8 9 0 1

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |        Type (0x88-0C)         |
Length              |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |I|      SubMessage Number      |
Length              |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |ActiveFlow Target Ports = 0x108|
ActiveFlow-Length          |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |  Mcast Flow ID TLV = 0x107    |S|   Mcast
Flow ID-Length      |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			Followed by one or more Target-Type TLV which
identifies the port

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |     Target-type-TLV=0x1000    |
Target-TLV-Length           |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |            ID type            |   Circuit
ID Length           |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |
|

			    ~                            Client-ID
~

			    |
|

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			--

			Regards,

			Aniruddha. A

			-----Original Message-----

			From: Maglione Roberta
[mailto:[email-masked]]

			Subject: RE: ANCP messages for Multicast query
and report

			Hi Aniruddha,

			       your proposal seems interesting to me,
but I have a comment:

			section 3.4.3 of the ancp-framework draft
defines 3 different 

			If my understanding is correct, your proposal
addresses 1 and 

			3, do you plan to extend it to cover also case
2?

			Thanks and best regards.

			Roberta

			-----Original Message-----

			From: [email-masked]
[mailto:[email-masked]] On 

			To: [email-masked]

			Subject: [ANCP] ANCP messages for Multicast
query and report

			Hi all,

			In the ANCP multicast extensions, there has to
be a way For 

			the NAS to query the AN for the state of active
multicast flows on it.

			We propose the following 2 new messages for this
purpose:

			-  Active-Flow Request

			-  Active-Flow Report

			The query from the NAS can be for all flows on
the AN or 

			flows active on a single port. Message Type 0x92
is used.

			  The Active Flow Request message is sent by the
NAS to the AN to

			  request multicast flow status on the AN.  The
payload contains the

			  following TLVs:

			     A Mandatory TLV.

			  o  The Target Type TLV.

			     Optional TLV, if present, request is for a
single port.

			  On receiving the Active Flow Request message,
the AN MUST respond

			  with the Active Flow Report containing the
requested information if

			  the Multicast capability has been negotiated.
The format of the

			  message is shown below:

			     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
2 3 4 5 6 7 8 9 0 1

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |        Type (0x88-0C)         |
Length              |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |I|      SubMessage Number      |
Length              |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |     ActiveFlowReq TLV =0x103  |
ActiveFlow-Length          |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |     Target-type-TLV=0x1000    |
Target-TLV-Length           |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |            ID type            |   Circuit
ID Length           |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |
|

			    ~                            Client-ID
~

			    |
|

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			                                Figure 1

			  The Active Flow Report message is sent from
the AN to the NAS in

			  response to the Active Flow Request message.
Active Flow Report

			  message contains information on the requested
multicast flows.  The

			  report can be for a single port, or all ports
depending on 

			the Target

			  Type in the request.

			  o Single Port Report

			  If the Active Flow Request had a specific port
(the presence of a

			  Target Type TLV), the response has the
following format:

			     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
2 3 4 5 6 7 8 9 0 1

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |        Type (0x88-0C)         |
Length              |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |I|      SubMessage Number      |
Length              |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    | ActiveFlowPortEntryTLV =0x105 |
ActiveFlow-Length          |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |     Target-type-TLV=0x1000    |
Target-TLV-Length           |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |            ID type            |   Circuit
ID Length           |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |
|

			    ~                            Client-ID
~

			    |
|

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			                                Figure 2

			  Followed by the Multicast Flow ID TLVs
(0x107), one for 

			each flow on

			     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
2 3 4 5 6 7 8 9 0 1

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |  Mcast Flow ID TLV = 0x107    |S|  Mcast
Flow ID-Length       |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			                                Figure 3

			  S is the source flag, if set, multicast source
address MUST be

			  present (SSM).

			 o  Report for all ports

			  If the Active Flow Request did not specify a
specific port 

			(no Target

			  Type TLV), the response will have the
following format:

			     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
2 3 4 5 6 7 8 9 0 1

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |        Type (0x88-0C)         |
Length              |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |I|      SubMessage Number      |
Length              |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |ActiveFlowMcastEntryTLV =0x104 |
ActiveFlow-Length          |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			    |  Mcast Flow ID TLV = 0x107    |S|   Mcast
Flow ID-Length      |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

	
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

			                                Figure 4

			  A Multicast Entry TLV (0x104) determines the
(flow, port), 

			therefore

			  it will have a Flow ID TLV and a Target-Type
TLV as its 

			sub TLVs, and

			  there will be as many Multicast Entry TLVs as
the number 

			of flows on

			  the AN.

			We have an implementation running with these
message types.

			--

			Regards,

			Aniruddha. A

			ANCP mailing list

			[email-masked]

			Questo messaggio e i suoi allegati sono
indirizzati 

			esclusivamente alle persone indicate. La
diffusione, copia o 

			qualsiasi altra azione derivante dalla
conoscenza di queste 

			informazioni sono rigorosamente vietate. Qualora
abbiate 

			ricevuto questo documento per errore siete
cortesemente 

			pregati di darne immediata comunicazione al
mittente e di 

			This e-mail and any attachments is confidential
and may 

			contain privileged information intended for the
addressee(s) only.

			Dissemination, copying, printing or use by
anybody else is 

			unauthorised.

			If you are not the intended recipient, please
delete this 

			message and any attachments and advise the
sender by return 

			e-mail, Thanks.

			ANCP mailing list

			[email-masked]

---

From: Francois Le Faucheur IMAP <[email-masked]>
Date: Thu, 25 Jun 2009 13:54:54 +0200

Hi,

On 25 Jun 2009, at 12:50, Aniruddha A (anira) wrote:

> Hi Francois,
>
> Active-Flow-Req TLV can be omitted, but then,  what will be the  
> message format for global report (for AN as a whole) ?

yes.
The TLVs effectively act as "scope limiters" ie it can limit scope of  
the query to one (or multiple) port, or to one or multiple flows. If  
absent, the query scope is not limited (ie query all flows on all  
ports).

Is that OK?

Francois

> My initial proposal was to make Target-TLV optional, so in global  
> report case, there will be Active-Flow-Req TLV only.
>
> --
> Regards,
> Aniruddha. A
>
>
> Cc: Francois Le Faucheur (flefauch); Maglione Roberta; [email-masked] 
>  Taylor; Sanjay Wadhwa
> Now would be a good time to provide comments on this topic if you  
> have any.
> always present in all "Request" messages from NAS and doe snot  
> convey actual information. I am guessing this may have been included  
> to distinguish the Request from the Response, but I think this can  
> be easily inferred by the direction NAS-->AN vs AN-->NAS.
>>> principle, but we would appreciate feedback on this proposal on  
>>> the list
>>> from the WG.
>>>
>>> Matthew
>>>
>>>
>>>> the NAS to query the AN for the state of active multicast flows  
>>>> on it.
>>>>
>>>>   with the Active Flow Report containing the requested  
>>>> information if

---

From: "Aniruddha A (anira)" <[email-masked]>
Date: Thu, 25 Jun 2009 23:16:38 +0530

Hi Francois,
 
Ok.
 
--
Regards,
Aniruddha. A

From: Francois Le Faucheur (flefauch) 
Sent: Thursday, June 25, 2009 5:25 PM
To: Aniruddha A (anira)
Cc: Francois Le Faucheur (flefauch); [email-masked]; Maglione Roberta;
[email-masked]; Sanjay Wadhwa; Shridhar Rao (shrirao)
Subject: Re: ANCP Multicast I-D Changes

Hi, 

	Hi Francois,

yes.

Is that OK?

Francois

	My initial proposal was to make Target-TLV optional, so in
global report case, there will be Active-Flow-Req TLV only.
	 
	--
	Regards,
	Aniruddha. A

	Folks,

	I am drafting text to incorporate something based on the
proposal below to support query by NAS about active multicast flows on
AN.
	Now would be a good time to provide comments on this topic if
you have any.
	I will propose using Message-Type 0x97 (since the earlier number
are now allocated)

	Aniruddha,
	I don't quite see the role of the "Active-Flow-Req TLV" since it
is always present in all "Request" messages from NAS and doe snot convey
actual information. I am guessing this may have been included to
distinguish the Request from the Response, but I think this can be
easily inferred by the direction NAS-->AN vs AN-->NAS.
	Somewhat similar to what is already done for the Delegated
Bandwidth Query Request/Response of ancp-mc-extensions-01.
	Is this TLV really needed?

	Thanks 

	Francois

		Begin forwarded message:

			From: "BOCCI Matthew"
<[email-masked]>
			Date: 31 March 2009 17:51:37 CEDT
			To: "Aniruddha A (anira)" <[email-masked]>,
<[email-masked]>
			Subject: Re: [ANCP] ANCP messages for Multicast
query and report

			This was discussed in San Francisco, and there
seemed to be agreement in
			principle, but we would appreciate feedback on
this proposal on the list
			from the WG.
			
			Matthew

				-----Original Message-----

				To: [email-masked]

				Subject: Re: [ANCP] ANCP messages for
Multicast query and report

				Hi All,

				I propose the following new ANCP message
to get all ports on 

				- Request message from NAS to AN to get
all the ports where a 

				multicast

				 flow is active.

				 The Mandatory Active-Flow-Req TLV is
followed by the Flow-ID TLV

				 which identifies which flow we are
interested in.

				     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7
8 9 0 1 2 3 4 5 6 7 8 9 0 1

				    |        Type (0x88-0C)         |
Length              |

				    | Vers  |  Sub  |MsgType=0x92   |
Res   |        Code           |

				    | Partition ID  |
Transaction Identifier             |

				    |I|      SubMessage Number      |
Length              |

	

				    |  Mcast Flow ID TLV = 0x107    |S|
Mcast Flow ID-Length      |

				    | AddrFamily    | EncType       |
Mcast source                 |

				    | AddrFamily    | EncType       |
Mcast group                  |

				- Report message from AN to NAS to send
all the ports for a 

				particular flow.

				     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7
8 9 0 1 2 3 4 5 6 7 8 9 0 1

				    |        Type (0x88-0C)         |
Length              |

				    | Vers  |  Sub  |MsgType=0x92    |
Res   |        Code          |

				    | Partition ID  |
Transaction Identifier             |

				    |I|      SubMessage Number      |
Length              |

	

				    |  Mcast Flow ID TLV = 0x107    |S|
Mcast Flow ID-Length      |

				    | AddrFamily    | EncType       |
Mcast source                 |

				    | AddrFamily    | EncType       |
Mcast group                  |

				Followed by one or more Target-Type TLV
which identifies the port

	

				    |            ID type            |
Circuit ID Length           |

				    |
|

				    ~
Client-ID                          ~

				    |
|

				--

				Regards,

				Aniruddha. A

				-----Original Message-----

				From: Maglione Roberta

				Sent: Thursday, February 05, 2009 9:19
PM

				Subject: RE: ANCP messages for Multicast
query and report

				Hi Aniruddha,

				       your proposal seems interesting
to me, but I have a comment:

				section 3.4.3 of the ancp-framework
draft defines 3 different 

				If my understanding is correct, your
proposal addresses 1 and 

				3, do you plan to extend it to cover
also case 2?

				Thanks and best regards.

				Roberta

				-----Original Message-----

				To: [email-masked]

				Subject: [ANCP] ANCP messages for
Multicast query and report

				Hi all,

				In the ANCP multicast extensions, there
has to be a way For 

				the NAS to query the AN for the state of
active multicast flows on it.

				We propose the following 2 new messages
for this purpose:

				-  Active-Flow Request

				-  Active-Flow Report

				The query from the NAS can be for all
flows on the AN or 

				flows active on a single port. Message
Type 0x92 is used.

				  The Active Flow Request message is
sent by the NAS to the AN to

				  request multicast flow status on the
AN.  The payload contains the

				  following TLVs:

				     A Mandatory TLV.

				  o  The Target Type TLV.

				     Optional TLV, if present, request
is for a single port.

				  On receiving the Active Flow Request
message, the AN MUST respond

				  with the Active Flow Report containing
the requested information if

				  the Multicast capability has been
negotiated.  The format of the

				  message is shown below:

				     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7
8 9 0 1 2 3 4 5 6 7 8 9 0 1

				    |        Type (0x88-0C)         |
Length              |

				    | Vers  |  Sub  |MsgType=0x92   |
Res   |        Code           |

				    | Partition ID  |
Transaction Identifier             |

				    |I|      SubMessage Number      |
Length              |

	

	

				    |            ID type            |
Circuit ID Length           |

				    |
|

				    ~
Client-ID                          ~

				    |
|

				                                Figure 1

				  The Active Flow Report message is sent
from the AN to the NAS in

				  response to the Active Flow Request
message.  Active Flow Report

				  message contains information on the
requested multicast flows.  The

				  report can be for a single port, or
all ports depending on 

				the Target

				  Type in the request.

				  o Single Port Report

				  If the Active Flow Request had a
specific port (the presence of a

				     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7
8 9 0 1 2 3 4 5 6 7 8 9 0 1

				    |        Type (0x88-0C)         |
Length              |

				    | Vers  |  Sub  |MsgType=0x92    |
Res   |        Code          |

				    | Partition ID  |
Transaction Identifier             |

				    |I|      SubMessage Number      |
Length              |

	

	

				    |            ID type            |
Circuit ID Length           |

				    |
|

				    ~
Client-ID                          ~

				    |
|

				                                Figure 2

				each flow on

				  the port.  The format of the Flow ID
TLV is:

				     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7
8 9 0 1 2 3 4 5 6 7 8 9 0 1

				    |  Mcast Flow ID TLV = 0x107    |S|
Mcast Flow ID-Length       |

				    | AddrFamily    | EncType       |
Mcast source                 |

				    | AddrFamily    | EncType       |
Mcast group                  |

				                                Figure 3

				  S is the source flag, if set,
multicast source address MUST be

				  present (SSM).

				 o  Report for all ports

				  If the Active Flow Request did not
specify a specific port 

				(no Target

				     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7
8 9 0 1 2 3 4 5 6 7 8 9 0 1

				    |        Type (0x88-0C)         |
Length              |

				    | Vers  |  Sub  |MsgType=0x92   |
Res   |        Code           |

				    | Partition ID  |
Transaction Identifier             |

				    |I|      SubMessage Number      |
Length              |

	

				    |  Mcast Flow ID TLV = 0x107    |S|
Mcast Flow ID-Length      |

				    | AddrFamily    | EncType       |
Mcast source                 |

				    | AddrFamily    | EncType       |
Mcast group                  |

				                                Figure 4

				  A Multicast Entry TLV (0x104)
determines the (flow, port), 

				therefore

				  it will have a Flow ID TLV and a
Target-Type TLV as its 

				sub TLVs, and

				  there will be as many Multicast Entry
TLVs as the number 

				of flows on

				  the AN.

				We have an implementation running with
these message types.

				--

				Regards,

				Aniruddha. A

				ANCP mailing list

				[email-masked]

				informazioni sono rigorosamente vietate.
Qualora abbiate 

				ricevuto questo documento per errore
siete cortesemente 

				pregati di darne immediata comunicazione
al mittente e di 

				This e-mail and any attachments is
confidential and may 

				contain privileged information intended
for the addressee(s) only.

				Dissemination, copying, printing or use
by anybody else is 

				unauthorised.

				If you are not the intended recipient,
please delete this 

				message and any attachments and advise
the sender by return 

				e-mail, Thanks.

				ANCP mailing list

				[email-masked]