Subject: [ANCP] Topology discovery question

From: Sidd Aanand <[email-masked]>
Date: Tue, 23 Jun 2009 10:06:10 -0400

Hi All,
 
Section 5.4.2 of the v05 ANCP draft says:
Also, when the ANCP session first comes up, the DSLAM SHOULD transmit 
a PORT UP message to the NAS for each line that is up. 
Is the expectation that each PORT UP message is sent as a separate GSMP
message or is the DSLAM expected to batch a set of PORT UP messages in a
single GSMP message? If it is the latter, how does the message convey
how many port up messages are contained within the single GSMP message?
 
Thanks,
Sidd

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Wed, 24 Jun 2009 14:42:50 +0200

Hi,
 
well, each Port-up should be sent in a separate message, however note
that since ANCP runs on TCP this doesn't actually matter much.
 
Cheers,
Woj.

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Sidd Aanand
	Sent: 23 June 2009 16:06
	To: [email-masked]
	Cc: Keith A. Monahan; Mark Dyga
	Subject: [ANCP] Topology discovery question

	Hi All,

	Also, when the ANCP session first comes up, the DSLAM SHOULD
transmit 
	a PORT UP message to the NAS for each line that is up. 
	Is the expectation that each PORT UP message is sent as a
separate GSMP message or is the DSLAM expected to batch a set of PORT UP
messages in a single GSMP message? If it is the latter, how does the
message convey how many port up messages are contained within the single
GSMP message?
	 
	Thanks,
	Sidd

---

From: <[email-masked]>
Date: Thu, 25 Jun 2009 13:12:15 +0200

Woj, Sidd,
 
I agree.
 
In any case a GSMP message is sent if a DSLAM comes up. 
ANCP reports port status allways which means three different stati: up,
down (idle), down (silent).
 
Regards
Thomas

  _____  

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von
Wojciech Dec (wdec)
Gesendet: Mittwoch, 24. Juni 2009 14:43
An: Sidd Aanand; [email-masked]
Cc: Keith A. Monahan; Mark Dyga
Betreff: Re: [ANCP] Topology discovery question

Hi,

Cheers,
Woj.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sidd Aanand
Sent: 23 June 2009 16:06
To: [email-masked]
Cc: Keith A. Monahan; Mark Dyga
Subject: [ANCP] Topology discovery question

Hi All,

 
Thanks,
Sidd