Subject: Re: [ANCP] Can we modify IANA registries set up for GSMPv3?

From: Wojciech Dec <[email-masked]>
Date: Thu, 01 Jul 2010 12:54:20 +0200

I am asking whether renaming the existing GSMP code point as ANCP,
effectively deprecating GSMP, is something that can be done?

-Woj.

On 01/07/2010 12:27, "Ralph Droms (rdroms)" <[email-masked]> wrote:

> Woj - I'm not clear on the course of action you are suggesting.  Do you mean
> to declare GSMP deprecated, assign all of the registries to ANCP and assign
> codepoints from those registries as if GSMP never existed?
> 
> - Ralph
> 
> On Jun 30, 2010, at 12:06 PM 6/30/10, Wojciech Dec wrote:
> 
>> > Adding Ralph...
>> >
>> > The core issue looks like being that ANCP still rides on the GSMP protocol
>> > code point, even though it is incompatible.
>> > I'm not sure if there is a precedent for a re-branding of a protocol type,
>> > but if that is an option, along with declaring GSMP deprecated, then we
>> > could have an alternative. (Note: Previous searches into finding
>> operational
>> > implementations of GSMP have not found any, but we will never know for
>> sure.
>> > That said, it's highly unlikely that the two will meet.)
>> >
>> > -Woj.
>> >
>> >
>> > On 30/06/2010 15:31, "Tom Taylor" <[email-masked]> wrote:
>> >
>>> >> This issue may affect other registries, but I realized it when I was
>>> looking
>>> >> at
>>> >> the reallocation of bits between Result and Code compared with GSMPv3.
>>> I'm
>>> >> sure
>>> >> it's legitimate to add code points to a registry for an older protocol,
>>> but
>>> >> this
>>> >> reallocation of bits means that the limits on the possible values change.
>>> Can
>>> >> we
>>> >> do that (implying that we obsolete GSMPv3 itself), or must we establish
>>> new
>>> >> parallel registries for ANCP?
>>> >>
>>> >> There is an intermediate solution where we continue to use GSMPv3
>>> registries
>>> >> but
>>> >> segregate the codepoints falling outside the limits for one protocol or
>>> the
>>> >> other, noting that they apply only to one protocol. Thus in the Result
>>> value
>>> >> registry we would add a note that any values greater than 15 apply to
>>> GSMPv3
>>> >> only, while in the Code registry, values greater than 255 apply to ANCP
>>> only.
>>> >> This sounds like the best solution, though I had to talk myself around to
>>> it.
>>> >>
>>> >> Tom Taylor
>>> >> _______________________________________________
>>> >> ANCP mailing list
>>> >> [email-masked]
>>> >> https://www.ietf.org/mailman/listinfo/ancp
>> >
> 
>

---

From: Ralph Droms <[email-masked]>
Date: Thu, 1 Jul 2010 07:53:49 -0400

I don't know the answer.  If you'll write up a short request, with a few sentences describing how we got the current situation, I'll take it to IANA and the IESG.

- Ralph

On Jul 1, 2010, at 6:54 AM 7/1/10, Wojciech Dec wrote:

> I am asking whether renaming the existing GSMP code point as ANCP, effectively deprecating GSMP, is something that can be done?
> 
> -Woj.
> 
> 
>> Woj - I'm not clear on the course of action you are suggesting.  Do you mean to declare GSMP deprecated, assign all of the registries to ANCP and assign codepoints from those registries as if GSMP never existed?
>> 
>> - Ralph
>> 
>>> could have an alternative. (Note: Previous searches into finding operational
>>> implementations of GSMP have not found any, but we will never know for sure.
>>>> This issue may affect other registries, but I realized it when I was looking
>>>> at
>>>> the reallocation of bits between Result and Code compared with GSMPv3. I'm
>>>> sure
>>>> it's legitimate to add code points to a registry for an older protocol, but
>>>> this
>>>> reallocation of bits means that the limits on the possible values change. Can
>>>> we
>>>> do that (implying that we obsolete GSMPv3 itself), or must we establish new
>>>> There is an intermediate solution where we continue to use GSMPv3 registries
>>>> but
>>>> segregate the codepoints falling outside the limits for one protocol or the
>>>> other, noting that they apply only to one protocol. Thus in the Result value
>>>> registry we would add a note that any values greater than 15 apply to GSMPv3
>>>> only, while in the Code registry, values greater than 255 apply to ANCP only.
>>>> This sounds like the best solution, though I had to talk myself around to it.
>>>> 
>>>> Tom Taylor

---

From: Ralph Droms <[email-masked]>
Date: Thu, 1 Jul 2010 06:27:57 -0400

- Ralph