Subject: [ANCP] ANCP version/sub-version registries

From: Tom Taylor <[email-masked]>
Date: Sat, 03 Jul 2010 16:42:08 -0400

The base protocol draft currently has two separate registries for ANCP version 
and ANCP sub-version. I'm not sure what these are good for, separately. My own 
suggestion is for a combined version.sub-version registry, the use of which 
would be to cross-reference version.sub-version values to their defining 
references. The first two entries would be:

Version      Reference

   3.1       Pre-standard
   3.2       RFC XXXX

Comments?

Tom Taylor

---

From: <[email-masked]>
Date: Wed, 7 Jul 2010 11:59:53 +0200

Basic intention for separate Pre-standard and RFC was based on discussion at Stockholm meeting last year regarding migration pre RFC implementation to RFC-standard based implementation. 
The reason for that separation was to have an identifier for distinguish protocol versions for migration.

For given reason at that point the working group already prepared the ground for alternative 1 (parallel registry).

Keeping in mind that GSMPv3 defined one byte for version and ancp defined two half bytes (version.subversion) I support a combined registry.

This provides three stages for that version field:

	0 3 GSMPv3 (according RFC3292, page 111; there is only one byte, no half bytes for version field = version)

	3 1 Pre-Standard (protocol draft 00...10; two half bytes for version field = version.subversion)

	3 2 RFC (two half byts for version field = version.subversion)

>From my point of view "0 3" is already registred as GSMPv3. For official registry "3 2" is needed for register ANCP. "3 1" is needed temporarily for migration of existing implementations which may also be registered too.

Regards
Thomas Haag

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Tom Taylor
Gesendet: Samstag, 3. Juli 2010 22:42
An: [email-masked]
Betreff: [ANCP] ANCP version/sub-version registries

Version      Reference

   3.1       Pre-standard
   3.2       RFC XXXX

Comments?

Tom Taylor

_______________________________________________
ANCP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ancp