Subject: Re: [Anima] Tomorrow's ANIMA meeting cancelled

From: Dean Bogdanovic <[email-masked]>
Date: Wed, 1 Oct 2014 14:52:44 +0000

Michael,

If people will be there, at the meeting, I would like to discuss following part of the charter

The main goal of the ANIMA WG is therefore to develop common infrastructure
components for distributed functions. The infrastructure should be capable of
providing the following services to those distributed functions:
o a common way to identify nodes
o a common security model
o a discovery mechanism
o a negotiation mechanism to enable closed-loop interaction
o a secure and logically separated communications channel
o a consistent autonomic management model

The first three bullets are good, especially the 3rd bullet about discovery mechanisms, but what I don't understand is what do you mean by closed-loop interaction. There is a need for control loop between autonomic agents, as well between autonomic agent and device where the autonomic agent sits. And then, how is it different from secure and logically separated communication channel. I see lot of overlap between those two bullets.

Where suitable protocols, models or methods exist, they will be preferred over creating new ones.

I agree with the above statement 100% :-)

It is preferred that autonomic functions would co-exist with traditional methods
of management and configuration, and the initial focus would be on
self-configuration.

This statement is confusing. From a device perspective, there is a set of instructions coming on how to change the state. Are those instructions derived locally or are sent from a remote station is not important for configuration of the device. What requirements are needed for autonomic agent to communicate the configuration instructions to device is  important.

Dean

On Oct 1, 2014, at 2:41 AM, Michael Behringer (mbehring) <[email-masked]<mailto:[email-masked]>> wrote:

Several folks can't make the ANIMA call tomorrow, we decided therefore to cancel the "official" call.

I leave the webex in place, in case some folks still want meet.

Michael

_______________________________________________
Anima mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/anima

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 02 Oct 2014 08:54:50 +1300

On 02/10/2014 03:52, Dean Bogdanovic wrote:
> The main goal of the ANIMA WG is therefore to develop common
> infrastructure components for distributed functions. The
> infrastructure should be capable of providing the following
> services to those distributed functions: 
> 
> 
> The first three bullets are good, especially the 3rd bullet
> about discovery mechanisms, but what I don't understand is
> what do you mean by closed-loop interaction. There is a need
> for control loop between autonomic agents, as well between
> autonomic agent and device where the autonomic agent sits.

Yes. And that (in a discrete mechanism rather than an analogue
servo-mechanism) means iterative exchange of messages until an
ending condition is reached. That is negotiation (which is
slightly more general than state synchronization as mentioned by
Rene).

However, it would be more logical to re-order those two bullets:

because of course it is that secure channel that will carry the
negotiation messages.

> And then, how is it different from secure and logically
> separated communication channel. I see lot of overlap between
> those two bullets.

I think that is clarified by putting them in the right order.

> I agree with the above statement 100% :-)

We all do. But after surveying available protocols I am not
too optimistic.

> 
> It is preferred that autonomic functions would co-exist with
> traditional methods of management and configuration, and the
> initial focus would be on self-configuration.
> 
> This statement is confusing. From a device perspective, there
> is a set of instructions coming on how to change the state.
> Are those instructions derived locally or are sent from a
> remote station is not important for configuration of the
> device. What requirements are needed for autonomic agent to
> communicate the configuration instructions to device is
> important.

I find your statement confusing too. Maybe we should just delete
"and the initial focus would be on self-configuration."?

Regards
    Brian
> 
> Dean
> 
> On Oct 1, 2014, at 2:41 AM, Michael Behringer (mbehring)
> <[email-masked]<mailto:[email-masked]>> wrote:
> 
> _______________________________________________ Anima mailing
> list [email-masked]<mailto:[email-masked]> 
> ------------------------------------------------------------------------
> 
> 
> _______________________________________________ Anima mailing
> list [email-masked]

---

From: Dean Bogdanovic <[email-masked]>
Date: Wed, 1 Oct 2014 20:59:17 +0000

> "and the initial focus would be on self-configuration."?

So what do you mean by self-configuration? There is a question where and how the configuration is created and you need an interface to communicate the configuration to the device. Question I have: does anima have any special requirements for the interface through which device is configured? This is something that is should be listed as an area to explore. Autonomic agent can decide based on certain conditions that device state has to be changed and it can create set of instructions to change the state of the device. How will that state change communicate to the device is a question too?

Dean

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 02 Oct 2014 10:48:57 +1300

> On Oct 1, 2014, at 3:54 PM, Brian E Carpenter <[email-masked]> wrote:

<snip>

> So what do you mean by self-configuration? There is a question where and how the configuration is created and you need an interface to communicate the configuration to the device. Question I have:…

Two comments on that:

1. Re the charter, we don't have to list every topic we will
discuss.

2. Re the question you ask: Yes, it certainly needs to be
discussed. My personal feeling is that we should declare it out
of scope for the generic mechanisms, and in scope for each
individual AN application. It really seems like something that
might need to be different in each case, expecially when there
are pre-existing mechanisms that might be used within a
sub-system (an example would be prefix delegation).

    Brian