Subject: [Anima] How it all fits together

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Fri, 14 Aug 2015 10:45:13 +0000

Sheng, 

In Prague you had two main comments about the reference model, 1) to reduce what's not in the current charter and 2) to add a section on "how it all fits together". 

I've now mused for a while on how to best do this, and here are my thoughts, for discussion, before I write it all up in detail. 

The best way to represent how it all fits together seems to be to describe how a node interacts with other nodes throughout its lifetime. So, my current thinking is to document the two cases: 

a) the behaviour of a new element (high level, mainly pointing to the bootstrap draft for details)
b) the behaviour of a domain node. 

This way, we can document the flow, which really contains all of the architectural components mentioned in the reference model. For example: 

- node wakes up, has a domain certificate. It doesn't keep network state, therefore: 
- it uses GRASP on the data plane to discover its neighbors
- it authenticates the neighbors and builds an ACP tunnel to them. 
- it installs its address in the ACP, and starts routing
- to discover services in the autonomic domain, it uses GRASP inside the ACP.
- Intent is distributed inside the ACP, see draft... 
- etc, etc, (including later on how ASAs interact). 

This is what you had in mind, right? 

If so, I think this partly exists already, in draft-behringer-anima-autonomic-control-plane, section 5. (not complete, so it needs stuff added such as the first bullet, the ASAs, etc.)

My proposal: The general parts of section 5 in draft-behringer-anima-autonomic-control-plane should probably move into the reference model, and only ACP specifics should remain in draft-behringer-anima-autonomic-control-plane. So, essentially, move section 5 of the ACP draft into the reference model, and refine that. 

Does that meet expectations? Is it the right way forward? 

Michael

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 14 Aug 2015 11:20:57 +0000

Hi, Michael,

Thanks for considering my comments and response. Please see my replies in lines.

>-----Original Message-----
>From: Michael Behringer (mbehring) [mailto:[email-masked]]
>
>Sheng,
>
>In Prague you had two main comments about the reference model, 1) to
>reduce what's not in the current charter and 2) to add a section on "how it all
>fits together".
>
>I've now mused for a while on how to best do this, and here are my thoughts,
>for discussion, before I write it all up in detail.
>
>The best way to represent how it all fits together seems to be to describe how
>a node interacts with other nodes throughout its lifetime. So, my current
>thinking is to document the two cases:
>
>This way, we can document the flow, which really contains all of the
>architectural components mentioned in the reference model. For example:
>

That's what I suggested.

>If so, I think this partly exists already, in
>draft-behringer-anima-autonomic-control-plane, section 5. (not complete, so
>it needs stuff added such as the first bullet, the ASAs, etc.)

Agreed.

>My proposal: The general parts of section 5 in
>draft-behringer-anima-autonomic-control-plane should probably move into
>the reference model, and only ACP specifics should remain in
>draft-behringer-anima-autonomic-control-plane. So, essentially, move
>section 5 of the ACP draft into the reference model, and refine that.

Just re-read the section 5, currently, it is looks like a mix of design consideration, general for autonomic and procedure of establishing ACP. May I suggest to dedicate this section for the procedure of establishing ACP? In another word, I think section 5.6, 5.9 and maybe part of section 5.7 should be replaced somewhere else. The procedure should be integrity here. Then, some pieces of the procedure of establishing ACP may be emphasized in an abstracted way in reference model, the section described how they fits together.

By the way, it may not be a good idea to submit a 00 version with any major changes. It would be better if you could submit draft-ietf-anima-autonomic-control-plane-00 as it is in -03, then make modifications in -01 version and represent them to the WG.

Best regards,

Sheng

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Fri, 14 Aug 2015 11:30:20 +0000

Inline... 

[...]
> >This is what you had in mind, right?

Ack - thanks.
 
[...]
> Just re-read the section 5, currently, it is looks like a mix of design
> consideration, general for autonomic and procedure of establishing ACP.
> May I suggest to dedicate this section for the procedure of establishing
> ACP? 

Yes, that is what I meant. 

> In another word, I think section 5.6, 5.9 and maybe part of section 5.7
> should be replaced somewhere else. The procedure should be integrity
> here. 

What do you mean with the last sentence? But, it sounds like we're in sync. 

> Then, some pieces of the procedure of establishing ACP may be
> emphasized in an abstracted way in reference model, the section described
> how they fits together.

Right. 

> By the way, it may not be a good idea to submit a 00 version with any major
> changes. It would be better if you could submit draft-ietf-anima-autonomic-
> control-plane-00 as it is in -03, then make modifications in -01 version and
> represent them to the WG.

OK, then I start by re-submitting the current draft (there were some minor edits only so far) with the new name first. No problem. 

Michael