Subject: [Anima] Updated Naming section in Reference Model draft

From: "Liubing (Leo)" <[email-masked]>
Date: Fri, 18 Mar 2016 13:56:05 +0000

Hi Michael and all,

I've prepared some update texts for the naming section.

Due to previous discussion, I think it's good to take the specific naming semantics/pattern out of the RM document. Then the RM document only keeps some general consideration of naming.
If me or somebody want to propose a specific naming mechanism, we can always write a dedicated draft for discussion.

Following is the new text. It is basically the previous Section 4.1.1 with minor revision.

"4.1 Naming
Inside a domain, each autonomic device should be assigned
a name.

Basic considerations for forming the names is as the following:
- Uniqueness
The names must not collide within one autonomic domain. It is acceptable that the names in different domains collide, since they could be distinguished by domains.
- Consistency
The devices' naming should follow the same pattern within a domain.
- Autonomous
The names must be assigned automatically without any human intervene.
It is recommended that the names are generated by the autonomic nodes themselves.

Specific naming convention is out of the scope of this document."

Any comments?

Best regards,
Bing

> -----Original Message-----
> From: Michael Behringer (mbehring) [mailto:[email-masked]]
> Sent: Thursday, March 17, 2016 12:36 AM
> To: Liubing (Leo)
> Subject: Naming section
> 
> Hi Bing,
> 
> It's time to update drafts... ;-)   You did the naming section in the ANIMA
> reference doc.
> 
> We decided to take out all the semantics, and "uplevel" the naming
> discussion significantly, without specifying a particular naming convention.
> 
> Did you have time to think about this section? Can you provide updated text?
> Monday is the deadline... If you have updated text, I suggest to copy the
> mailing list, to enable discussion.
> 
> Thoughts?
> 
> Michael

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Fri, 18 Mar 2016 16:19:26 +0000

I've added this text in the draft for now. We need to discuss this in more detail, in Buenos Aires. 

Thanks Bing!

Other co-authors: I'm compiling the next version of the reference draft, there are quite a few contributions still outstanding...

Michael

> From: Liubing (Leo) [mailto:[email-masked]]
> Sent: 18 March 2016 14:56
> To: Michael Behringer (mbehring) <[email-masked]>
> Cc: [email-masked]
> Subject: Updated Naming section in Reference Model draft
> 
> Hi Michael and all,
> 
> Due to previous discussion, I think it's good to take the specific naming
> semantics/pattern out of the RM document. Then the RM document only
> keeps some general consideration of naming.
> If me or somebody want to propose a specific naming mechanism, we can
> always write a dedicated draft for discussion.
> 
> Inside a domain, each autonomic device should be assigned a name.
> 
> The names must not collide within one autonomic domain. It is acceptable
> that the names in different domains collide, since they could be distinguished
> by domains.
> - Consistency
> > Monday is the deadline... If you have updated text, I suggest to copy
> > the mailing list, to enable discussion.
> >
> > Thoughts?
> >
> > Michael