Subject: Re: [Anima] 7.2 Specific ASAs [was Reference Model Issues]

From: Michael Richardson <[email-masked]>
Date: Wed, 06 Apr 2016 15:37:07 -0400

Brian E Carpenter <[email-masked]> wrote:
    >>> On 25/03/2016 06:52, Michael Behringer (mbehring) wrote:
    >>> ...
    >>>> 7.2 Specific ASAs [for the Enrolment Process]
    >>>> - should explain MUST implement
    >>>
    >>> And that they MUST be present in all nodes by default. In particular the
    >>> Proxy ASA MUST discover whether it needs to be active (see discussion
    >>> yesterday). I suppose the same applies to the Registrar ASA but possibly that
    >>> needs to be configured "on" by the NOC?
    >>
    >> Yes, agree, that's what I meant. Switching the proxy ASA off if not needed is an optimisation, in my view. (Also, once enrolled, you can switch off the enrolment ASA of course).
    >>
    >> The registrar is effectively a policy definition point (PDP), thus MUST be set up manually.

    > Yes, that seems reasonable in a "professionally managed network" which is the
    > Anima target. I wouldn't exclude an election process in a completely unmanaged
    > network, but that's out of scope here.

We probably want only one active registrar, and we might want to have a
passive backup in bigger networks.  Setting those up is a manual process, but
the election would still be useful.  The machines likely are not co-located
on the same LAN, so mechanisms like VRRP won't work.

If GRASP can do elections across the ACP, then we should use that.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 7 Apr 2016 07:53:38 +1200

> If GRASP can do elections across the ACP, then we should use that.

I'm sure we could model such an election as a negotiation (I'm imagining two
ASAs called "Clinton" and "Cruz" as I write). But of course this won't
work prior to ACP formation, so there's another bootstrapping situation.

    Brian