Subject: [Anima] GRASP, discovery, and roles

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 7 Apr 2016 16:59:18 -0400

I appear to have missed something in the descriptions.

On the one hand, it is very clear that ASAs need to discover certain 
kinds of special entities.  Registrars are one example.  Prefix 
delegators or usage coordinators are others.

On the other hand, when I look at the GRASP discovery mechanisms, what I 
see is text that ASAs discover peer ASAs who support a given objective.

So how does this work if what I (as an ASA) need to discover is a 
resource coordinator.  That is not an objective I offer.  So how do I 
extablish communication with the right entity/

Or am I completely misreading the specs?

Yours,
Joel

---

From: "Liubing (Leo)" <[email-masked]>
Date: Thu, 7 Apr 2016 21:48:47 +0000

Hi Joel,

> -----Original Message-----
> From: Anima [mailto:[email-masked]] On Behalf Of Joel M. Halpern
> Sent: Thursday, April 07, 2016 5:59 PM
> To: Anima WG
> Subject: [Anima] GRASP, discovery, and roles
> 
> On the one hand, it is very clear that ASAs need to discover certain kinds of
> special entities.  Registrars are one example.  Prefix delegators or usage
> coordinators are others.
> 
> On the other hand, when I look at the GRASP discovery mechanisms, what I see
> is text that ASAs discover peer ASAs who support a given objective.
> 
> So how does this work if what I (as an ASA) need to discover is a resource
> coordinator.  That is not an objective I offer.  So how do I extablish
> communication with the right entity/

[Bing] My understanding: we could discover "resource coordination" as an objective. If some entity is right the "coordinator", then it will response to that discovery. GRASP discovery only cares about whether some entities could provide "resource coordination" function, and doesn't care about the entity's role.

In my mind, "objective" is more regarding to function; and "role" more regarding to the device's character. So, they are two different dimensions. But the "objective" might have a finer-granularity than "Role", which means, one entity of a specific Role, might support multiple objectives.

Brian: please shout out if I'm not sync with you:)

Best regards,
Bing

> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 7 Apr 2016 17:57:23 -0400

Given that I register in order to participate in teh discovery, it seems 
that I could just as easily end up "discovering" another participant 
when what I need is the coordinator.
Am I mis-reading it?

Yours,
Joel

---

From: "Liubing (Leo)" <[email-masked]>
Date: Thu, 7 Apr 2016 22:16:26 +0000

> From: Joel M. Halpern [mailto:[email-masked]]
> Sent: Thursday, April 07, 2016 6:57 PM
> To: Liubing (Leo); Anima WG
> Cc: Brian E Carpenter
> Subject: Re: [Anima] GRASP, discovery, and roles
> 
> Given that I register in order to participate in teh discovery, it seems that I
> could just as easily end up "discovering" another participant when what I need
> is the coordinator.

[Bing] In terms of GRASP terminology, what you need is the "coordination function/service", and the one who response you, implies it is a "coordinator" or whatever role which could provide identical coordination function/service as the "coordinator". So, just don't worry about the one who response you is "another" guy who is not qualified to serve you. 

Did I capture your concern correctly?

B.R.
Bing

> >> On the other hand, when I look at the GRASP discovery mechanisms,
> >> what I see is text that ASAs discover peer ASAs who support a given
> objective.
> >>
> > [Bing] My understanding: we could discover "resource coordination" as an
> objective. If some entity is right the "coordinator", then it will response to that
> discovery. GRASP discovery only cares about whether some entities could
> provide "resource coordination" function, and doesn't care about the entity's
> role.
> >
> > In my mind, "objective" is more regarding to function; and "role" more
> regarding to the device's character. So, they are two different dimensions. But
> the "objective" might have a finer-granularity than "Role", which means, one
> entity of a specific Role, might support multiple objectives.
> >

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 7 Apr 2016 18:25:08 -0400

If I could just ignore some responses, and be sure I would get the other 
responses, that would be a way to solve the problem.  But as far as I 
understand GRASP< that isn't what happens.  My discovery might prompt 
several answers, but along any given branch it stops when it hits any 
responder, even if they are just another participant.

Yours,
Joel

---

From: "Liubing (Leo)" <[email-masked]>
Date: Thu, 7 Apr 2016 22:38:12 +0000

> Sent: Thursday, April 07, 2016 7:25 PM
> several answers, but along any given branch it stops when it hits any responder,
> even if they are just another participant.

[Bing] This is the "multiple responses" open issue we used to discuss. 
GRASP will not stop receiving other responses, (actually it just can't), according to discussion in last ietf, people tended to handle the multiple responses to ASA, who will decide to use which discovered result. I think we'll need to clearly specify the behavior in the API document.

B.R.
Bing

> >> Given that I register in order to participate in teh discovery, it
> >> seems that I could just as easily end up "discovering" another
> >> participant when what I need is the coordinator.
> >
> > [Bing] In terms of GRASP terminology, what you need is the "coordination
> function/service", and the one who response you, implies it is a "coordinator"
> or whatever role which could provide identical coordination function/service as
> the "coordinator". So, just don't worry about the one who response you is
> "another" guy who is not qualified to serve you.
> >
> >>>> On the one hand, it is very clear that ASAs need to discover
> >>>> certain kinds of special entities.  Registrars are one example.
> >>>> Prefix delegators or usage coordinators are others.
> >>>>
> >>>> resource coordinator.  That is not an objective I offer.  So how do
> >>>> I extablish communication with the right entity/
> >>>
> >> objective. If some entity is right the "coordinator", then it will
> >> response to that discovery. GRASP discovery only cares about whether
> >> some entities could provide "resource coordination" function, and
> >> doesn't care about the entity's role.
> >>>
> >> regarding to the device's character. So, they are two different
> >> dimensions. But the "objective" might have a finer-granularity than
> >> "Role", which means, one entity of a specific Role, might support multiple
> objectives.
> >>>

---

From: John Strassner <[email-masked]>
Date: Fri, 8 Apr 2016 15:55:29 -0700

Two points.

First, a "role" is **just** a fancy name for a responsibility. It abstracts
the entity performing the role from the role itself. This way, we can
keep information about the entity separate from the functions that the
entity performs, and better scale the system.

That being said, I don't understand how this will work. Clearly, defining
a rigid classification system is bad. I could imagine a metadata-driven
system, wherein "interests" are advertised by nodes, and a semantic
network, based on some formal type of logic, could be used to reason
about which interests are useful for a given node.

I've done this before, love researching this, but this is NOT easy.

regards,
John

On Thu, Apr 7, 2016 at 2:48 PM, Liubing (Leo) <[email-masked]>
wrote:

> kinds of
> see
> resource
> objective. If some entity is right the "coordinator", then it will response
> to that discovery. GRASP discovery only cares about whether some entities
> could provide "resource coordination" function, and doesn't care about the
> entity's role.
>
> regarding to the device's character. So, they are two different dimensions.
> But the "objective" might have a finer-granularity than "Role", which
> means, one entity of a specific Role, might support multiple objectives.
>

-- 
regards,
John

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 9 Apr 2016 11:45:03 +1200

> this is NOT easy

Indeed. That's why I think this discussion comes later...

Regards
   Brian

---

From: John Strassner <[email-masked]>
Date: Fri, 8 Apr 2016 17:16:00 -0700

Fair enough; I just want to know if my guess at how this operates is
correct. :-)

regards,
John

On Fri, Apr 8, 2016 at 4:45 PM, Brian E Carpenter <
[email-masked]> wrote:

> response
> dimensions.

-- 
regards,
John