Subject: [Anima] Comment to your presentation on draft-ciavaglia-anima-knowledge-00

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Thu, 7 Apr 2016 20:22:13 +0000

Laurent, 

Since we couldn't finish the discussion online, here my comment on the list: 

You won't be surprised to hear that I'm asking also here for the smallest, simplest possible first step. To get us all on the same page, and understand the requirement better. 

So I was thinking, we actually have a good use case for this: draft-ietf-anima-prefix-management could probably do with a small knowledge plane; in its simplest case, an operator wants to know the current status of assignments across the entire network; before a node requests more address space from another node, it could ask a knowledge plane where the biggest free pools are. 

Disassembling this a bit: questions to the knowledge plane could be: 
- "which node has the biggest free address pool?"
- "what's the average / max / min usage of local pools across the network?"
- "how much address space is still available?" (not quite the same as above, I think)
- etc. 

Would that make a nice use case to understand the knowledge plane better? 

Michael

---

From: Jéferson Campos Nobre <[email-masked]>
Date: Sat, 09 Apr 2016 02:50:28 +0000

Hi Laurent.
Just to add up the question I was asking when you became offline...
It is more a clarification: are you proposing to use different data
models/protocols in ANIMA than the ones used in other WGs? Or you are
describing the requirements for the data models/protocols to be used in
ANIMA? I got confused.
Thanks.
Jéferson

Em qui, 7 de abr de 2016 às 17:22, Michael Behringer (mbehring) <
[email-masked]> escreveu:

> You won't be surprised to hear that I'm asking also here for the smallest,
> simplest possible first step. To get us all on the same page, and
> understand the requirement better.
>
> So I was thinking, we actually have a good use case for this:
> draft-ietf-anima-prefix-management could probably do with a small knowledge
> plane; in its simplest case, an operator wants to know the current status
> of assignments across the entire network; before a node requests more
> address space from another node, it could ask a knowledge plane where the
> biggest free pools are.
>
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>