Subject: Re: [Anima] Intent "beginning to end"

From: "jmh.direct" <[email-masked]>
Date: Thu, 21 Apr 2016 20:23:38 -0400

From what I have seen, at the business level the needed information is spread across multiple sources.  So if, as diagrammed, Intent starts at the human, then something needs to compile it together.
Yours,Joel

Sent via the Samsung Galaxy S® 6, an AT&T 4G LTE smartphone-------- Original message --------From: Brian E Carpenter <[email-masked]> Date: 4/21/2016  5:02 PM  (GMT-05:00) To: John Strassner <[email-masked]>, "Joel M. Halpern" <[email-masked]> Cc: Anima WG <[email-masked]>, "Michael Behringer (mbehring)" <[email-masked]> Subject: Re: [Anima] Intent "beginning to end" 
On 22/04/2016 08:46, John Strassner wrote:
...
>    3) I believe that interpreting/compiling intent will be HARD, and
>        that understanding intent will be MUCH HARDER. Why does
>        every autonomic node need to do that?

Surely that depends on the detailed design of Intent syntax and semantics,
by which I mean the Intent that is distributed to all autonomic nodes
and hence to all ASAs. Given that we know it needs to be interpreted by
individual ASAs, shouldn't we design it to be readily interpreted?
(If there is some more abstract format of Intent that is *not* distributed
everywhere, that's fine, but it's not our concern for designing Anima.
We have to worry about the concrete Intent that's sent to all AN nodes.)

An ASA that manages resource X, which involves negotiation with other
ASAs also managing resource X, and setting configuration for itself and
perhaps for subsidiary non-autonomic devices using resource X, will need
to interpret statements about settings the affect resource X, as well as
statements about generic settings. So they need to be readily interpretable.

    Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 22 Apr 2016 13:12:45 +1200

> From what I have seen, at the business level the needed information is spread across multiple sources.  So if, as diagrammed, Intent starts at the human, then something needs to compile it together.

Certainly. So in fact we are talking about two different things.

Intent (H): what humans generate, that must be sanity checked, reconciled, and compiled into
Intent (A): a consistent form of Intent that can be interpreted by an algorithm in any autonomic node.

I believe that Anima should focus on Intent (A).

   Brian

---

From: John Strassner <[email-masked]>
Date: Thu, 21 Apr 2016 18:25:33 -0700

> by an algorithm in any autonomic node.

When I read draft draft-du-anima-an-intent-03, I got the impression
that both Intent (H) and Intent (A) were worked on in the policy
system. Even if this is not the case, clearly nodes that are not
fully autonomic will not be interested in adding additional
resources to understand and act on intent.

My problem is that I do not believe that we can define a mechanism
to specify Intent (A) in a vendor-independent, interoperable manner.
Hence, I see no reason why **every** mode MUST be able to ingest
and act on intent.

regards,
John

On Thu, Apr 21, 2016 at 6:12 PM, Brian E Carpenter <
[email-masked]> wrote:

> > From what I have seen, at the business level the needed information is
> spread across multiple sources.  So if, as diagrammed, Intent starts at the
> human, then something needs to compile it together.
>
> > Sent via the Samsung Galaxy S® 6, an AT&T 4G LTE smartphone--------
> Original message --------From: Brian E Carpenter <
> [email-masked]> Date: 4/21/2016  5:02 PM  (GMT-05:00) To:
> John Strassner <[email-masked]>, "Joel M. Halpern" <
> [email-masked]> Cc: Anima WG <[email-masked]>, "Michael Behringer
> (mbehring)" <[email-masked]> Subject: Re: [Anima] Intent "beginning
> to end"

-- 
regards,
John