Subject: [Anima] Intent per ASA or per AF?

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Fri, 18 Nov 2016 01:53:02 +0000

One question that just came up: Should Intent be designed per ASA or per AF? 

My suggestion previously was to segment Intent into sections per Autonomic Functions. 

Example: Intent for the bootstrap function could be: 
- allow bootstrapping new devices only during maintenance window

For such Intent, action could be taken on the registrar (one ASA of the AF), or on the proxy (another ASA of the same AF). 

It seems to me an author of an AF might like all ASAs of his AF to know about the Intent, because the proxy may also take actions. 

Michael

---

From: Laurent Ciavaglia <[email-masked]>
Date: Fri, 18 Nov 2016 03:04:28 +0100

Michael,

Definitely not designed per ASA.

As mentioned at the mic, in draft-peloso 
(https://datatracker.ietf.org/doc/draft-peloso-anima-autonomic-function), 
we've proposed format for "intent" at the AF level.
Please note, that once "resolved" the AF intent will exist (be 
translated) in the instances of the AF (the ASAs) as AF instance 
descriptor. This is ASA-level/specific information.

Best regards, Laurent.

On 18/11/2016 02:53, Michael Behringer (mbehring) wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>

-- 

Laurent Ciavaglia

Nokia, Bell Labs

+33 160 402 636

route de Villejust - Nozay, France

linkedin.com/in/laurent.ciavaglia

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 18 Nov 2016 15:14:38 +1300

> It seems to me an author of an AF might like all ASAs of his AF to know about the Intent, because the proxy may also take actions.

Yes, I think so. Again we hit the question of granularity and whether this is actually
Intent, but a policy like that might be added to Intent-for-BRSKI, and both registrars
and proxies need to know it.

So I'd expect we will need intent to be in sections that are per-function (and we will
therefore need a method of guaranteeing that function names are unique). In fact we get
a more general result if we simply say that intent is divided in sections that have
unique labels; then it's easy to support intent per-function, per-objective, or
even per-geography if we want.

    Brian

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Fri, 18 Nov 2016 02:24:03 +0000

Agree, Laurent. Then let’s nail this down in the Intent draft: “Intent is defined per Autonomic Function”.
Michael
From: Laurent Ciavaglia [mailto:[email-masked]]
Sent: 18 November 2016 11:04
To: Michael Behringer (mbehring) <[email-masked]>; [email-masked]
Subject: Re: [Anima] Intent per ASA or per AF?

Michael,

As mentioned at the mic, in draft-peloso (https://datatracker.ietf.org/doc/draft-peloso-anima-autonomic-function), we've proposed format for "intent" at the AF level.
Please note, that once "resolved" the AF intent will exist (be translated) in the instances of the AF (the ASAs) as AF instance descriptor. This is ASA-level/specific information.

Best regards, Laurent.

Michael

Anima mailing list

[email-masked]<mailto:[email-masked]>

--

Laurent Ciavaglia
Nokia, Bell Labs

+33 160 402 636

---

From: <[email-masked]>
Date: Thu, 17 Nov 2016 21:46:38 -0500

+1 for defining it per autonomic function.  This is also a way to potentially “scope” intent distribution.  

--- Alex

From: Anima [mailto:[email-masked]] On Behalf Of Michael Behringer (mbehring)
Sent: Thursday, November 17, 2016 9:24 PM
To: Laurent Ciavaglia <[email-masked]>; [email-masked]
Subject: Re: [Anima] Intent per ASA or per AF?

Michael

From: Laurent Ciavaglia [mailto:[email-masked]] 
Sent: 18 November 2016 11:04
To: Michael Behringer (mbehring) <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: Re: [Anima] Intent per ASA or per AF?

Michael,

Best regards, Laurent.

 

 
 
Michael
 
_______________________________________________
Anima mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/anima

-- 

Laurent Ciavaglia

Nokia, Bell Labs

+33 160 402 636

---

From: Michael Richardson <[email-masked]>
Date: Sun, 20 Nov 2016 15:41:37 +0900

> Example: Intent for the bootstrap function could be: - allow
    > bootstrapping new devices only during maintenance window

I agree that this is a useful policy.

I come back to such pseudo-time-based Intents to wonder how they work.
We discussed this a year ago... and never, I thought, reached consensus.

I think that the answer to that would tell me how Intents should be
partitioned.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Sun, 20 Nov 2016 17:36:29 +0000

> -----Original Message-----
> From: Michael Richardson [mailto:[email-masked]]
> Sent: 20 November 2016 07:42
> To: Michael Behringer (mbehring) <[email-masked]>
> Cc: [email-masked]

Not sure I completely understand, and not sure that's what I wanted to say. My point was that a policy like above could be implemented on the proxy as well as the registrar. Maybe in some cases on both. So, segmenting per function seems more useful than by ASA. 

Michael

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 21 Nov 2016 08:08:23 +1300

> Not sure I completely understand, and not sure that's what I wanted to say. My point was that a policy like above could be implemented on the proxy as well as the registrar. Maybe in some cases on…

This conversation strengthens my conviction that we should leave this as
flexible as possible, because the requirements will change with experience.
In other words, label each segment of Intent - and the label may well be
the name of an autonomic function - but do not make rules about the labels.

That way there is flexibility for the future.

     Brian

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Mon, 21 Nov 2016 17:19:32 +0000

> In other words, label each segment of Intent - and the label may well be the
> name of an autonomic function - but do not make rules about the labels.
> 

In principle, I agree, we want to be as flexible as possible. But the ANI MUST be able to segment Intent into components. So I think we can only permit "segment types" that the ANI understands and knows how to handle. 

In that, I think we can only define "AN-function" and "AN-ASA" at this moment, at least there is no other clear option right now. My point, we do need some rules. 

Michael