Subject: Re: [Anima] GRASP issue 55: Could discovery be performed over TCP?

From: Michael Richardson <[email-masked]>
Date: Sat, 12 Nov 2016 11:51:39 +0900

Toerless Eckert <[email-masked]> wrote:
    > I am confused about the reason for this discussion. It seems you are
    > trying to figure out how to minimize the impact of the insecure
    > multicast piece of GRASP, but in the context of ANIMA this question
    > would be irrelevant, because we are not doing any insecure GRASP in
    > BRSKY or ACP with current draft - the use of insecure GRASP was removed
    > in those drafts before Berlin because of the majority of the bootstrap
    > teams choice for DNS-SD/mDNS.

In ANIMA, agreed.

    > Do you see some IoT context where you would use insecure GRASP instead
    > of DNS-SD/mDNS, eg: in some IoT context ?

In 6tisch-secure-join, I specified a GRASP query (over TCP) between Join
Assistant and Registrar.  It would be "secure" in the sense that it would not
be exposed to traffic from new nodes, only existing nodes.

The time sequence diagram I envisioned was:
   JA         Int-Nodes         Registrar
    ---disc----->   -----disc----->
    <-----------  TCP M_END--------  new  TCP
    ------  QUERY ---M_REQ_NEG---->  same TCP
    <-----  REPLY ---M_END---------  same TCP

However, I think that we will have to replace the GRASP query with something
else, maybe just a CoAP request, as the TCP for GRASP is rather too much for
some.. To be discussed.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 12 Nov 2016 16:11:28 +1300

So, I guess you've arrived... below:
> else, maybe just a CoAP request, as the TCP for GRASP is rather too much for

I agree, GRASP is designed for autonomic nodes and I don't think we should promote
it for other usage at the moment.

   Brian

---

From: Michael Richardson <[email-masked]>
Date: Sun, 13 Nov 2016 16:31:10 +0900

Brian E Carpenter <[email-masked]> wrote:
    >> However, I think that we will have to replace the GRASP query with
    >> something else, maybe just a CoAP request, as the TCP for GRASP is
    >> rather too much for some.. To be discussed.

    > I agree, GRASP is designed for autonomic nodes and I don't think we
    > should promote it for other usage at the moment.

GRASP over CoAP would work, but still, it might not be right.

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 14 Nov 2016 08:05:16 +1300

> GRASP over CoAP would work, but still, it might not be right.

Exactly, so let's get the basic work finished first.

    Brian