Subject: [Anima] Need WG input: Alexy Melnikov's suggestion on GRASP

From: Brian E Carpenter <[email-masked]>
Date: Mon, 29 May 2017 13:38:35 +1200

Hi,

I have started the process of going through IESG comments on the GRASP draft.
Where something is editorial or obviously non-controversial, I will not
ask for input. But I do need input on some things, and here is the first.
Please answer quickly; no answer will be taken to mean that you don't care...

Alexy wrote:
>>      uri-locator = [O_URI_LOCATOR, text]
>>
>> I suggest inclusion of optional transport protocol here to match other
>> locators and to follow best practices for not encoding transport
>> information in URIs.

That would become
uri-locator = [O_URI_LOCATOR, text, transport-proto, port-number]

Opinions? Objections?

    Brian

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 28 May 2017 21:48:23 -0400

If, as he says, that is the best current practice then lets go for it.
Joel

On 5/28/17 9:38 PM, Brian E Carpenter wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>

---

From: Michael Richardson <[email-masked]>
Date: Mon, 29 May 2017 14:49:04 -0400

Brian E Carpenter <[email-masked]> wrote:
    > I have started the process of going through IESG comments on the GRASP
    > draft.  Where something is editorial or obviously non-controversial, I
    > will not ask for input. But I do need input on some things, and here is
    > the first.  Please answer quickly; no answer will be taken to mean that
    > you don't care...

    >>> I suggest inclusion of optional transport protocol here to match
    >>> other locators and to follow best practices for not encoding
    >>> transport information in URIs.

    > That would become uri-locator = [O_URI_LOCATOR, text, transport-proto,
    > port-number]

    > Opinions? Objections?

If the resource is really at  https://example.com:9943/my/path

what would text, transport-proto be?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 30 May 2017 08:40:12 +1200

> what would text, transport-proto be?

"https://example.com:9943/my/path", Null, Null perhaps.

Also of course see the thread on Adam Roach's comment.

    Brian

---

From: Michael Richardson <[email-masked]>
Date: Tue, 30 May 2017 12:37:08 -0400

Brian E Carpenter <[email-masked]> wrote:

    >> Brian E Carpenter <[email-masked]> wrote: > I have
    >> started the process of going through IESG comments on the GRASP >
    >> > will not ask for input. But I do need input on some things, and here
    >> is > the first.  Please answer quickly; no answer will be taken to
    >> mean that > you don't care...
    >>
    >> > Alexy wrote: >>> uri-locator = [O_URI_LOCATOR, text]
    >> >>>
    >> >>> other locators and to follow best practices for not encoding >>>
    >> > That would become uri-locator = [O_URI_LOCATOR, text,
    >> transport-proto, > port-number]
    >>
    >> > Opinions? Objections?
    >>

    > Also of course see the thread on Adam Roach's comment.

okay, then give me an example where it wouldn't be null and null?

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 1 Jun 2017 15:22:30 +1200

> okay, then give me an example where it wouldn't be null and null?

funnyschema:funny.stuff

Who knows what proto and port might be appropriate? I'll buy
Alexy's suggestion, because it really costs nothing.

    Brian