Subject: [Anima] Question to the WG about draft-ietf-anima-prefix-management

From: Brian E Carpenter <[email-masked]>
Date: Thu, 4 May 2017 13:57:55 +1200

Hi,

Before we move the prefix management draft forward, I've been enhancing
the corresponding demonstration ASA to be more realistic. The new version
isn't quite ready for public release yet, but I have made it capable
of dynamically assigning prefixes of any reasonable length on demand
(the previous version was limited to a few pre-defined prefix lengths).

Doing this, I realised that it's a very simple enhancement to include
IPv4 prefixes (represented as IPv4-mapped IPv6 addresses). For fun, you
can look at the output from the ASA below, which shows how it can
split a /104 prefix into multiple longer prefixes when asked to
assign a /120 (known in IPv4 as a /24).

So to my question: should we add an "IP version" flag to the 
PrefixManager objective? It would be easy to do, and would allow one
to write an ASA that manages prefixes for both protocols.

Regards
   Brian

[output edited only by deleting noise]

_MainThread 3268 GRASP startup function exiting 
_MainThread 3268 ========================== 
_MainThread 3268 ASA Pfxm2 is starting up. 
_MainThread 3268 ========================== 
_MainThread 3268 Pfxm2 is a demonstration Autonomic Service Agent. 
_MainThread 3268 It supports the IPv6 Edge Prefix Management 
_MainThread 3268 objective 'PrefixManager' and its companion 
_MainThread 3268 'PrefixManager.Params'. 

Act as master? Y/N:y
_MainThread 3268 This ASA will provide an initial prefix pool. 
_MainThread 3268 Also, it will supply default parameters for other ASAs. 
Default prefix for pool? Y/N:n
Prefix length for pool (3..127):104
Manual prefix entry? Y/N:y
Enter IPv6 prefix:::ffff:10.0.0.0
_MainThread 3268 Prefix pool contents: 
_MainThread 3268 ::ffff:a00:0 / 104 

>>> p = get_from_pool(120)
>>> ipaddress.IPv6Address(p)
IPv6Address('::ffff:aff:ff00')
>>> dump_pool()
_MainThread 3268 Prefix pool contents: 
_MainThread 3268 ::ffff:a00:0 / 105 
_MainThread 3268 ::ffff:a80:0 / 106 
_MainThread 3268 ::ffff:ac0:0 / 107 
_MainThread 3268 ::ffff:ae0:0 / 108 
_MainThread 3268 ::ffff:af0:0 / 109 
_MainThread 3268 ::ffff:af8:0 / 110 
_MainThread 3268 ::ffff:afc:0 / 111 
_MainThread 3268 ::ffff:afe:0 / 112 
_MainThread 3268 ::ffff:aff:0 / 113 
_MainThread 3268 ::ffff:aff:8000 / 114 
_MainThread 3268 ::ffff:aff:c000 / 115 
_MainThread 3268 ::ffff:aff:e000 / 116 
_MainThread 3268 ::ffff:aff:f000 / 117 
_MainThread 3268 ::ffff:aff:f800 / 118 
_MainThread 3268 ::ffff:aff:fc00 / 119 
_MainThread 3268 ::ffff:aff:fe00 / 120

---

From: William Atwood <[email-masked]>
Date: Thu, 4 May 2017 07:17:32 -0400

My vote is yes.

There are a lot of IPv4 systems out there, and if we can retrofit into
them (even if it requires a bit of smoke and mirrors to fake the
existence of an IDevID), then that would be a big win.

  Bill

On 03/05/2017 9:57 PM, Brian E Carpenter wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
> 

-- 

Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email:[email-masked]
1455 de Maisonneuve Blvd. West    http://users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 5 May 2017 01:56:44 +0000

My vote is also yes for the flag. Although GRASP and ACP is mainly IPv6 based, the operator might like to manage IPv4 plane through it. The dual stack/network would be existing for a long while.

Sheng

> -----Original Message-----
> From: Anima [mailto:[email-masked]] On Behalf Of William Atwood
> Sent: Thursday, May 04, 2017 7:18 PM
> To: [email-masked]
> Subject: Re: [Anima] Question to the WG about
> draft-ietf-anima-prefix-management
> 
> My vote is yes.
> 
> There are a lot of IPv4 systems out there, and if we can retrofit into them (even
> if it requires a bit of smoke and mirrors to fake the existence of an IDevID),
> then that would be a big win.
> 
>   Bill
> 
> > Before we move the prefix management draft forward, I've been
> > enhancing the corresponding demonstration ASA to be more realistic.
> > The new version isn't quite ready for public release yet, but I have
> > made it capable of dynamically assigning prefixes of any reasonable
> > length on demand (the previous version was limited to a few pre-defined
> prefix lengths).
> >
> > IPv4 prefixes (represented as IPv4-mapped IPv6 addresses). For fun,
> > you can look at the output from the ASA below, which shows how it can
> > split a /104 prefix into multiple longer prefixes when asked to assign
> > a /120 (known in IPv4 as a /24).
> >
> > _MainThread 3268 GRASP startup function exiting _MainThread 3268
> > ========================== _MainThread 3268 ASA Pfxm2 is starting up.
> > _MainThread 3268 ========================== _MainThread 3268
> Pfxm2 is
> > a demonstration Autonomic Service Agent.
> > _MainThread 3268 ::ffff:aff:8000 / 114 _MainThread 3268
> > ::ffff:aff:c000 / 115 _MainThread 3268 ::ffff:aff:e000 / 116
> > _MainThread 3268 ::ffff:aff:f000 / 117 _MainThread 3268
> > ::ffff:aff:f800 / 118 _MainThread 3268 ::ffff:aff:fc00 / 119