Subject: [Anima] Martin Vigoureux's Block on charter-ietf-anima-01-05: (with BLOCK and COMMENT)

From: Martin Vigoureux via Datatracker <[email-masked]>
Date: Mon, 29 Apr 2019 10:30:51 -0700

Martin Vigoureux has entered the following ballot position for
charter-ietf-anima-01-05: Block

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-anima/

----------------------------------------------------------------------
BLOCK:
----------------------------------------------------------------------

Hi,

I am under the impression that there is a small ambiguity in the charter, which
shouldn't be hard to resolve:

   ANIMA work will rely on the framework described in
   draft-ietf-anima-reference-model. [...] The three areas of the framework are
   [...] and (3) Intent.

   ANIMA will not work on Intent [...] without explicit rechartering.

The first piece seems to allow for working on Intent while the second clearly
not (within the current charter).

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I'm not sure to understand what the following means:

   Acceptance of work items by the WG will be scheduled/throttled so that
   contributors can target them to enter WG last call after not more than a number
   of IETF meeting cycles agreed by the AD.

---

From: Barry Leiba <[email-masked]>
Date: Mon, 29 Apr 2019 14:59:10 -0400

> not (within the current charter).

I tripped over that also when I first read it, but then understood:
the WG will rely on the framework, which includes a set of things.
Not all of those things will be worked on via this charter.  In
particular, "intent" is one of the things that won't be.

As I read it, I think the charter is OK.  I suppose it could be
clarified this way:

OLD
ANIMA work will rely on the framework described in
draft-ietf-anima-reference-model. Work not related to this framework is welcome
for review, but WG adoption of such work requires explicit rechartering. The
three areas of the framework are (1) the Autonomic Networking Infrastructure
(ANI), (2) Autonomic Functions (AF) built from software modules called
Autonomic Service Agents (ASA) and (3) Intent.

NEW
ANIMA work will rely on the framework described in
draft-ietf-anima-reference-model, though only parts of the framework are
in scope for this charter, as detailed below.  Work not related to
this framework
is welcome for review, but WG adoption of such work requires explicit
rechartering.
The three areas of the framework are (1) the Autonomic Networking Infrastructure
(ANI), (2) Autonomic Functions (AF) built from software modules called
Autonomic Service Agents (ASA) and (3) Intent.

END

>    of IETF meeting cycles agreed by the AD.

As I read it, it means that the working group won't take on so much
work that the work they do take on doesn't get done.  Acceptance is
based on negotiating a schedule (based on meeting cycles), and if the
schedule isn't met, new work items can't be accepted.

Barry

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 30 Apr 2019 08:29:46 +1200

Barry,

I believe your interpretation is correct.

Regards
   Brian Carpenter

On 30-Apr-19 06:59, Barry Leiba wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>

---

From: "Vigoureux, Martin (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Mon, 29 Apr 2019 20:50:16 +0000

Hi Barry,

I had reached the same conclusion, but I think not everyone might and as you highlight it shouldn't be difficult to make sure that there is no misunderstanding of what is in scope and out of scope of the charter.

On the second item, I am afraid that this charter might be setting expectations on the pace (though not quantified) at which documents will be processed between adoption and LC.

-m

-----Original Message-----
From: Barry Leiba <[email-masked]> 
Sent: Monday, April 29, 2019 20:59
To: Vigoureux, Martin (Nokia - FR/Paris-Saclay) <[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: Martin Vigoureux's Block on charter-ietf-anima-01-05: (with BLOCK and COMMENT)

> I am under the impression that there is a small ambiguity in the 
> charter, which shouldn't be hard to resolve:
>
> The first piece seems to allow for working on Intent while the second 
> clearly not (within the current charter).

I tripped over that also when I first read it, but then understood:
the WG will rely on the framework, which includes a set of things.
Not all of those things will be worked on via this charter.  In particular, "intent" is one of the things that won't be.

As I read it, I think the charter is OK.  I suppose it could be clarified this way:

OLD
ANIMA work will rely on the framework described in draft-ietf-anima-reference-model. Work not related to this framework is welcome for review, but WG adoption of such work requires explicit rechartering. The three areas of the framework are (1) the Autonomic Networking Infrastructure (ANI), (2) Autonomic Functions (AF) built from software modules called Autonomic Service Agents (ASA) and (3) Intent.

NEW
ANIMA work will rely on the framework described in draft-ietf-anima-reference-model, though only parts of the framework are in scope for this charter, as detailed below.  Work not related to this framework is welcome for review, but WG adoption of such work requires explicit rechartering.
The three areas of the framework are (1) the Autonomic Networking Infrastructure (ANI), (2) Autonomic Functions (AF) built from software modules called Autonomic Service Agents (ASA) and (3) Intent.

END

>    of IETF meeting cycles agreed by the AD.

As I read it, it means that the working group won't take on so much work that the work they do take on doesn't get done.  Acceptance is based on negotiating a schedule (based on meeting cycles), and if the schedule isn't met, new work items can't be accepted.

Barry