Subject: [Anima] Reminder//RE: Alissa Cooper's Block on charter-ietf-anima-01-05: (with BLOCK and COMMENT)

From: Sheng Jiang <[email-masked]>
Date: Tue, 16 Jul 2019 09:30:34 +0000

Dear Alissa,

Could you check whether the latest 2.0.9 version on WiKi addresses your block. If not, we would like to further modify it according to your new feedback. We really would like to see progress on rechartering. Many thanks.

https://trac.ietf.org/trac/anima/wiki/Recharter2019

Dear Ignas, could you upload the 2.0.9 version to datatracker? Many thanks,

Sheng

> -----Original Message-----
> From: Toerless Eckert [mailto:[email-masked]]
> Sent: Wednesday, July 10, 2019 7:34 PM
> To: Alissa Cooper <[email-masked]>; [email-masked]
> Cc: Sheng Jiang <[email-masked]>; Brian E Carpenter
> <[email-masked]>; IESG <[email-masked]>; [email-masked];
> [email-masked]
> Subject: Re: [Anima] Alissa Cooper's Block on charter-ietf-anima-01-05: (with
> BLOCK and COMMENT)
> 
> Thanks for the update, Sheng!
> Ignas: can you pls. upload wiki 2.0.9 charter to datatracker ?
> 
> Alissa: Thanks for your comments. I hope that the latest 2.0.9 version on the wiki
> as proposed by Sheng resolves your block. If not, then it would be great if we
> could accelerate resolving them so that we could actually start working on charter
> 2 @ IETF105.
> 
> I think we always intended for what you proposed to be true, e.g: that whats not
> listed in the target work areas would require AD approval to be chartered. I guess
> we never wrote that explicitly because we had some even more specific
> mentioning of explicit AD approval cases in earlier versions of the proposed
> charter and those sentence got argued away by reviewers as being too
> procedural and unnecessary for a charter.
> 
> Cheers
>     Toerless
> 
> On Mon, Jul 08, 2019 at 09:23:01AM -0400, Alissa Cooper wrote:
> > Hi Sheng,
> >
> > > On Jul 3, 2019, at 10:39 AM, Sheng Jiang <[email-masked]> wrote:
> > >
> > > Hi, Alissa,
> > >
> > > Thanks for your kindly response. I have made a new version (2.0.8) according
> to your feedback. Explanation in lines below.
> > >
> > > Please see https://trac.ietf.org/trac/anima/wiki/Recharter2019
> > >
> > >> -----Original Message-----
> > >> From: Alissa Cooper [mailto:[email-masked]]
> > >> Sent: Wednesday, July 3, 2019 5:13 AM
> > >> To: Brian E Carpenter <[email-masked]>
> > >> Cc: IESG <[email-masked]>; [email-masked]; [email-masked]
> > >> Subject: Re: [Anima] Alissa Cooper's Block on
> > >> charter-ietf-anima-01-05: (with BLOCK and COMMENT)
> > >>
> > >> Hi all,
> > >>
> > >> I???ve been discussing this on my weekly call with the OPS ADs for
> > >> the last couple of weeks and based on the call that we had earlier
> > >> today my understanding is that now would be a good time to re-review.
> > >>
> > >> Regarding this text: "New work items will be adopted by the WG only
> > >> if their contributors target them to enter WG last call within a
> > >> number of IETF meeting cycles agreed by the AD.???
> > >>
> > >> I still don???t get this. It is a very common case that
> > >> contributors think their drafts are going to get through to WGLC in
> > >> X cycles, and then they end up taking 2X or 10X because some new
> > >> person wanders into the WG or some other work starts up in another
> > >> WG that has an intersection with the work or someone changes jobs
> > >> or any manner of other things. The WG needs milestones with dates,
> preferably at the point of approving the re-charter.
> > >> Those might be missed too, but there might as well not be two sets
> > >> of markers laid down that are potentially going to be missed rather than one
> set.
> > >
> > > I have just deleted the sentence. It's something the chairs can do during the
> WG management process. We tried to give draft owners some pressure not to
> be too slow by adding these text. I do agree this should not be so rigid as these
> text. So, let's take it out and the chairs will monitor the progress of WG drafts
> closely.
> >
> > Thanks.
> >
> > >
> > >> Regarding the ???indicative scope of possible work items??? ???
> > >> this doesn???t address my concern about the WG???s scope. This
> > >> charter is in contrast to the current ANIMA charter, which says:
> > >> "The initial set of work items is limited to the above list to stay
> > >> focused and avoid 'boiling the ocean???.??? I don???t see the
> > >> rationale for not carrying that forward to the next set of specific
> > >> work items where WG participants have demonstrated interest and
> > >> intent to carry the work forward. If that is the list of initial milestone topics
> listed, then limiting to that makes sense to me.
> > >
> > > I have added a specific list of work items into the initial milestone list.
> > >
> > > Obviously, this initial milestone list does NOT cover all the topics
> > > that WG participants have showed interests and willingness to work
> > > on. The purpose to have this description of "indicative scope of
> > > possible work items??? are actually two: A, limit the potential work
> > > items not to be too wide
> >
> > I think my disconnect here is that the list doesn???t actually limit the WG???s
> scope because it uses the language ???indicative scope of possible work items???
> and ???including but not limited to.??? The five areas of work in this list seem
> broad and large enough to keep the WG busy for quite some time. For the
> charter to effectively limit the scope I think it would need to say ???The scope of
> work items is limited to:??? or something like that.
> >
> > Thanks,
> > Alissa
> >
> > > , otherwise, people may take anything has the work "automatic" to the WG; B,
> to give the chairs a little bit flexibility to adopt new works beyond the initial
> milestone list. We try to avoid the problem that every time a new draft comes up,
> it may become a charter revision, particularly, giving the current re-charting
> process have taken us many months.
> > >
> > > Best regards,
> > >
> > > Sheng
> > >
> > >> Thanks,
> > >> Alissa
> > >>
> > >>> On Jun 10, 2019, at 9:02 PM, Brian E Carpenter
> > >> <[email-masked]> wrote:
> > >>>
> > >>> Hi all,
> > >>>
> > >>> I've taken the liberty of posting an update to the draft charter
> > >>> at https://trac.ietf.org/trac/anima/wiki/Recharter2019. I tried to
> > >>> respond to all the IESG comments, and in particular:
> > >>>
> > >>> (a) I deleted Intent from the summarised reference model
> > >>> framework, since the reference model doesn't usefully define Intent.
> > >>>
> > >>> (b) I tried to make the statement about workload throttling more
> > >>> implementable.
> > >>>
> > >>> (c) I still think that the laundry list of *possible* work items
> > >>> is useful (it helps to define the scope) but I've tried make it
> > >>> clear that it is only the "indicative scope of possible work items".
> > >>> It really isn't mission creep; all the items mentioned relate
> > >>> directly to the ANI and AF topics.
> > >>>
> > >>> (d) I intentionally removed the reference to not covering machine
> > >>> learning and AI. It isn't suggested anywhere in the reference
> > >>> model, so why even mention it?
> > >>>
> > >>> (e) I fixed nits and tuned the wording in several places.
> > >>>
> > >>> I hope this helps. We really need a new charter before Montreal.
> > >>> WG Chairs and AD, over to you...
> > >>>
> > >>> Regards
> > >>>  Brian Carpenter
> > >>>
> > >>> On 02-May-19 08:39, Brian E Carpenter wrote:
> > >>>> Hi Alissa,
> > >>>>
> > >>>> On 02-May-19 08:05, Alissa Cooper via Datatracker wrote:
> > >>>> ...
> > >>>>> ----------------------------------------------------------------
> > >>>>> ----
> > >>>>> --
> > >>>>> BLOCK:
> > >>>>> ----------------------------------------------------------------
> > >>>>> ----
> > >>>>> --
> > >>>>>
> > >>>>> (1) "Acceptance of work items by the WG will be
> > >>>>> scheduled/throttled so that contributors can target them to
> > >>>>> enter WG last call after not more than a number of IETF meeting cycles
> agreed by the AD."
> > >>>>>
> > >>>>> I don't understand the implications of this. What happens if the
> > >>>>> adopted work items have not entered WGLC after the agreed number
> > >>>>> of cycles? If the answer is anything other than "the WG abandons
> > >>>>> the work," I don't understand how this is a throttling
> > >>>>> mechanism. A throttling mechanism would need an explicit limit
> > >>>>> on the number of
> > >> adopted work items at any one time, I think.
> > >>>>
> > >>>> I agree that the text is a bit illogical. In a sense it's
> > >>>> unnecessary, because every WG should be matching its workload to
> > >>>> its capacity. Maybe that's all we should say, rather than trying
> > >>>> to describe a
> > >> slightly vague algorithm?
> > >>>>
> > >>>>> (2) The proposed work items is a very large and somewhat
> > >>>>> unbounded list of items, whereas the purpose of writing a
> > >>>>> charter is to scope the work of the WG and hopefully set out a
> > >>>>> realistic work plan that will be accompanied by deployment. For
> > >>>>> a WG that has produced 5 documents in the last 5 years, I think
> > >>>>> the charter needs to more narrowly focus on the most highly
> > >>>>> prioritized work items. Once those are nearing completion, it
> > >>>>> seems as though evaluation of what is needed next based on
> > >>>>> deployment experience would then dictate the next
> > >> set of items for another re-charter.
> > >>>>
> > >>>> I think the point here is that now that the relatively small
> > >>>> number of infrastructure documents are almost finished, the next
> > >>>> stage opens up the possibilities for a much wider range of work
> > >>>> that builds on the infrastructure. The priorities aren't even
> > >>>> obvious. So this goes with the previous point, and to quite some
> > >>>> extent the criteria will be whether the WG has capacity more than which
> topic has priority.
> > >>>>
> > >>>> That's why there's a bucket list of work items and a short list
> > >>>> of immediate milestones.
> > >>>>
> > >>>> Would this help?
> > >>>>
> > >>>> s/Proposed work items include.../Possible work items include.../
> > >>>>
> > >>>>>
> > >>>>>
> > >>>>> ----------------------------------------------------------------
> > >>>>> ----
> > >>>>> --
> > >>>>> COMMENT:
> > >>>>> ----------------------------------------------------------------
> > >>>>> ----
> > >>>>> --
> > >>>>>
> > >>>>> It would be good to see milestones with dates before this gets
> approved.
> > >>>>>
> > >>>>> I think this charter would benefit from an English edit pass
> > >>>>> before going
> > >> out for external review.
> > >>>>
> > >>>> I'll volunteer, when the open issues have been resolved.
> > >>>>
> > >>>>> What is "compounding environment"?
> > >>>>
> > >>>> An excellent question.
> > >>>>
> > >>>>   Brian
> > >>>>
> > >
> 
> --
> ---
> [email-masked]

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 16 Jul 2019 09:44:53 -0400

Thanks. I’ll clear my block when the 2.0.9 version gets uploaded to the datatracker.
Alissa

> On Jul 16, 2019, at 5:30 AM, Sheng Jiang <[email-masked]> wrote:
> 
> Dear Alissa,
>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 23 Jul 2019 00:15:18 +0200

Hi Alissa,

Ignas did upload wiki version 2.0.9 to data-tracker today, where it is online
now as versions charter-ietf-anima-01-07.

Would be great if you can deal with your block, so we can at least show
some measure of progress on our progress in the process during the WG meeting.

Thanks so much
    Toerless

On Tue, Jul 16, 2019 at 09:44:53AM -0400, Alissa Cooper wrote:
> Thanks. I???ll clear my block when the 2.0.9 version gets uploaded to the datatracker.
> Alissa
> 
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

-- 
---
[email-masked]