Subject: [Anima] Adoption call for draft-liu-anima-grasp-distribution (ends 01/27/2020)

From: Toerless Eckert <[email-masked]>
Date: Mon, 13 Jan 2020 12:45:33 +0100

This message starts a two-week adoption call, it ends on January 27th, 2020.

draft-liu-anima-grasp-distribution was progressed up to version -13 with
the help of the WG, it was last presented at IETF106 with good interest.
The draft is now clearly in scope of ANIMA charter 2 that was adopted
around IETF106. The authors asked for adoption of the document.
As far as the chairs heard, there was no objection in the room.

We therefore are asking the ANIMA working group for adoption of the following work:

Title:    Information Distribution in Autonomic Networking
Name:     draft-liu-anima-grasp-distribution
Authors:  B. Liu, X. Xiao, A. Hecker, S. Jiang, Z. Despotovic
URL:      https://datatracker.ietf.org/doc/draft-liu-anima-grasp-distribution/

This document is intended to become a standards track ANIMA WG document.

Standard track is desired because it is meant to become the required
small set of protocol extensions to the GRASP protocol in support of
the self-organization of ASA.

Please express your support or rejection. If you think this document
should _not_ be adopted, please also explicitly indicate the reasons.

For the ANIMA WG chairs, 
    Toerless

---

From: Michael Richardson <[email-masked]>
Date: Mon, 13 Jan 2020 13:23:15 -0500

I have re-read the document quickly.
I think that some of the how does it work parts will need to expanded.
I support adoption.

My non-blocking comments:
1) I think that I'd like to see more reference to the use cases in the
   introduction.
   
2) I think that Connected-Car case is not useful unless the ACP will
   be extended to the car, and I think that is unreasonable to do in
   the general situation.  Maybe it makes sense for an autonomous
   vehicle situation where all vehicles are owned by the 'taxi' service.

3) I think that the killer app for this is Firmware Updates.
   By abstracting the location of the firmware from the name of the firmware,
   while providing a way to notify about it, this significantly supports
   distribution of firmware updates.
   References to SUIT would appropriate.                

Toerless Eckert <[email-masked]> wrote:
    > draft-liu-anima-grasp-distribution was progressed up to version -13
    > with the help of the WG, it was last presented at IETF106 with good
    > interest.  The draft is now clearly in scope of ANIMA charter 2 that
    > was adopted around IETF106. The authors asked for adoption of the
    > document.  As far as the chairs heard, there was no objection in the
    > room.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 14 Jan 2020 07:43:43 +1300

I support adoption. However, the issues discussed in the following message still need to be clarified:

https://mailarchive.ietf.org/arch/msg/anima/_0fYQPBcLPt8xzQee7P4dILsn3A

I probably need to follow up directly on that message but I'm on travel for a few days.

Regards
   Brian

On 14-Jan-20 00:45, Toerless Eckert wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
> .
>

---

From: "Liubing (Leo)" <[email-masked]>
Date: Sun, 19 Jan 2020 07:29:20 +0000

Hi Dear all,

I support the adoption as a co-author.

I believe this document make useful extension to current ANI/GRASP, to allow information distribution capabilities in a flexible manner (e.g. Pub/Sub, Selective Flooding etc.) .
And as a co-author I'd like to continue refine the draft with carefully considering  comments from Brian, Michael and other potential people in the WG.

Many thanks.

B.R.
Bing

> -----Original Message-----
> From: Toerless Eckert [mailto:[email-masked]]
> Sent: Monday, January 13, 2020 7:46 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Anima] Adoption call for draft-liu-anima-grasp-distribution (ends
> 01/27/2020)
> 
> draft-liu-anima-grasp-distribution was progressed up to version -13 with the
> help of the WG, it was last presented at IETF106 with good interest.
> The draft is now clearly in scope of ANIMA charter 2 that was adopted around
> IETF106. The authors asked for adoption of the document.
> Standard track is desired because it is meant to become the required small set of
> protocol extensions to the GRASP protocol in support of the self-organization of
> ASA.
> 
> Please express your support or rejection. If you think this document should
> _not_ be adopted, please also explicitly indicate the reasons.
> 
> For the ANIMA WG chairs,
>     Toerless

---

From: Xun Xiao <[email-masked]>
Date: Wed, 22 Jan 2020 09:45:29 +0000

Dear ANIMA,

As a co-author of the draft, I also support the adoption. 

 This draft generalizes the requirements of information distribution in ANI, tries to categorize various information distribution scenarios and proposes some useful extensions on GRASP in order to cover all the information distribution cases. Although there are still some details and questions needing further clarification or even modifications, it should be good to have such a generic function layer for ANI. Thanks.

Best Regards,

Xun Xiao (肖迅)
Advanced Wireless Technology Lab
Munich Research Center
Huawei Technologies Co.,Ltd.

-----Original Message-----
From: Toerless Eckert [mailto:[email-masked]] 
Sent: Monday, 13 January 2020 12:46
To: [email-masked]
Cc: [email-masked]
Subject: [Anima] Adoption call for draft-liu-anima-grasp-distribution (ends 01/27/2020)

draft-liu-anima-grasp-distribution was progressed up to version -13 with the help of the WG, it was last presented at IETF106 with good interest.
The draft is now clearly in scope of ANIMA charter 2 that was adopted around IETF106. The authors asked for adoption of the document.
As far as the chairs heard, there was no objection in the room.

Standard track is desired because it is meant to become the required small set of protocol extensions to the GRASP protocol in support of the self-organization of ASA.

Please express your support or rejection. If you think this document should _not_ be adopted, please also explicitly indicate the reasons.

For the ANIMA WG chairs, 
    Toerless

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Wed, 22 Jan 2020 15:46:50 +0100

Hi,

> As far as the chairs heard, there was no objection in the room.

I support adoption, but also support the suggestion (from IETF106)
to revise the document so that it is written less
implementation-oriented and focusses more on protocol behavior
description, e.g.,
section 4 uses currently a module-oriented description.

Gruß
 Roland

---

From: <[email-masked]>
Date: Wed, 22 Jan 2020 15:40:52 +0000

Hi all,

I support the draft. 

Some serious work is required for the following sections to better motivate the required extensions:

   1  Introduction  . . . . . . . . . . . . . . . . . . . . . . . . .  3
   2. Terminology . . . . . . . . . . . . . . . . . . . . . . . . . .  3
   3. Requirements of Enriched Information Distribution . . . . . . .  4
   4. Node Behaviors  . . . . . . . . . . . . . . . . . . . . . . . .  5
     4.1 Instant Information Distribution (IID) Sub-module  . . . . .  5
     4.2 Asynchronous Information Distribution (AID) Sub-module . . .  6
     4.3 Summary  . . . . . . . . . . . . . . . . . . . . . . . . . . 10

I would also move some use cases in the appendix into the core text. It would be even interesting if some of the extensions/usage are illustrated with one use case. 

There is some disconnect in the terms used in the document vs. the ANIMA reference architecture (e.g. the use of autonomic function). Double checking that would be cool. 

Cheers,
Med

> -----Message d'origine-----
> De : Anima [mailto:[email-masked]] De la part de Toerless
> Eckert
> Envoyé : lundi 13 janvier 2020 12:46
> À : [email-masked]
> Cc : [email-masked]
> Objet : [Anima] Adoption call for draft-liu-anima-grasp-distribution
> (ends 01/27/2020)
> 
> with