Subject: Re: [Anima] I-D Action: draft-richardson-anima-masa-considerations-02.txt

From: Brian E Carpenter <[email-masked]>
Date: Tue, 21 Jan 2020 11:54:36 +1300

Hi,

This draft takes me out of my comfort zone, but it seems like
an important topic. One sub-section did catch my eye:

> 2.1.  On-device private key generation
> 
>    Generating the key on-device has the advantage that the private key
>    never leaves the device.  The disadvantage is that the device may not
>    have a verified random number generator.

A reference to RFC4086 would useful.

>    There are a number of options of how to get the public key securely
>    from the device to the certification authority.  This transmission
>    must be done in an integral manner, and must be securely associated
>    with the assigned serial number.  The serial number goes into the
>    certificate, and the resulting certificate needs to be loaded into
>    the manufacturer's asset database.  This asset database needs to be
>    shared with the MASA.

The first sentence made me stop and think. Normally, a "public" key
can and must be revealed in public, so doesn't need to be moved
securely. I *think* you are saying that the association of a given
public key with a given serial number must be kept secret. If so,
please say that explicitly.

>    One way to do the transmission is during a manufacturing during a Bed
>    of Nails (see [BedOfNails]) or Boundary Scan.  

I think that needs a bit more description.

>       There are other ways
>    that could be used where a certificate signing request is sent over a
>    special network channel after the system has been started the first
>    time.  

What's special? Couldn't it just be a TLS session?

>       There are risks with these methods, as an attacker with
>    physical access may be able to put device back into this mode
>    afterwards.

You could recommend that the device sets a hard flag that
makes this impossible. Maybe it should simply *delete* its
public key after uploading it once.

Regards
   Brian

On 06-Dec-19 10:19, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : Operational Considerations for Manufacturer Authorized Signing Authority
>         Author          : Michael Richardson
> 	Filename        : draft-richardson-anima-masa-considerations-02.txt
> 	Pages           : 11
> 	Date            : 2019-12-05
> 
> Abstract:
>    This document describes a number of operational modes that a BRSKI
>    Manufacturer Authorized Signing Authority (MASA) may take on.
> 
>    Each mode is defined, and then each mode is given a relevance within
>    an over applicability of what kind of organization the MASA is
>    deployed into.  This document does not change any protocol
>    mechanisms.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-richardson-anima-masa-considerations/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-richardson-anima-masa-considerations-02
> https://datatracker.ietf.org/doc/html/draft-richardson-anima-masa-considerations-02
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-richardson-anima-masa-considerations-02
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Michael Richardson <[email-masked]>
Date: Mon, 20 Jan 2020 19:51:53 -0500

> please say that explicitly.

The association between the public key and the serial number must integral.
This isn't about privacy, but about integrity.
I'm not saying that the association with a serial number must be secret, but
that it must be very difficult to be interferred with.

    > I think that needs a bit more description.

okay.
I will ask a few friends in the electronics business what kind of reference
they would make.
Was  https://en.wikipedia.org/wiki/In-circuit_test#Bed_of_nails_tester
insufficient, or do you want something inline?

    > What's special? Couldn't it just be a TLS session?

It depends a lot about the environment.
It neededn't be TLS at all: it could be just a special network cable that is
plugged in.  What matters is that the system be secure against interloppers.

    > public key after uploading it once.

Yes. I mean to read some of the documentation for TPM chips.
I believe that they blow a fuse.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [