Subject: [Anima] Rob/Warren: Early allocation request for draft-ietf-anima-constrained-voucher (according to RFC7120)

From: [email-masked]
Date: Fri, 23 Jul 2021 01:35:40 +0200

Dear Rob, Warren,

As chairs of the ANIMA WG, we hereby request your AD approval
for early allocation of code points from IANA according to RFC7120
for draft-ietf-anima-constrained-voucher.

This is similar to the early registration request we did for what
is now 	RFC8366 (voucher), where we requested voucher encoding with CMS
(application/voucher-cms+json) in 2019. 

We have now active development and interop work (during IETF111 Hackathon)
for the new encoding option for the constained voucher via COSE. It would
help the ongoing pre-production implementations a lot if they would not have to
come up with non-assigned code-points now.

Toerless (for the chairs)

Draft:

Reference document for registration request is:
  https://datatracker.ietf.org/doc/html/draft-ietf-anima-constrained-voucher-13

to be pushed soon after datatracker opens again, until then:

https://github.com/anima-wg/constrained-voucher/blob/master/constrained-voucher.txt

We request two early allocations:

1. IANA "Media Types" applications registry accordin to draft section 12.5/12.5.1:
   https://www.iana.org/assignments/media-types/media-types.xhtml#application

   Name                 Template                        Reference
   voucher-cose+cbor	application/voucher-cose+cbor   [draft-ietf-anima-constrained-voucher]

   Template according to reference draft, section 12.5.1:

   Type name:  application
   Subtype name:  voucher-cose+cbor
   Required parameters:  none
   Optional parameters:  none
   Encoding considerations:  binary
   Security considerations:  Security Considerations of THIS RFC.
   Interoperability considerations:  The format is designed to be
     broadly interoperable.
   Published specification:  THIS RFC.
   Applications that use this media type:  ANIMA, 6tisch, and other
     zero-touch onboarding systems
   Additional information:
     Magic number(s):  None
     File extension(s):  .vch
     Macintosh file type code(s):  none
   Person & email address to contact for further information:  IETF
     ANIMA WG
   Intended usage:  LIMITED
   Restrictions on usage:  NONE
   Author:  ANIMA WG
   Change controller:  IETF
   Provisional registration? (standards tree only):  NO

2. CoAP content type registy
   https://www.iana.org/assignments/core-parameters/core-parameters.xhtml#content-formats

   Media type                    Encoding   ID  References
   ----------------------------  --------- ---- ----------
   application/voucher-cose+cbor           TBD3 [draft-ietf-anima-constrained-voucher]

The ANIMA WG chairs have verified that the required conditions for
early allocation from RFC7120, Section 2 are met:

a) Standards Action (document is standards track ANIMA WG draft)

b) The WG draft adequately describes the desired semantics.

c) The WG participants actively working on implementations of the
   draft have confirmed that the semantic of the code point is
   stable to the extend that it is clear that the final
   RFC will need it, and active interoperability testing is ongoing,
   only challenged by availability of an early allocation.

d) The working group chairs think that it would be highly helpful to
   receive an early allocation code point now to support further
   interoperability testing, ensuring that the final RFC has the
   highest level of practical vetting and can be finished as soon
   as possible.

The request for early allocation was brought up in the working group
and was faced with no disagreement. The working group chairs also
understand that there is no risk of depletion of the registry in question.

Thank you very much
    Toerless (for the chairs)

---

From: Warren Kumari <[email-masked]>
Date: Tue, 27 Jul 2021 15:02:45 -0400

This sounds fine to me, but actual approval should come from Rob.
W

-- 
The computing scientist’s main challenge is not to get confused by the
complexities of his own making.
  -- E. W. Dijkstra