Subject: [Anima] Call for agenda items ANIMA @ IETF 111, online

From: "[email-masked]" <[email-masked]>
Date: Thu, 8 Jul 2021 17:12:00 +0200

Dear ANIMA WG

It is this time again! 

ANIMA WG will meet at IETF111 online for two 1 hour slots:
  Monday   July 26, Session 2, 21:30 - 22:30 UTC
  Thursday July 29, Session 1, 19:00 - 20:00 UTC
So we will have more time for discussions.

Please submit your requests for Agenda items in reply to this email,
to [email-masked] and copy [email-masked] unless you want
to discuss agenda issues in private with the chairs.

    Topic/Title
    Nam of Presenter(s)
    Length of time requested
    If applicable: name of draft(s) discussed

    Please note explicitly if you CAN have the agenda item only
    in one of the two slots due to conflicts.

No need to wait with agenda slots until you have uploaded your (updated) draft!

Especially this time around we would appreciate requests for agenda
slots to be as early as possible so we can try to shuffle them
around the two time slots best. Of course, by default we would sort
as usual by WG adopted items first, then actively discussed non-WG
items and finally new, non-discussed work proposals.

Also: Once you have your slides, go to:

  https://datatracker.ietf.org/meeting/111/session/anima

and upload your slides via the "Propose Slides" Button
(pick either of the two slots as you see fit).

Please also remember to (re-)start discussing any non-WG adopted work
also on the [email-masked] mailing list to encourage WG members
to read your work and comment!

More details about the IETF 111 can be found at:
https://www.ietf.org/how/meetings/111/

ANIMA WG Chairs, Toerless/Sheng

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 11 Jul 2021 10:54:24 +1200

Hi,

About draft-ietf-anima-asa-guidelines:

Although we probably want to produce one more version, I think the authors of this draft feel it is as complete as seems possible at present. So is it possible to plan a WG Last Call as soon as the next version comes out?

If so, I would suggest that we do *not* need a slot in the meeting, but simply a mention in the Chair's slides that the document is nearly ready.

If the chairs disagree, of course we could briefly present it yet again, but in the Monday session please, if you would like me to be awake ;-).

Regards
   Brian Carpenter

On 09-Jul-21 03:12, [email-masked] wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>

---

From: "Fries, Steffen" <[email-masked]>
Date: Mon, 12 Jul 2021 08:35:27 +0000

Hello Toreless,

We would like to provide an update to BRSKI-AE. Here the info:

    Topic/Title 			: BRSKI-AE
     Name of Presenter(s)	: Steffen Fries
     Length of time requested	: 15 min
     If applicable			:  draft-ietf-anima-brski-async-enroll-03.txt	

If possible we would like to discuss the status of BRSKI-AE in the second session on Thursday, as the Monday session is in parallel to a LAMPS session.

Best regards
Steffen

> -----Original Message-----
> From: Anima <[email-masked]> On Behalf Of [email-masked]
> Sent: Donnerstag, 8. Juli 2021 17:12
> To: [email-masked]; [email-masked]
> Subject: [Anima] Call for agenda items ANIMA @ IETF 111, online
> 
> Dear ANIMA WG
> 
> It is this time again!
> 
>   Thursday July 29, Session 1, 19:00 - 20:00 UTC So we will have more time for
> discussions.
> 
> Please submit your requests for Agenda items in reply to this email, to anima-
> [email-masked] and copy [email-masked] unless you want to discuss agenda
> issues in private with the chairs.
> 
>     Topic/Title
>     Nam of Presenter(s)
>     Length of time requested
> Especially this time around we would appreciate requests for agenda slots to be
> as early as possible so we can try to shuffle them around the two time slots best.
> Of course, by default we would sort as usual by WG adopted items first, then
> actively discussed non-WG items and finally new, non-discussed work proposals.
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatrac
> ker.ietf.org%2Fmeeting%2F111%2Fsession%2Fanima&amp;data=04%7C01%7Cc
> ef9763c-149c-4881-b9c2-
> 5fedc277663a%40ad011.siemens.com%7C3cbdd85c0d5942b6f5fb08d94222c82
> 8%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C6376135394252642
> 83%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiL
> CJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=50LDy25FpJsDwf7mcT
> uzQcPBe3GLG1cYEsB4lHH%2BK7s%3D&amp;reserved=0
> 
> and upload your slides via the "Propose Slides" Button (pick either of the two
> slots as you see fit).
> 
> Please also remember to (re-)start discussing any non-WG adopted work also on
> the [email-masked] mailing list to encourage WG members to read your work
> and comment!
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf
> .org%2Fhow%2Fmeetings%2F111%2F&amp;data=04%7C01%7Ccef9763c-149c-
> 4881-b9c2-
> 5fedc277663a%40ad011.siemens.com%7C3cbdd85c0d5942b6f5fb08d94222c82
> 8%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C6376135394252642
> 83%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiL
> CJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=12cBiD4Q3nnVBPXLVs
> 5VnAFaKdmKKVMpE7E7cDpp8HI%3D&amp;reserved=0
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf
> .org%2Fmailman%2Flistinfo%2Fanima&amp;data=04%7C01%7Ccef9763c-149c-
> 4881-b9c2-
> 5fedc277663a%40ad011.siemens.com%7C3cbdd85c0d5942b6f5fb08d94222c82
> 8%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C6376135394252642
> 83%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiL
> CJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=o441I77W%2Fh4FBD6
> 754X9coaQUpM2%2FWhRVttFY2y3i18%3D&amp;reserved=0

---

From: Liyizhou <[email-masked]>
Date: Mon, 12 Jul 2021 08:59:55 +0000

Hi Chairs,

We would like to request a time slot for the following item.

    Topic/Title: Autonomic IP Address To Access Control Groups Mapping
    Name of Presenter(s): Yizhou Li
    Length of time requested: 15 minutes
    If applicable: name of draft(s) discussed: draft-yizhou-anima-ip-to-access-control-groups-00

Monday session is preferred if possible.

Thank you,
Yizhou

-----Original Message-----
From: Anima [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, July 8, 2021 11:12 PM
To: [email-masked]; [email-masked]
Subject: [Anima] Call for agenda items ANIMA @ IETF 111, online

Dear ANIMA WG

It is this time again! 

ANIMA WG will meet at IETF111 online for two 1 hour slots:
  Monday   July 26, Session 2, 21:30 - 22:30 UTC
  Thursday July 29, Session 1, 19:00 - 20:00 UTC So we will have more time for discussions.

Please submit your requests for Agenda items in reply to this email, to [email-masked] and copy [email-masked] unless you want to discuss agenda issues in private with the chairs.

    Topic/Title
    Nam of Presenter(s)
    Length of time requested

Especially this time around we would appreciate requests for agenda slots to be as early as possible so we can try to shuffle them around the two time slots best. Of course, by default we would sort as usual by WG adopted items first, then actively discussed non-WG items and finally new, non-discussed work proposals.

and upload your slides via the "Propose Slides" Button (pick either of the two slots as you see fit).

Please also remember to (re-)start discussing any non-WG adopted work also on the [email-masked] mailing list to encourage WG members to read your work and comment!

---

From: Michael Richardson <[email-masked]>
Date: Mon, 12 Jul 2021 07:41:50 -0400

Brian E Carpenter <[email-masked]> wrote:
    > Although we probably want to produce one more version, I think the
    > authors of this draft feel it is as complete as seems possible at
    > present. So is it possible to plan a WG Last Call as soon as the next
    > version comes out?

I concur.

---

From: Michael Richardson <[email-masked]>
Date: Mon, 12 Jul 2021 07:48:00 -0400

I have uploaded some placeholder slides for ietf-constrained-voucher
as well as brski-cloud.

There is a hackathon for ietf-constrained-voucher, so we'll replace the
slides with hackathon results, once the event has occured.

I had hoped to start a WGLC for ietf-constrained-voucher, as well as
constrained-join-proxy, but ietf-constrained-voucher still needs more
Security Considerations and some Applicability statement.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Tue, 13 Jul 2021 12:54:25 +0200

Dear chairs,

I'd like to request a slot.

Topic/Title: Autonomic setup of fog monitoring agents
Name of Presenter(s): Carlos J. Bernardos
Length of time requested: 5 to 10 minutes
If applicable: name of draft(s) discussed:
https://datatracker.ietf.org/doc/draft-bernardos-anima-fog-monitoring/

Thanks!

Carlos

---

From: Xun Xiao <[email-masked]>
Date: Fri, 16 Jul 2021 14:43:40 +0000

Dear ANIMA-chairs,

I would like to have a slot.

    Topic/Title: 			updates of gasp-distribution-draft-03
    Nam of Presenter(s): 	Xun Xiao
    Length of time requested: 	10 mins
   Name of draft(s) discussed: 	draft-ietf-anima-grasp-distribution-03

I prefer Thursday July 29's session (due to the time zone).

BR/Xun

-----Original Message-----
From: Anima [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, 8 July 2021 17:12
To: [email-masked]; [email-masked]
Subject: [Anima] Call for agenda items ANIMA @ IETF 111, online

Dear ANIMA WG

It is this time again! 

    Topic/Title
    Nam of Presenter(s)
    Length of time requested

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 23 Jul 2021 02:11:38 +0200

Steffen, Michael:

Thursday for BRSKI-AE is fine. I will assume 
the split-out JWS voucher draft (Michael wants to publish it as draft-ietf-anima-jws-voucher-00)
should then also be discussed.

Right now i will account that as one slot. But feel
free to suggest different speaker/slides for both drafts.

Cheers
    Toerless.

-- 
---
[email-masked]

---

From: Dangjuanna <[email-masked]>
Date: Fri, 23 Jul 2021 03:23:35 +0000

Hi Brian and All,

I have an interest on draft-ietf-anima-asa-guidelines. Would you like to pay attention to draft-dang-anima-network-service-auto-deployment-00?

To achieve the objective of network service auto-deployment, the autonomic networks ecosystem must design a new ASAs and corresponding GRASP objective definitions. The ASAs are responsible for resource-based path management and control, such as resource-based path /segment-path calculation and path state maintenance. The GRASP is used to exchanging the service/path information and the related resource information among the autonomic nodes in order to negotiate the service/path resources. Therefore, the ASAs must legally register with GRASP in the ACP . Therefore, the ASAs must legally register with GRASP in the ACP for the purpose of serving them with the related GRASP objects.

A New GRASP Objective Option as an example is defined as follows.
- name: s-deployment-value, which is need to be assigned by IANA registration
- objective-flag: F_DISC and F_SYNCH
- objective-value: a data structure as follows
  -- s-identification, which is used to distinguish different network services
  -- s-deployment-type, which indicates that it is new, or updated, or deleted 
  -- s-resource-information, which are the assured resources of the network service.
    -- resource-type, which indicate bandwidth, or latency, etc.
    -- resource-value, which indicate the value.
  -- s-deployment-status, which indicate deployment success or failure, and the reason for the failure

The corresponding ASA need full life cycle management, from establishment, maintenance to termination. The ASA on network autonomic node interacts with GRASP objective ( such as s-deployment-value) via GRASP API. The ASA interaction among different nodes uses GRASP protocol for information exchange, synchronization and negotiation.

Personally, I feel that this document has helped me a lot in my work.

Best wishes,
Joanna

-----Original Message-----
From: Anima [mailto:[email-masked]] On Behalf Of Brian E Carpenter
Sent: 2021年7月11日 6:54
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Anima] Call for agenda items ANIMA @ IETF 111, online

Hi,

Regards
   Brian Carpenter

On 09-Jul-21 03:12, [email-masked] wrote:
> to [email-masked] and copy [email-masked] unless you want to 
> discuss agenda issues in private with the chairs.
> 
>     Topic/Title
>     Nam of Presenter(s)
>     Length of time requested
> slots to be as early as possible so we can try to shuffle them around 
> the two time slots best. Of course, by default we would sort as usual 
> by WG adopted items first, then actively discussed non-WG items and 
> finally new, non-discussed work proposals.
> 
> also on the [email-masked] mailing list to encourage WG members to 
> read your work and comment!
>

---

From: "Fries, Steffen" <[email-masked]>
Date: Fri, 23 Jul 2021 06:17:46 +0000

Hi Toerless,

Just to clarify the relations of the drafts, draft-ietf-anima-jws-voucher-00 and draft-ietf-anima-brski-async-enroll-03 are two independent drafts. BRSKI-AE utilizes the JWS-voucher and normatively refers to it. 
The split I was referring to relates to the two use cases in BRSKI-AE, which developed differently. So we see a benefit in separating them. 

>From that point of view we may handle them as two separate points in the agenda. 
I will upload the slides for BRSKI-AE soon. 

Best regards
Steffen

> From: [email-masked] <[email-masked]>
> Sent: Freitag, 23. Juli 2021 02:12
> To: Fries, Steffen (T RDA CST) <[email-masked]>
> Cc: [email-masked]; [email-masked]; Werner, Thomas (T RDA CST SEA-
> DE) <[email-masked]>; Brockhaus, Hendrik (T RDA CST SEA-DE)
> <[email-masked]>; Eliot Lear <[email-masked]>
> Subject: Steffen/Michael/*: Slot for draft-ietf-anima-jws-voucher-00 ?! Re:
> [Anima] Call for agenda items ANIMA @ IETF 111, online
> 
> Steffen, Michael:
> 
> Thursday for BRSKI-AE is fine. I will assume the split-out JWS voucher draft
> (Michael wants to publish it as draft-ietf-anima-jws-voucher-00) should then
> also be discussed.
> 
> Right now i will account that as one slot. But feel free to suggest different
> speaker/slides for both drafts.
> 
> Cheers
>     Toerless.
> 
> > If possible we would like to discuss the status of BRSKI-AE in the second
> session on Thursday, as the Monday session is in parallel to a LAMPS session.
> >
> > Best regards
> > Steffen
> >
> > > to anima- [email-masked] and copy [email-masked] unless you want to
> > > slots to be as early as possible so we can try to shuffle them around the two
> time slots best.
> > > Of course, by default we would sort as usual by WG adopted items
> > > first, then actively discussed non-WG items and finally new, non-discussed
> work proposals.
> > >
> > > Please also remember to (re-)start discussing any non-WG adopted
> > > work also on the [email-masked] mailing list to encourage WG members