Subject: [Ans-research] Definition of scalability

From: "Costas Constantinou" <[email-masked]>
Date: Wed, 11 Jun 2003 16:09:25 +0100

Hello,

This is an attempt to follow-up the action point given out at the end of the ANS-research meeting on 1 June 2003 at MobiHoc '03 in Annapolis.

As I am new to both the research topic and your community (I am a radio engineer), please feel free to shoot down as irrelevant anything I have to say, but please provide me with explanations on why exactly I am a complete "fraud." ;-)

There are four distinct major issues (and numerous minor ones) that you are all raising, and it is perhaps worthwhile to attempt to tackle them one at a time.

Question 1: What are the quantifiable figures of merit/performance we can agree as being relevant (i.e. Zygmunt's SOMETHING#2 vector in his 8 April 2003 message) - more on this below.

Question 2: What are the free variables (i.e. Zygmunt's SOMETHING#1) that we wish the figures of merit to scale with respect to.

Question 3: How do we sample the (possibly highly) multi-dimensional space of free variables in a meaningful manner that enables us to compare like with like.

Question 4: How do we map detailed local protocols/rules/etc. to observed scaling behaviour of the figures of merit, *reliably* and *unambiguously*.

All these questions are tough, but questions 2 and 3 are likely to be the most complex ones leading to disagreements and considerable discussion. However, before we scale "mount Everest," could we agree to establish a "base camp" by tackling question 1? This is not as innocuous as it might seem to the casual observer. The previous discussions on the list amply demonstrate that it will be hard to resist the temptation to throw in issues belonging to the other questions, but I think we need to impose some self-discipline, just to make tangible progress.

Also, I would like to clarify that any research issues that are not measurable quantitatively as suggested above, need to be excluded from this thread. For example, does security fall in this category? Can I measure a quantity that quantifies how secure a network is? I am getting conflicting opinions on this! having said this, it does not mean that any such issues are not valid MANET research topics, and they still belong to this research group's activities and discussions.

My highly incomplete (and almost certainly flawed) offering to the first question is:
   a) Appropriately defined (to account for information that reaches its destination with unacceptable delay) packet loss rate by the network
   b) Average peak power consumption per node (in some arbitrary units)
   c) Total spectrum bandwidth occupied

Finally, it is important to remember that the age-old argument of bell-heads versus net-heads ought to be weighted in favour of the net-heads in this instance - "don't care how something is done, as long as it delivers with minimal cost to the end-user."

For example, the overhead/control traffic or speed of re-convergence of the network to mobility induced failures are instances of  "don't care." Similarly I don't care if the computational complexity of my algorithms was high, or whether the offered traffic was unicast, broadcast or multicast. On the other hand, has my battery run down, did my message get across (securely, timely, etc.), and did I end up consuming all the spectrum in the process are arguably more relevant questions. The former topics are of course important to researchers, but they should not be the *measure* of performance and scalability.

Over to you for tearing up these thoughts!
Costas.

*********************************************
Dr Costas Constantinou
Senior Lecturer in Communications Engineering
Electronic, Electrical & Computer Engineering
The University of Birmingham
Edgbaston, Birmingham, B15 2TT
Tel: +44-121-414-4303
Fax: +44-121-414-4291
Email: [email-masked]
*********************************************
_______________________________________________
Ans-research mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ans-research

---

From: S Woodside <[email-masked]>
Date: Wed, 11 Jun 2003 14:55:45 -0400

On Wednesday, June 11, 2003, at 11:09  AM, Costas Constantinou wrote:

> Hello,
>
> This is an attempt to follow-up the action point given out at the end 
> of the ANS-research meeting on 1 June 2003 at MobiHoc '03 in > Annapolis.

Are notes/minutes/slides available?

simon

--
www.simonwoodside.com -- 99% Devil, 1% Angel