Subject: [Apn] APN vs. Network Slicing

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 30 Jul 2021 21:28:21 +0000

Hi Jim,

To follow up on your comments about APN vs. Slicing, here are some points that I did not have time to exchange during the BoF.

- While slicing does involve setting aside/up resources, that is the means to meet specific requirements for traffic delivery.
- Traffic delivered in network slices are identified by some identifiers so that network nodes knows how to forward them to meet the requirements. Combined with "slice aggregate" concept introduced in draft-bestbar-xxx drafts, fine granularity can be achieved down to flow level (vs. slice level).

In short, the goal of APN and slicing are the same (or slicing covers even more). Additionally, it is not that slicing is a use case of APN. It's the other way around - slicing does what APN want to do.

I could not get my one-page slide shared to better illustrate my point that APN problem domain/solution are already covered by IETF slicing, but let me post the text from that slide here. The sub-bullets are text quoted from the network slicing framework https://datatracker.ietf.org/doc/html/draft-ietf-teas-ietf-network-slices。

*       Ongoing IETF Network Slicing work already addresses the problem domain and solution
*       An IETF Network Slice provides the required connectivity between different entities in RAN and CN segments of an end-to-end network slice, with a specific performance commitment.
*        It is intended that IETF Network Slices can be created to meet specific requirements, typically expressed as bandwidth, latency, latency variation, and other desired or required characteristics.
*       An IETF Network Slice combines the connectivity resource requirements and associated network behaviors such as bandwidth, latency, jitter, and network functions with other resource behaviors such as compute and storage availability.
*       Term "Slice" refers to a set of characteristics and behaviors that separate one type of user-traffic from another.  IETF Network Slice assumes that an underlying network is capable of ... fulfilling all or some of SLOs to all of the traffic in the slice or to specific flows
*       Many approaches are currently being worked on to support IETF Network Slices in IP and MPLS networks with or without the use of Segment Routing.  Most of these approaches utilize a way of marking packets so that network nodes can apply specific routing and forwarding behaviors to packets that belong to different IETF Network Slices. Different mechanisms for marking packets have been proposed (including using MPLS labels and Segment Rouing segment IDs)
*       The realization can be achieved in a form of either physical or logical connectivity using VPNs, virtual networks (VNs), or a variety of tunneling technologies such as Segment Routing, MPLS, etc.
*       Slice Aggregate concept (similar to DiffServ Behavior Aggregate) in draft-bestbar is about identifying some or all traffic in a slice using opaque numbers and providing corresponding forwarding treatment
*       Forwarding/steering should be based on opaque numbers not structured APN IDs

Thanks.
Jeffrey

  Juniper Business Use Only

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Fri, 30 Jul 2021 21:48:07 +0000

Sorry to Jim that I jumped in.

Hi Jeffrey,

You have been explaining about what network slicing can do or does. But that is really up to the network slicing people to figure out. There have been several years for people to clarify the concept and consolidate the various terminologies even now. Here we only talk about APN.

APN and network slicing are two things. They don’t have to have any relationships, and they do not conflict each other.

The only connection is that APN provides a way to steer some traffic into a particular network slicing based on an operator’s control and its customer’s consent.

Thank you!

Best regards,
Shuping

From: Apn [mailto:[email-masked]] On Behalf Of Jeffrey (Zhaohui) Zhang
Sent: Saturday, July 31, 2021 5:28 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Apn] APN vs. Network Slicing

Hi Jim,

・        Ongoing IETF Network Slicing work already addresses the problem domain and solution
・        An IETF Network Slice provides the required connectivity between different entities in RAN and CN segments of an end-to-end network slice, with a specific performance commitment.
・        It is intended that IETF Network Slices can be created to meet specific requirements, typically expressed as bandwidth, latency, latency variation, and other desired or required characteristics.
・        An IETF Network Slice combines the connectivity resource requirements and associated network behaviors such as bandwidth, latency, jitter, and network functions with other resource behaviors such as compute and storage availability.
・        Term "Slice" refers to a set of characteristics and behaviors that separate one type of user-traffic from another.  IETF Network Slice assumes that an underlying network is capable of ... fulfilling all or some of SLOs to all of the traffic in the slice or to specific flows
・        Many approaches are currently being worked on to support IETF Network Slices in IP and MPLS networks with or without the use of Segment Routing.  Most of these approaches utilize a way of marking packets so that network nodes can apply specific routing and forwarding behaviors to packets that belong to different IETF Network Slices. Different mechanisms for marking packets have been proposed (including using MPLS labels and Segment Rouing segment IDs)
・        The realization can be achieved in a form of either physical or logical connectivity using VPNs, virtual networks (VNs), or a variety of tunneling technologies such as Segment Routing, MPLS, etc.
・        Slice Aggregate concept (similar to DiffServ Behavior Aggregate) in draft-bestbar is about identifying some or all traffic in a slice using opaque numbers and providing corresponding forwarding treatment
・        Forwarding/steering should be based on opaque numbers not structured APN IDs

Thanks.
Jeffrey

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 30 Jul 2021 22:53:25 +0100

Hi Jeffrey,

The formatting in your email may be a bit garbled, and I want to make sure
people understand the distinction between your opinions/assertions and what
is documented in draft-ietf-teas-ietf-network-slices. (Let me declare an
interest: I am currently the editor of that document.)

The material that is quoted from the TEAS draft (which is still a work in
progress) is

*	An IETF Network Slice provides the required connectivity between
different entities in RAN and CN segments of an end-to-end network slice,
with a specific performance commitment.
*	It is intended that IETF Network Slices can be created to meet
specific requirements, typically expressed as bandwidth, latency, latency
variation, and other desired or required characteristics.
*	An IETF Network Slice combines the connectivity resource
requirements and associated network behaviors such as bandwidth, latency,
jitter, and network functions with other resource behaviors such as compute
and storage availability.
*	Term "Slice" refers to a set of characteristics and behaviors that
separate one type of user-traffic from another.  IETF Network Slice assumes
that an underlying network is capable of ... fulfilling all or some of SLOs
to all of the traffic in the slice or to specific flows
*	Many approaches are currently being worked on to support IETF
Network Slices in IP and MPLS networks with or without the use of Segment
Routing.  Most of these approaches utilize a way of marking packets so that
network nodes can apply specific routing and forwarding behaviors to packets
that belong to different IETF Network Slices. Different mechanisms for
marking packets have been proposed (including using MPLS labels and Segment
Routing segment IDs)
*	The realization can be achieved in a form of either physical or
logical connectivity using VPNs, virtual networks (VNs), or a variety of
tunneling technologies such as Segment Routing, MPLS, etc.

The other points in your email are your opinions (and very glad you
expressed them).

I don’t think that what you quoted is particularly opposed to APN, but it
is notable (perhaps) that there are currently several proposals to achieve
similar things. If they are really trying to do the same thing then
inventing multiple approaches does not seem wise. If there is a good overlap
between approaches, it may be wise to make sure we select an approach that
is inclusive, unless we decide that specialism has a significant benefit.

These questions extend to how “markers” are applied to different
forwarding planes, and to what information is carried in a the markers.

Cheers,

Adrian

From: Apn <[email-masked]> On Behalf Of Jeffrey (Zhaohui) Zhang
Sent: 30 July 2021 22:28
To: [email-masked]
Cc: [email-masked]
Subject: [Apn] APN vs. Network Slicing

Hi Jim,

To follow up on your comments about APN vs. Slicing, here are some points
that I did not have time to exchange during the BoF.

- While slicing does involve setting aside/up resources, that is the means
to meet specific requirements for traffic delivery.

- Traffic delivered in network slices are identified by some identifiers so
that network nodes knows how to forward them to meet the requirements.
Combined with "slice aggregate" concept introduced in draft-bestbar-xxx
drafts, fine granularity can be achieved down to flow level (vs. slice
level).

In short, the goal of APN and slicing are the same (or slicing covers even
more). Additionally, it is not that slicing is a use case of APN. It's the
other way around - slicing does what APN want to do.

I could not get my one-page slide shared to better illustrate my point that
APN problem domain/solution are already covered by IETF slicing, but let me
post the text from that slide here. The sub-bullets are text quoted from the
network slicing framework
<https://datatracker.ietf.org/doc/html/draft-ietf-teas-ietf-network-slices>
https://datatracker.ietf.org/doc/html/draft-ietf-teas-ietf-network-slices。

*	Ongoing IETF Network Slicing work already addresses the problem
domain and solution

*	An IETF Network Slice provides the required connectivity between
different entities in RAN and CN segments of an end-to-end network slice,
with a specific performance commitment.
*	It is intended that IETF Network Slices can be created to meet
specific requirements, typically expressed as bandwidth, latency, latency
variation, and other desired or required characteristics.
*	An IETF Network Slice combines the connectivity resource
requirements and associated network behaviors such as bandwidth, latency,
jitter, and network functions with other resource behaviors such as compute
and storage availability.
*	Term "Slice" refers to a set of characteristics and behaviors that
separate one type of user-traffic from another.  IETF Network Slice assumes
that an underlying network is capable of ... fulfilling all or some of SLOs
to all of the traffic in the slice or to specific flows
*	Many approaches are currently being worked on to support IETF
Network Slices in IP and MPLS networks with or without the use of Segment
Routing.  Most of these approaches utilize a way of marking packets so that
network nodes can apply specific routing and forwarding behaviors to packets
that belong to different IETF Network Slices. Different mechanisms for
marking packets have been proposed (including using MPLS labels and Segment
Rouing segment IDs)
*	The realization can be achieved in a form of either physical or
logical connectivity using VPNs, virtual networks (VNs), or a variety of
tunneling technologies such as Segment Routing, MPLS, etc.
*	Slice Aggregate concept (similar to DiffServ Behavior Aggregate) in
draft-bestbar is about identifying some or all traffic in a slice using
opaque numbers and providing corresponding forwarding treatment

*	Forwarding/steering should be based on opaque numbers not structured
APN IDs

Thanks.

Jeffrey

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Sat, 31 Jul 2021 01:24:38 +0000

Hi Adrian,

Indeed you/some or maybe all just see a single level of indentation. In that case, the 1st and last bullet are supposed to be first level bullets and others are second level bullets that explain the first bullet (that IETF slicing covers the APN problem domain and solutions).

Also, the second last bullet（about “slice aggregate”）is also indeed my opinion (like the 1st and last) not quotes. Others are quotes from the IETF network slicing framework draft. Thank you for quoting them out correctly.

Please see more zzh> below.

From: Adrian Farrel <[email-masked]>
Sent: Friday, July 30, 2021 5:53 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: [Apn] APN vs. Network Slicing

[External Email. Be cautious of content]

Hi Jeffrey,

The formatting in your email may be a bit garbled, and I want to make sure people understand the distinction between your opinions/assertions and what is documented in draft-ietf-teas-ietf-network-slices. (Let me declare an interest: I am currently the editor of that document.)

The material that is quoted from the TEAS draft (which is still a work in progress) is

  *   An IETF Network Slice provides the required connectivity between different entities in RAN and CN segments of an end-to-end network slice, with a specific performance commitment.
  *   It is intended that IETF Network Slices can be created to meet specific requirements, typically expressed as bandwidth, latency, latency variation, and other desired or required characteristics.
  *   An IETF Network Slice combines the connectivity resource requirements and associated network behaviors such as bandwidth, latency, jitter, and network functions with other resource behaviors such as compute and storage availability.
  *   Term "Slice" refers to a set of characteristics and behaviors that separate one type of user-traffic from another.  IETF Network Slice assumes that an underlying network is capable of ... fulfilling all or some of SLOs to all of the traffic in the slice or to specific flows
  *   Many approaches are currently being worked on to support IETF Network Slices in IP and MPLS networks with or without the use of Segment Routing.  Most of these approaches utilize a way of marking packets so that network nodes can apply specific routing and forwarding behaviors to packets that belong to different IETF Network Slices. Different mechanisms for marking packets have been proposed (including using MPLS labels and Segment Routing segment IDs)
  *   The realization can be achieved in a form of either physical or logical connectivity using VPNs, virtual networks (VNs), or a variety of tunneling technologies such as Segment Routing, MPLS, etc.
The other points in your email are your opinions (and very glad you expressed them).

I don’t think that what you quoted is particularly opposed to APN, but it is notable (perhaps) that there are currently several proposals to achieve similar things. If they are really trying to do the same thing then inventing multiple approaches does not seem wise. If there is a good overlap between approaches, it may be wise to make sure we select an approach that is inclusive, unless we decide that specialism has a significant benefit.

Zzh> I am not against the APN problem domain. I do think it is in the scope of the slicing work (plus the “slice aggregate” concept in draft-bestbar that provides finer granularity below slices) and further discussion/work should be done in that framework instead of a new WG. Slicing is the solution for APN problem domain, not a use case for APN.

These questions extend to how “markers” are applied to different forwarding planes, and to what information is carried in a the markers.

Zzh> I do think markers should be simple opaque numbers w/o any structure defined. Besides that it simplifies the forwarding plane, it is also "future” proof. Imagine that a structure is defined for the APN ID to be a <app, user> tuple and hardware is built to parse the app/user fields. Then a new requirement comes up and now we need to add something else to the mix - we’d need to respin the hardware. But with a simple opaque number w/o any structure, it can be mapped to any combination and no new hardware is needed.

Zzh> If that is agreed on, then MPLS label does the job already for MPLS data plane; just like how the VXLAN VNI is the equivalent of an VPN label and SRv6 address’ func part can be the equivalent of a VPN label, those bits can also be used as opaque markers in APN or slicing.
Zzh> Instead of defining a new standalone opaque marker and put it as a new field in MPLS/V6/NOV3 headers, an MPLS label can be put into the VNI field, or become part of an IPv6 address, or even put into some kind of extension header. I don’t think that conflict with the goal of having a *generic* marker.

Zzh> Thanks!
Zzh> Jeffrey

Cheers,
Adrian

From: Apn <[email-masked]<mailto:[email-masked]>> On Behalf Of Jeffrey (Zhaohui) Zhang
Sent: 30 July 2021 22:28
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Apn] APN vs. Network Slicing

Hi Jim,

I could not get my one-page slide shared to better illustrate my point that APN problem domain/solution are already covered by IETF slicing, but let me post the text from that slide here. The sub-bullets are text quoted from the network slicing framework https://datatracker.ietf.org/doc/html/draft-ietf-teas-ietf-network-slices<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-ietf-teas-ietf-network-slices__;!!NEt6yMaO-gk!Tn0O_z_GumjnV0ysybB5jRF3-4MsafOLj8DW2cu5soF9C9dMSRUbgu78AEW1eNqe$>。

Thanks.
Jeffrey