Subject: [Apn] APN BoF, thoughts on what to standardize and what to not standardize

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 30 Jul 2021 21:23:01 +0000

Thanks to the chairs and presenters for an informative BoF.
We ran out of time before I was able to share my thoughts on the first two questions posed by the chairs, what to include and what to exclude from potential standardization related to APN. My thoughts are as follows:

1) Standardization of the APN attribute
I have seen the need for a well defined attribute such as this many times, not only in IETF, but also in MEF and the Linux Foundation. I believe the standardization of this would be useful, though I am not sure IETF is the best place to do it.

2) Determination of APN attribute to assign (non-standard) - exclude
This determination could be based on the 5-tuple or any other mechanism available to the operator, and since APN is meant to be used within the administrative domain of a single operator, there is no need to standardize.

3) Standardization of mechanism to encode, decode, and transport APN attribute within one or more existing encapsulation mechanism. 
Several people mentioned this. Rather than invent yet another encapsulation mechanism, show how the APN attribute could be used within the context of existing encapsulation mechanisms. 

4) Determination to what to do with the APN attribute (non-standard) - exclude
This is an operator specific determination. No need to standardize.

Cheers,
Charles

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Fri, 30 Jul 2021 21:38:06 +0000

Hi Charles, 

Many thanks for sharing your thoughts! You have clearly got the key points of the APN work, which made me extremely happy and cheered me up that I was actually being understood. 

I fully agree with you, and you are very welcomed to work together on these items. 

Besides the items we may also want to consider the control and management plane protocol extensions. 

Thank you and Cheers! 

Best Regards, 
Shuping 

> -----Original Message-----
> From: Apn [mailto:[email-masked]] On Behalf Of Charles Eckel
> (eckelcu)
> Sent: Saturday, July 31, 2021 5:23 AM
> To: [email-masked]
> Subject: [Apn] APN BoF, thoughts on what to standardize and what to not
> standardize
> 
> We ran out of time before I was able to share my thoughts on the first two
> questions posed by the chairs, what to include and what to exclude from
> potential standardization related to APN. My thoughts are as follows:
> 
> I have seen the need for a well defined attribute such as this many times, not
> only in IETF, but also in MEF and the Linux Foundation. I believe the
> standardization of this would be useful, though I am not sure IETF is the best
> place to do it.
> 
> 2) Determination of APN attribute to assign (non-standard) - exclude This
> determination could be based on the 5-tuple or any other mechanism
> available to the operator, and since APN is meant to be used within the
> administrative domain of a single operator, there is no need to standardize.
> 
> 3) Standardization of mechanism to encode, decode, and transport APN
> attribute within one or more existing encapsulation mechanism.
> Several people mentioned this. Rather than invent yet another encapsulation
> mechanism, show how the APN attribute could be used within the context of
> existing encapsulation mechanisms.
> 
> 4) Determination to what to do with the APN attribute (non-standard) -
> exclude This is an operator specific determination. No need to standardize.
> 
> Cheers,
> Charles
> --
> Apn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apn