Subject: ETSI defining ASN.1 (with derived XML schema)

From: Patrik Fältström <[email-masked]>
Date: Thu, 11 Sep 2008 12:07:17 +0200

Is anyone working with the ETSI standard for how to transfer data  
between providers of services and law enforcement agencies when  
talking about data retention?

They are defining an ASN.1 format of the data, and then they have the  
intention (as it seems) to derive an XML schema from it. When talking  
with ETSI, they are interested in getting help from IETF, and if  
someone is interested in helping, please help. I can help with  
contacts if you do not have any.

<http://www.3gpp.org/ftp/TSG_SA/WG3_Security/TSGS3_LI/2007_26_KeyWest/Docs/SA3LI07_080_DTS-LI-00033_V0.4.0._RD_HO.doc 

    Patrik

_______________________________________________
Apps-Discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: John C Klensin <[email-masked]>
Date: Thu, 11 Sep 2008 10:54:42 -0400

--On Thursday, 11 September, 2008 12:07 +0200 Patrik Fältström
<[email-masked]> wrote:

> Is anyone working with the ETSI standard for how to transfer
> data   between providers of services and law enforcement
> agencies when   talking about data retention?
> 
> They are defining an ASN.1 format of the data, and then they
> have the   intention (as it seems) to derive an XML schema
> from it. When talking   with ETSI, they are interested in
> getting help from IETF, and if   someone is interested in
> helping, please help. I can help with   contacts if you do not
> have any.
> 
> <http://www.3gpp.org/ftp/TSG_SA/WG3_Security/TSGS3_LI/2007_26_
> KeyWest/Docs/SA3LI07_080_DTS-LI-00033_V0.4.0._RD_HO.doc  >

Patrik,

Did you also forward this to the ECRIT folks (and Fred)?  If
not, please do so -- it would seem to me, at least in my
ignorance, that right way to approach this problem would be to
extend the ECRIT model to deal with this type of message, rather
than reinventing the wheel, much less by using ASN.1 as a
starting point.  And there is already supposed to be a close
liaison relationship between ECRIT and ETSI.

   john

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 11 Sep 2008 17:01:19 +0200

> liaison relationship between ECRIT and ETSI.

Ok, good point. Let me send to them as well.

    Patrik

---

From: [email-masked]
Date: Thu, 11 Sep 2008 16:13:36 +0100

> starting point.

John,

Thus far, as I understand it, there has been a complete seperation between 
the need to place a call in real-time to the emergency services, and the 
potential requirements of the law enforcement agencies for retrospective 
access to logs and location information.

This is also the case at NICC in the UK where we've been working on the 
architecture for determining the location of VoIP callers.

I humbly suggest therefore that ECRIT is _not_ the place for this work.

kind regards,

Ray

-- 
Ray Bellis, MA(Oxon)
Senior Researcher in Advanced Projects, Nominet
e: [email-masked], t: +44 1865 332211
_______________________________________________
Apps-Discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 11 Sep 2008 17:16:19 +0200

> I humbly suggest therefore that ECRIT is _not_ the place for this  

The work is already done at ETSI, it is only me being nervous the work  
MIGHT be done without whatever help might be needed from IETF, given  
the experience IETF has with designing similar protocols.

I am trying to understand the landscape.

    Patrik

---

From: John C Klensin <[email-masked]>
Date: Thu, 11 Sep 2008 11:34:08 -0400

--On Thursday, 11 September, 2008 16:13 +0100
[email-masked] wrote:

>> extend the ECRIT model to deal with this type of message,
>> rather than reinventing the wheel, much less by using ASN.1
>> as a starting point.
> 
> John,
> 
> Thus far, as I understand it, there has been a complete
> seperation between  the need to place a call in real-time to
> the emergency services, and the  potential requirements of the
> law enforcement agencies for retrospective  access to logs and
> location information.
> 
> This is also the case at NICC in the UK where we've been
> working on the  architecture for determining the location of
> VoIP callers.
> 

Ray, 

Let me make a distinction that may not have been clear in my
note to Patrik.

>From his note, these people are designing a format for
transmitting messages from law enforcement agencies and
providers.  Presumably, they are also addressing the other
issues associated with such messages and their implications and
processing.

ECRIT deals with a different class of messages, but its work
includes a format that the law enforcement agencies and
providers are, among others, going to need to support.   The WG
has, I understand, been concerned about integrity and
authentication of those messages.

I dislike reinvention of the wheel.  I think that having two
uses for the same basic formats tends to strengthen, and promote
deployment of, both applications.   Conversely, I don't believe
that encouraging law enforcement to use unique formats for their
messages (and requests and/or demands) will deter them from
sending such messages.  If unique formats accomplish anything at
all, it is to increase costs to taxpayers and to make it easier
to hide the tracks associated with questionable investigations.

Consequently, if ETSI is headed down this path, I think that
ECRIT _formats_ (and maybe other work) would be a better
starting point than ASN.1, a clean sheet of paper, and the
intent to create an XML representation of the ASN.1   I did not,
in any way, intend to suggest that the ECRIT WG get involved in
this particular piece of work except, if needed, to advise them
on compatibility of formats.

best,
     john

---

From: Eric Burger <[email-masked]>
Date: Sun, 14 Sep 2008 21:04:57 -0400

Pardon my ignorance, but is there something here more than X.693?

---

From: Patrik Fältström <[email-masked]>
Date: Mon, 15 Sep 2008 06:10:37 +0200

Not if the original format really is a valid good ASN.1, no. And if I  
now understand correctly it is defined in ASN.1 because LI handover  
protocol(s) are defined using ASN.1. They have now added XML (via X. 
693 I hope, I will check) just so people can choose XML if they want.  
Or rather, it is the other way around. They wanted to have XML format  
only, but people working with LI that uses ASN.1 and ber wanted to use  
the same base protocols for data retention.

But my overall question was whether anyone in IETF was _also_ working  
with this ETSI standard, or if I am the closest individual (that only  
passively watch what ETSI is doing).

    Patrik