Subject: [APPS-REVIEW] Fwd: review request: draft-ietf-ippm-storetraceroutes-03

From: Lisa Dusseault <[email-masked]>
Date: Mon, 23 Apr 2007 15:00:53 -0700

Did this ever get through and result in a review?  I think it didn't  
-- I don't see an entry on the XML-Dir archives.

I'm sending to the Apps review  list as well.

thanks,
Lisa

Begin forwarded message:

> From: Lars Eggert <[email-masked]>
> Date: March 13, 2007 6:27:04 AM PDT
> To: Ted Hardie <[email-masked]>, "Lisa M. Dusseault"  
> <[email-masked]>, [email-masked]
> Subject: Fwd: review request: draft-ietf-ippm-storetraceroutes-03
>
> FYI, forgot to CC the ADs on my email to xml-dir.
>
> Begin forwarded message:
>
>> From: Lars Eggert <[email-masked]>
>> Date: March 13, 2007 15:16:50 GMT+02:00
>> To: [email-masked]
>> Cc: [email-masked]
>> Subject: review request: draft-ietf-ippm-storetraceroutes-03
>>
>> Hi,
>>
>> I think draft-ietf-ippm-storetraceroutes-03 would benefit from an  
>> XML directorate review  during its WG last call - would you assign  
>> a reviewer?
>>
>> (AFAIK, the XML directorate hasn't looked at this yet.)
>>
>> Thanks,
>> Lars
>>
>> Begin forwarded message:
>>> From: "ext Henk Uijterwaal" <[email-masked]>
>>> Date: March 13, 2007 9:35:56 GMT+02:00
>>> To: IETF IPPM WG <[email-masked]>
>>> Subject: [ippm] WGLC for draft-ietf-ippm-storetraceroutes-03.txt
>>>
>>> IPPM group,
>>>
>>> The draft "Traceroute Measurements Information Model and XML Data  
>>> Model"
>>> (draft-ietf-ippm-storetraceroutes-03.txt) has been discussed  
>>> extensively
>>> in this group and all comments have been addressed.  In addition,  
>>> members
>>> of the OGF Network Measurement WG have examined it for compatibility
>>> with their set of measurement schemas. We would like to start a  
>>> WGLC on
>>> it in order to move it forward. Please raise any remaining issues by
>>> Tuesday, April 10, 9:00 UTC.  An URL for the draft is:
>>>
>>> http://www.ietf.org/internet-drafts/draft-ietf-ippm- 
>>> storetraceroutes-03.txt
>>>
>>> Matt & Henk
>>>
>>
>
> Lars
>
>

_______________________________________________
APPS-REVIEW mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/apps-review

---

From: Ned Freed <[email-masked]>
Date: Mon, 23 Apr 2007 18:00:56 -0700 (PDT)

> -- I don't see an entry on the XML-Dir archives.

I don't believe it came through previously but I may have missed it.

A few comments...

First of all, a fair amount of this document seems to be concerned with matters
having little to do with the stated goal of defining an information
model and XML data model for traceroute. There's a bunch of stuff about
traceroute parameters on different platforms and accuracy that while I'm
sure were useful in developing the models, seem a bit out of place in the
final document defining the models. Perhaps this material could be
moved to a separate informational document and thereby reduce the
length of this to something less than 45 pages?

Second, I scanned the schema and the overall design seems basically OK. (There
is, however, a bunch of stuff in there that I don't know anything about, such
as MPLS labels. Maybe the traceroutes I'm used to are aenemic by modern
standards...) However, the document would benefit TREMENDOUSLY from the
addition of some examples showing the format in use. I use XML Schema so often
that I can get a rough sense of the overall format from looking at it but I
somewhat doubt if this is a skill generally shared by most readers. And the
accompanying text descriptions seem a bit light on describing the overall
structure.

Third, I extracted the schema and ran it through a validator, and there
are a number of errors:

    <xs:complexType name="_inetAddressASNumber">
       <xs:annotation>
         <xs:documentation>Specifies the AS number of a hop in the
         traceroute path as a 24 bit number and the indication how
         the mapping from IP address to AS number was performed.
         </xs:documentation>
       <xs:sequence>
         <xs:element name="asNumber"
                     type="_asNumber"/>
         <xs:element name="ipASNumberMappingType"
                     type="_ipASNumberMappingType"/>
       </xs:sequence>
     </xs:complexType>

The closing </xs:annotation> is missing.

<xs:complexType name="_RoundTripTime">
       <xs:annotation>
         <xs:documentation>Specifies the amount of time measured
         in milliseconds from when a probe was sent to when its
         response was received or when it timed out. The value
         of this element is reported as the truncation of the
         number reported by the traceroute tool (the output
         "&lt1 ms" is therefore encoded as 0 ms).
         A string with the value of "RoundTripTimeNotAvailable"
         means either the probe was lost because of a timeout
         or it was not possible to transmit a probe.
         Units are: milliseconds.
         </xs:documentation>
       </xs:annotation>
       <xs:choice>
           <xs:element name="probeRoundTripTime"
                       type="_probeRoundTripTime"/>
           <xs:element name="probeRoundTripTimeNotAvailable"
                       type="_probeRoundTripTime"/>
       </xs:choice>
     </xs:complexType>

The "&lt" should have a semicolon appended.

Those are the only errors preventing the schema from being well formed.
However, there are two validation errors:

     <xs:restriction base="xs:unsignedInt">
         <xs:maxExclusive value="4294967296"/>
  
Value '4294967296' is not facet-valid with respect to maxInclusive '4294967295'
for type 'unsignedInt'.

And my validator is saying something is wrong with _traceRoute that I didn't
bother to decipher:

Error resolving component '_traceRoute'. It was detected that '_traceRoute' has
no namespace, but components with no target namespace are not referenceable
from this schema document. If '_traceRoute' is intended to have a namespace,
perhaps a prefix needs to be provided. If it is intended that '_traceRoute' has
no namespace, then an 'import' without a "namespace" attribute should be added
to the file.

Not having any data to try against the schema, I stopped without fixing the
validation errors. But errors like this do make me wonder if the schema has
actually been applied to real data in this format...

				Ned