Subject: [aqm] Nugget from IETF-1 proceedings

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 17 Jan 2014 08:46:37 +0000

Nothing new under the sun. Proceedings from the very first IETF meeting, held 28 years ago today:

"Nagle presented his 'fair queuing' scheme, in which gateways maintain separate queues for each sending host. In this way, hosts with pathological implementations can not usurp more than their fair share of the gateway’s resources. This invoked spirited and interested discussion. Zhang pointed out that this was a subtle change in architecture away from a pure datagram network. Callon reminded everyone that he had written a paper advocating a connection oriented Internet Protocol several years ago."

https://www.ietf.org/proceedings/01.pdf, page 5

Lars

---

From: Dave Taht <[email-masked]>
Date: Fri, 17 Jan 2014 08:28:51 -0500

> https://www.ietf.org/proceedings/01.pdf, page 5

It actually starts at page 88.

Reading the rest was great. Wow. What a wonderful piece of history!
Thank you for digging that up!

Seeing the problems they were trying to solve at the time was very revealing.

"1000 nodes running at 9600 baud, with one outage every 5 minutes will
only use 20% of the bandwidth for routing information"

And nagles preso retains many cogent points, although I guess "source
quench" was all the rage at the time.

> Lars
>
> _______________________________________________
> aqm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aqm
>

-- 
Dave Täht

Fixing bufferbloat with cerowrt: http://www.teklibre.com/cerowrt/subscribe.html

---

From: Lixia Zhang <[email-masked]>
Date: Fri, 17 Jan 2014 20:56:57 -0800

> https://www.ietf.org/proceedings/01.pdf, page 5

thanks for digging this out!  My memory for that meeting totally faded away, other than the weather was gorgeous (compared to Boson;)

I got into networking in 1981, I recall a number of other Internet meetings before this one but I guess they left no traces...  it is great that people spent serious effort to keep IETF history.

Lixia
PS: about that "subtle change away from pure datagram" comment: it's amusing how little we/I understood the issue of keeping state inside network at the time.