Subject: [aqm] CoDel: After much ado ...

From: Jana Iyengar <[email-masked]>
Date: Mon, 11 Sep 2017 17:27:14 -0700

... draft-ietf-aqm-codel-08
<https://tools.ietf.org/html/draft-ietf-aqm-codel> is finally posted. This
new version addresses all IESG comments during IESG review, in addition to
review comments by Patrick Timmons and Yoav Nir. We thank everyone for
their help with reviews.

Most importantly, I want to personally thank the fq_codel authors for
sending me Yerba Mate <https://photos.app.goo.gl/IiOG6BAN9beHRIZQ2>, Dave
Taht for sending me delicious freshly-baked cookies
<https://photos.app.goo.gl/cmbi3aTHL0JmnLRk2>, and Paul McKenney for
sending me a ton of organic green tea
<https://photos.app.goo.gl/BSQZKLARM8lNfZMr2> to help me move on the
document. I will say that you all managed to do something nobody has
managed so far: you successfully shamed me into getting this work done.

I also received bungee cords <https://photos.app.goo.gl/w6TjHDbNaJvIzajd2>
from the fq_codel authors to tie myself to my chair with, which I put to
good use: I would like to share here evidence of my atonement
<https://photos.app.goo.gl/M84GDVlQC62W4eHv2>. (Cookies are not in the
picture, because they were delicious. Thanks, Dave!)

- jana

(P.S.: I now look forward to receiving thank you gifts. Oh, and I'm
caffeine-free and vegetarian, just in case.)

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Tue, 12 Sep 2017 10:32:38 +0200

> review comments by Patrick Timmons and Yoav Nir. We thank everyone for

And there was much rejoicing! Yay, well done :)

> picture, because they were delicious. Thanks, Dave!)

This is beyond awesome. Thank you for sharing the pictures :D

> caffeine-free and vegetarian, just in case.)

Let's get the RFC published first, shall we? ;)

-Toke

---

From: Dave Taht <[email-masked]>
Date: Tue, 12 Sep 2017 09:31:28 -0700

Jana Iyengar <[email-masked]> writes:

> ... draft-ietf-aqm-codel-08 is finally posted. This new version addresses all
> IESG comments during IESG review, in addition to review comments by Patrick
> Timmons and Yoav Nir. We thank everyone for their help with reviews. 
>
> Most importantly, I want to personally thank the fq_codel authors for sending me
> Yerba Mate, Dave Taht for sending me delicious freshly-baked cookies, and Paul
> McKenney for sending me a ton of organic green tea to help me move on the
> document. I will say that you all managed to do something nobody has managed so
> far: you successfully shamed me into getting this work done.
>
> I also received bungee cords from the fq_codel authors to tie myself to my chair
> with, which I put to good use: I would like to share here evidence of my
> atonement. (Cookies are not in the picture, because they were delicious. Thanks,
> Dave!)

Yer welcome, and thank you VERY MUCH for completing this. I got some
bungee cords for myself, too, as I have more than a few things 98% done
I'd like to get off my plate.

Perhaps we could include these new concepts in future standards for the
RFC creation processes?

However, I think at least one new hardware standard is necessary. There
needs to be some sort of laptop mounting bracket for the cookies and a
powerful feedback loop between interface and future IOT enabled-bungee
cords. Particularly, reaching for the mouse, rather than cookies or tea,
should be de-incentivised. I couldn't come up with a good way to
distinguish between those forms of muscular traffic.

> _______________________________________________
> aqm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aqm

---

From: Mirja Kühlewind <[email-masked]>
Date: Tue, 12 Sep 2017 19:18:31 +0200

Do I get gifts as well if I delay the final publication for long enough 
now...? ;-)

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Tue, 12 Sep 2017 19:56:20 +0200

Mirja Kühlewind <[email-masked]> writes:

> Do I get gifts as well if I delay the final publication for long
> enough now...? ;-)

I fear what we got for Jana was the last items on the gift shop's "thank
you for delaying our draft" shelf. But I do believe there were a couple
of items left on the "thank you for expediting publication of our draft"
shelf. And that shelf is much nicer anyway...  ;)

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Sep 2017 11:16:38 -0700

> shelf. And that shelf is much nicer anyway...  ;)

hah! I wasn't sure if I should've waited longer... now I know :-)

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Fri, 15 Sep 2017 12:24:13 +0200

Hi Jana again,

I really don’t want to hold up the doc any further but... I had a quick look at the changes and the comments, and have a few more questions to you how or if those points where address. I hope this is really quick.

1) Did you also check the sec-art and gen-art review. Both, as well as some ADs, suggested to (better) define such terms as Sojourn time, estimator, or Interval. Would it make sense to add something to the terminology section, or did you decide this is not needed?

2) Did you see Alia’s comments on mircoflows? I think it is true that in some cases you may also want to use additional information like the flow label or DSCP and not just the 5-tuple, while the text explicitly talks about 5-tuples. Do you want to add something here, or did you on purpose decide to only restrict to 5-tuples? I thinks this may be an unnecessary restriction and probably was not meant to be one.

3) Did you see this comment from Ekr:
"Following up on the above point, you must be able to
  drop packets when the queue is entirely full, but S
  4.4 doesn't seem to contemplate this. What is the impact
  of this? You just drop and ignore?“
Can you explain how this was addressed? Maybe I just missed that but it seems important.

Thanks!
Mirja

> Am 12.09.2017 um 02:27 schrieb Jana Iyengar <[email-masked]>:
> 
> ... draft-ietf-aqm-codel-08 is finally posted. This new version addresses all IESG comments during IESG review, in addition to review comments by Patrick Timmons and Yoav Nir. We thank everyone for their help with reviews. 
> 
> Most importantly, I want to personally thank the fq_codel authors for sending me Yerba Mate, Dave Taht for sending me delicious freshly-baked cookies, and Paul McKenney for sending me a ton of organic green tea to help me move on the document. I will say that you all managed to do something nobody has managed so far: you successfully shamed me into getting this work done.
> 
> I also received bungee cords from the fq_codel authors to tie myself to my chair with, which I put to good use: I would like to share here evidence of my atonement. (Cookies are not in the picture, because they were delicious. Thanks, Dave!)
> 
> - jana
> 
> (P.S.: I now look forward to receiving thank you gifts. Oh, and I'm caffeine-free and vegetarian, just in case.)
>

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 29 Sep 2017 18:01:44 -0700

Mirja,

Thanks for you review -- apologies for not addressing everything. I had
left a few things out as not necessary to change the draft, but we've now
made the following changes in draft-ietf-aqm-codel-09
<https://tools.ietf.org/html/draft-ietf-aqm-codel-09>.

1) Did you also check the sec-art and gen-art review. Both, as well as some
> ADs, suggested to (better) define such terms as Sojourn time, estimator, or
> Interval. Would it make sense to add something to the terminology section,
> or did you decide this is not needed?
>

We've added these definitons now in Section 2.

> 2) Did you see Alia’s comments on mircoflows? I think it is true that in
> some cases you may also want to use additional information like the flow
> label or DSCP and not just the 5-tuple, while the text explicitly talks
> about 5-tuples. Do you want to add something here, or did you on purpose
> decide to only restrict to 5-tuples? I thinks this may be an unnecessary
> restriction and probably was not meant to be one.
>

We fixed the draft to remove mentions of 5-tuples. (This was already done
in -08.)

> Can you explain how this was addressed? Maybe I just missed that but it

There's nothing to be done if a packet arrives at a full buffer besides
dropping it... we've added a sentence now that says "Packets arriving at a
full buffer SHOULD be dropped." Hopefully that should clarify things.

Hope this covers everything that's pending -- let me know if I've missed
anything.

(I received jim-jam biscuits/cookies from Jim Gettys which helped with this
round -- thanks Jim :-))

- jana

Thanks!
> > ... draft-ietf-aqm-codel-08 is finally posted. This new version
> addresses all IESG comments during IESG review, in addition to review
> comments by Patrick Timmons and Yoav Nir. We thank everyone for their help
> with reviews.
> >
> sending me Yerba Mate, Dave Taht for sending me delicious freshly-baked
> cookies, and Paul McKenney for sending me a ton of organic green tea to
> help me move on the document. I will say that you all managed to do
> something nobody has managed so far: you successfully shamed me into
> getting this work done.
> >
> > I also received bungee cords from the fq_codel authors to tie myself to
> my chair with, which I put to good use: I would like to share here evidence
> of my atonement. (Cookies are not in the picture, because they were
> delicious. Thanks, Dave!)
> >
> > - jana
> >