Subject: Re: [armd] Updated ARMD Charter and Milestones

From: Ralph Droms <[email-masked]>
Date: Wed, 2 Feb 2011 17:33:36 -0500

Linda - can you point me at the latest rev of the draft charter?  Thanks.

- Ralph

On Jan 28, 2011, at 3:01 PM 1/28/11, Linda Dunbar wrote:

> Jari, 
> 
> Thank you very much for the comments. I will update it and upload to the website. 
> 
> Linda
> 
> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]] 
> Sent: Thursday, January 27, 2011 1:26 AM
> To: Linda Dunbar
> Cc: [email-masked]; [email-masked]; 'Hares Susan'
> Subject: Re: Updated ARMD Charter and Milestones
> 
> Linda,
> 
> Thanks for suggesting text. I have a few comments on this. The main
> comment is that I do not think we are ready to create a working group
> that actually develops the solutions. I would like to see the "document
> the scaling characteristics" stage successfully completed first before
> chartering any work on solutions. This is not to say that we can't do
> the work -- even in the schedule you outline in the milestones -- but at
> least I personally have some trouble committing to the solution part
> before I fully understand the current characteristics.
> 
> So from my perspective I'd remove the solution milestones and text
> discussing that part of the work. I would also change the objectives as
> follows:
> 
> (1）To document the scaling characteristics of ARP (IPv4) and ND (IPv6)
> with respect to increasing numbers of hosts in data centers, (2) to
> identify limitations of ARP and ND in such environments, (3) provide
> design recommendations intended to minimize issues associated with the
> identified limitations, and (4) to develop appropriate solutions to
> better support data centers with large number of hosts.
> 
> =>
> 
> （1）To document the scaling characteristics of ARP (IPv4) and ND (IPv6)
> with respect to increasing numbers of hosts in data centers and (2)
> provide operational recommendations intended to minimize issues
> associated with the limits inherent in these characteristics.
> 
> (Just my $0.02, of course, not wearing any hats at the moment.)
> 
> Jari
>

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 03 Feb 2011 16:17:52 +0000

Hi Ralph,

I revise the ARMD Charter statement based on Jari's suggestion. Here it is.

ARMD: Address Resolution for Massive number of hosts in Data Center

Working Group objectives:  （1）To document the scaling characteristics of ARP (IPv4) and ND (IPv6) with respect to increasing numbers of hosts in data centers and (2)to provide operational recommendations intended to minimize issues associated with the limits inherent in these characteristics.
 .

Description of Working Group:
Data Center Networks may be required to support a very large number of attached hosts.  This is often the case in virtualization environments where hosts are instantiated as Virtual Machines (VMs).  In such environments, many VMs may be associated with each physical server. A VM is configured with one or more ports, each of which corresponds to an IP host interface providing attachment to a distinct IP subnet (e.g., IEEE 802.1Q VLAN).

In a virtualized data center, a VM may be placed on any physical server. A variety of algorithms can be applied to select the location of a VM. Resource aware algorithms (e.g. energy, bandwidth, etc,) will use a placement that satisfies the processing requirements of each VM but require the minimal number of physical servers and switching devices.  Data center administrators have long desired the flexibility of being able to relocate hosts from over utilized servers to underutilized servers without the restriction of where they are.
With this, and similar types of assignment algorithm, subnets tend to extend throughout the network. Then ARP/ND traffic associated with each subnet is likely to traverse a significant number of links and switches in the network.  Thus, in the case of the virtualized data center, the partition of the physical network into multiple subnetworks may not confine ARP/ND to a limited number of links/switches as might otherwise be expected.
Another side effect of hosts belonging to one subnet being spread across multiple TOR switches, is that those TOR switches’ filtering data bases (FDBs) are frequently refreshed by ARP/ND broadcast/multicast messages. Most likely, the frequency of ARP/ND by hosts is shorter then TOR’s FDB MAC aging time. That means TOR’s FDB never age out any MAC entries. For switches whose FDB capacity is less than all the hosts among all VLANs using that switch, some MAC entries will be lost due to the FDB being full instead of being aged out. Under those circumstances, packets for those MACs will be flooded across the entire network.
The ARMD work would proceed in phases.  The initial phase will document the scaling characteristics of ARP/ND in the data center environment, identify limitations implied by the scaling characteristics, and provide recommendations with respect to network design for minimizing issues associated with the identified limitations. A later phase would address potential solutions to make ARP/ND protocols scale in such environments.
Goals and Milestones:
*       March 2011:     Problem statement
*       March ~Nov 2011: ARP/ND statistics collection and behavior analysis in various Data Center environments, including but not limited to:
o       Many subnets with various sizes
o       Subnets with hosts on VMs and VMs migrate over time
o       Subnets with some hosts on local VMs and others on VMs in the cloud (like Amazon’s EC2).
o       Large subnet

*       July 2011 ~ March 2012: Recommendation on how to avoid or minimize the issues caused by ARP/ND
*       Nov 2011: Gap Analysis Statement within Data Center
o       Gaps within ARP
o       Gaps within IPv6 ND or autoconfiguration
*       Nov 2011: Survey of Existing Solutions
o       Survey of NHRP (RFC2332) & SCSP (RFC2334),  and their applicability to Ethernet networks;
o       Survey of TRILL work as a potential solution;
o       Survey of  other potential solutions, like MOOSE or SEATTLE; and
o       Other proposals
*       Nov 2011: Security Analysis of Existing Solutions
o       Study existing solutions, like Dynamic ARP Inspection, Egress ARP Inspection, etc, and evaluate if any of them or others should be included in the solutions specified by this working group.

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]]
Sent: Wednesday, February 02, 2011 4:34 PM
To: Linda Dunbar
Cc: Ralph Droms; Jari Arkko; [email-masked]; 'Hares Susan'
Subject: Re: Updated ARMD Charter and Milestones

- Ralph