Subject: [Asdf] Roman Danyliw's No Objection on charter-ietf-asdf-00-00: (with COMMENT)

From: Roman Danyliw via Datatracker <[email-masked]>
Date: Wed, 09 Sep 2020 11:01:53 -0700

Roman Danyliw has entered the following ballot position for
charter-ietf-asdf-00-00: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-asdf/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

** What is "Thing Interaction and Data Modelling"?

** What is currently outstanding to make SDF “IEFT quality”?  I worry that the
text currently reads as “start with SDF and make it better”.

** What does "working with experts from OneDM and its contributing
organizations" practically mean?  Is this something other than the participants
who previously worked on SDF will now continue working on it in the IETF?  Is
there some formal liaison activity?

** Per "model harmonization,”  is that trying to streamline the “200 models in
the SDF format”?  How wide of scope will this be?  How does one know if one is
done “harmonizing”?

** What does the collaboration with the IRTF FDT group entail?

---

From: Niklas Widell <[email-masked]>
Date: Thu, 10 Sep 2020 08:46:29 +0000

Hi Roman, 
Thanks for comments

On 2020-09-09, 20:02, "Roman Danyliw via Datatracker" <[email-masked]> wrote:

How to model the interactions with Things ( IoT devices) and the data that those interactions involve. It is further described in the background (second paragraph).  Agree that it is a bit terse, but it is really all there is to it. 

At least two things are outstanding,  (1) technical scrutiny/review/input/insights from the wider IETF community to improve quality, which I guess is related to your interpretation, and (2) feature growth based on reaching more groups/SDOs than was possible when the work was limited to pre-going-public OneDM, that will allow for wider thing model interoperability than was possible before (i.e., to model things from a wider range of ecosystems). So the work's scope will remain the same, but its capability to model a wider set of things/ecosystems will (hopefully) improve. 

You are right, the expectation is that the folks doing SDF in OneDM will now do it IETF in instead, with others joining in. OneDM is not a new organization, it is a liaison activity between IoT SDOs. As long as there is no wish from IETF to be involved in the governance setup of OneDM, there is no need from what I can tell for formal liaison. 

The actual harmonization of the models is done in OneDM. With harmonization is meant the process of aligning candidate models for a particular thing type from the contributing ecosystems into a common model expressed in SDF hosted by OneDM. For instance, both IPSO and OCF have models for temperature, the harmonization process takes these two models and aligns them into a OneDM temperature model in described in SDF, that can then be used in both IPSO and OCF by translating back to their respective model formats. Getting this process right is the headache of the OneDM group right now, but a key building block of that process is to have SDF in place. 
FWIW, OneDM and SDF provides value even before the harmonization process and the resulting repository of models is in place, most models contributed to OneDM's playground repo come from industry standards already (e.g., from IPSO and OCF) so they are useful out of the box. 

Largely speculative and TBD, but the assumption is that there could be interesting insights from formal design that could influence SDF

Cheers,
Niklas

---

From: Michael Richardson <[email-masked]>
Date: Thu, 10 Sep 2020 15:07:27 -0400

Niklas Widell <niklas.widell=[email-masked]> wrote:
    > organizations" practically mean?  Is this something other than the
    > participants who previously worked on SDF will now continue working on
    > it in the IETF?  Is there some formal liaison activity?

    > You are right, the expectation is that the folks doing SDF in OneDM
    > will now do it IETF in instead, with others joining in. OneDM is not a
    > new organization, it is a liaison activity between IoT SDOs. As long as
    > there is no wish from IETF to be involved in the governance setup of
    > OneDM, there is no need from what I can tell for formal liaison.

AFAIK, I think that it would be more correct to say:

  ** OneDM is not an organization, it is a liaison activity between IoT SDOs.**

It doesn't really exist as a legal entity.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide