Subject: [Asdf] Benjamin Kaduk's No Objection on charter-ietf-asdf-00-01: (with COMMENT)

From: Benjamin Kaduk via Datatracker <[email-masked]>
Date: Wed, 09 Sep 2020 17:27:08 -0700

Benjamin Kaduk has entered the following ballot position for
charter-ietf-asdf-00-01: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-asdf/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Roman's point about the lack of a gap analysis between "what SDF is now" and
"what the final product should be" is spot-on.

It also seems pretty important to have a clear picture about what the expected
relationship between OneDM and the IETF/this WG is to be.

In a related vein, do we have a sense of who will participate that is not
already participating in OneDM?

I suspect that some of the terminology used here will not be familiar to all
IETF participants; is the expectation to just roll the terminology/definitions
into the main spec?

It's a bit unclear to me how SDFs relate to TDTs (though I don't expect the
answer to need to be in the charter).

---

From: Niklas Widell <[email-masked]>
Date: Thu, 10 Sep 2020 12:22:04 +0000

Hi Benjamin, 
Thanks for your comments. 

On 2020-09-10, 02:27, "Benjamin Kaduk via Datatracker" <[email-masked]> wrote:

One additional aspect in addition to what I replied to Roman is that there from OneDM perspective is an interest in getting the job done and finished within reasonable time without rush, to be able to settle the harmonized models and their repository. 
An example of a identified new feature is for improved modelling of thing and object composition (aka complex objects), where the current draft is insufficient already today. Other features requests will likely come as other ecosystems join, and may be incorporated based on WG decision given normal considerations (value/within scope/within time etc).  

From IETF perspective OneDM is a user group to the work being done in ASDF. 

As was mentioned in the BoF the OneDM group had limited membership until recently for historical reasons, but it is now "public" and open for participation. Anecdotal evidence indicates that there is interest in other quarters (i.e., other IoT related standards communities), how much that translates into interest in OneDM participation and/or in ASDF participation remains to be seen. 

Good point. Regarding the terminology coming from OneDM that is not totally stable yet either

(assuming you mean W3C's Thing Description Templates) TDs describe specific instances of things, while a TDT is a template/class for those instances. SDF models would also be something like a class description, but coming from a different perspective than TDTs. There are both similarities and differences, and there is an ongoing discussion on the relationship in T2TRG's WISHI group. 

Cheers, 
Niklas