Subject: [Asdf] PR #15: sdfType (addressing issue #13)

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Feb 2021 14:23:16 +0100

I have submitted a pull request to address issue 13.
Clearly, this is a minimal solution of the issue just for SDF 1.1, but I think it is providing the right way forward for data types that we need to have in the SDF information model but cannot represent in the data model using JSON values except by defining a convention for that.

https://raw.githack.com/ietf-wg-asdf/SDF/sdftype/sdf.html#name-sdftype

Comments welcome.
Once issue 13 is done, I would submit draft-ietf-asdf-sdf-02, and we can have an “implementation draft” consensus call (for SDF 1.1).

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Feb 2021 16:11:58 +0100

… and there is now one little update from the discussion we just had in the OneDM call.

The whole PR is a really small change, so please fire away the reviews (in Github or here)...

https://github.com/ietf-wg-asdf/SDF/pull/15

Grüße, Carsten

> On 2021-02-08, at 14:23, Carsten Bormann <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Feb 2021 17:35:34 +0100

> Once issue 13 is done, I would submit draft-ietf-asdf-sdf-02, and we can have an “implementation draft” consensus call (for SDF 1.1).

That went quick, three approvals within an hour of the last update, thank you!

I have submitted -02 with these changes.
If the chairs think that is the appropriate next step, I would like to ask them to issue a consensus call that we can adopt -02 (or an updated version -03) as an implementation draft, also known as SDF 1.1.

Grüße, Carsten