Subject: [Asrg] MTP draft

From: Hadmut Danisch <[email-masked]>
Date: Tue, 4 Mar 2003 17:02:29 +0100

Hi,

it was already mentioned that a redesign of the Transfer
Protocol might be taken into consideration. I was already
collecting some thoughts when this working group came up.

Due to the forthcoming IETF meeting, it is currently not
possible to submit drafts. But if anyone likes to have
a glance at it:

http://www.danisch.de/tmp/draft_mtp.txt

regards
Hadmut
_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: Martin hepworth <[email-masked]>
Date: Tue, 04 Mar 2003 16:17:21 +0000

Hadmut

wouldn't it be better to specify an XML schema so you can track the 
incoming message format version for syntax checking? I know http has 
it's uses, but doing an ugly back fit schema was a pain.

-- 
Martin Hepworth
Senior Systems Administrator
Solid State Logic Ltd
+44 (0)1865 842300

**********************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

This footnote also confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.

www.mimesweeper.com
**********************************************************************

---

From: Hadmut Danisch <[email-masked]>
Date: Tue, 4 Mar 2003 17:37:04 +0100

> it's uses, but doing an ugly back fit schema was a pain.

Well, that's something I didn't think about. I was focussed on 
a HTTP approach and didn't even spend a second about XML. Maybe
that's better, while I still prefer the HTTP style, which does
the job very well, I think. 

But I agree, XML could be more powerful. The disadvantage is that
it might be difficult to keep the RFC 822 email structure...

Hadmut

---

From: Martin hepworth <[email-masked]>
Date: Tue, 04 Mar 2003 17:02:27 +0000

> it might be difficult to keep the RFC 822 email structure...
Well just as easy to keep the mail structure as with http. You still 
need a starting doctype defn to be http1.1 compliant don't you?

www.mimesweeper.com