Subject: RE: [Asrg] DCC and IP checksums

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 10 Mar 2003 08:49:32 -0800

>  Keeping unique MD5's over the lifetime of the system is 
> impractical and
> will eventually start encroaching on the "hammering distance" 
> issue.

Maybe for some, we have infrastructure that handles 6 billion
transactions on data sets of many Gb. So there is an existence
proof at least :-)

If there is a business model this type of scheme can be 
deployed, my concern is that I would prefer we looked at
mechanisms that did not require such quantities of hardware.

Looking at the various spam gangs on the net there are 
major differences in the level of sophistication. The 
Nigerian gangs don't appear to have got much beyond working
out how to use CAPS LOCK. You can detect a risible proportion
of Nigerian letters simply by scanning for 'modalities of the
transaction'.

Rather than use an MD5 approach I would prefer to use 
something that was rather more adaptive and reactive. The 
spam senders can clearly react faster than we can turn out
standards. I think this is a case where Java or C# mobile
code approaches could have an application. This would allow
the fingerprint matching technology to evolve in response
to attempts to defeat it.

One of the features of the cricumvention technology is that
its use can provide some of the best spam indicators. For
example any subject line that has a string of whitespace and
random non text garbage appended at the end has a huge
probability of being spam.

If we get to the point where the only spam being sent is
being sent by a small number of offshore spam houses using
ever more convoluted tactics to defeat spam filtering
technology the business will start to shrink very quickly.

	Phill
 
_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: Kee Hinckley <[email-masked]>
Date: Mon, 10 Mar 2003 16:23:26 -0500

>of Nigerian letters simply by scanning for 'modalities of the

In the end, "content filtering" is another word for "natural language 
processing".  And while I know several NLP folks looking for jobs, I 
don't really think that's a good long term direction.

I see a few uses for content filtering.

1. Short term limitation of the spam problem.
2. Aid in forcing spammers into areas where simple authentication 
works, while we transition to a more complex authentication system.
3. Content filtering.  Cases where your goal is actually to filter 
content, not eliminate spam.  E.g. to ensure that Ashcroft doesn't 
get any mail with the word "chicken breast" in it.
-- 
Kee Hinckley
http://www.puremessaging.com/        Junk-Free Email Filtering
http://commons.somewhere.com/buzz/   Writings on Technology and Society

I'm not sure which upsets me more: that people are so unwilling to accept
responsibility for their own actions, or that they are so eager to regulate
everyone else's.
_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg