Subject: [Asrg] Requirements to solutions

From: Hadmut Danisch <[email-masked]>
Date: Wed, 19 Mar 2003 10:39:24 -0800

Hi,

I'd like to share some of my private notes about
requirements a solution must/should fulfill:

- must work everywhere on the world, in every legislation
- must work with every spammer, regardless of age, etc.
- must work with every recipient, regardless of age,...
- must work even if spammers know all details
  - must fulfill Shannon's Maxim  (Attacker knows cryptographical methods)
  - must fulfill Kerckhoff's Law

- must be robust
- must not require to be updated often
- must work with any language
- must work with encrypted messages
- must be easy to maintain
- must work for the dummy user

Any comments or objections?

Hadmut

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: "Alan DeKok" <[email-masked]>
Date: Wed, 19 Mar 2003 08:47:11 -0500

> requirements a solution must/should fulfill:
...
> Any comments or objections?

 - must be easy to implement
 - must be less work than current work dealing with spam
 - must be low cost
 - must be effective

  Alan DeKok.

---

From: Chuq Von Rospach <[email-masked]>
Date: Wed, 19 Mar 2003 11:03:30 -0800

> Any comments or objections?

we can all go home now, I guess.

but seriously, A solution doing ALL that is impossible. A suite of 
solutions that to a greater or lesser degree do some of that in an 
overlapping way? we'll still not make 100% of the goal. If anything 
less than 100% success is failure, we might as well go home.

(email != a manned space flight to mars, though, so maybe we don't need 
massive over-engineering and triple redundancy?)

-- 
Chuq Von Rospach, Architech
[email-masked] -- http://www.plaidworks.com/chuqui/blog/

---

From: Frank de Lange <[email-masked]>
Date: Wed, 19 Mar 2003 20:41:10 +0100

>Any comments or objections?
 - must be as simple as possible in implementation (KISS)
 - must be free of restricted IP (as in intellectual 'property')
 - must limit the load increase on the network to a minimum (think 
low-speed links, pay-per-packet links, etc)
 - must not increase the cost of email for users (so no pay-per-mail)

Frank

---

From: Matt Sergeant <[email-masked]>
Date: Wed, 19 Mar 2003 21:12:35 +0000 (GMT)

> - must work for the dummy user

Must not put a significant financial burden on legitimate email users.

Matt.