Subject: RE: [Asrg] Re: Asrg digest, Vol 1 #133 - 14 msgs

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 28 Mar 2003 12:45:29 -0800

We need to get beyond mechansisms that rely on listing 
dialup blocks etc. There is simply too much hassle involved
getting blocks listed and unlisted etc. Blacklists are
not a cheap solution, maintaining them properly is very 
expensive. What happens when someone is assigned an IP
block that has previously been identified as dialup?
how do they even know the listing exists? Similar problems
are being seen with the listing of IP blocks that were
previously 'unassigned' and hijacked by spamers, now
people are being assigned new IP blocks and finding that 
they are blacklisted before they ever send a mail.

Complaint volume is not a good guide here, how does someone
know why or even if you are blacklisting them? All they
know is that there is a university with a faulty mail service.

We need to move from these ad-hoc mechanisms to mechanisms
that are not tied to ad-hoc assumptions about how the
network works.

My broadband DHCP address may in theory be 'dynamic' but
it has been stable for the past two years. Lots of 
companies run mail servers off machines with DHCP addresses.

The only Internet protocol that requires a static IP 
address is DNS.

postmaster@IPaddress is never guaranteed to work. We move
machines arround all the time. This email could go out
via any one of a number of email servers that are hosted
in completely different IP address blocks.

The SMTP client tells the server which address it wants
complaints sent to when it does the initial SMTP HELO
command.

		Phill

> -----Original Message-----
> From: Steven F Siirila [mailto:[email-masked]]
> Sent: Friday, March 28, 2003 3:24 PM
> To: Markus Stumpf
> Cc: Steven F Siirila; Hallam-Baker, Phillip; [email-masked]
> Subject: Re: [Asrg] Re: Asrg digest, Vol 1 #133 - 14 msgs
> 
> 
> On Fri, Mar 28, 2003 at 09:18:14PM +0100, Markus Stumpf wrote:
> > On Fri, Mar 28, 2003 at 02:11:20PM -0600, Steven F Siirila wrote:
> > > As far as we're concerned, if you don't have a static 
> address for which
> > > we can reach you at Postmaster@[IPaddress] later on, you 
> have no business
> > > sending us email from that address.  Such users are told 
> to route their
> > > email through their ISP or obtain a static IP address for 
> their MTA.
> > 
> > If the DSL provider charges extra bucks for use of their 
> mailserver or
> > doesn't have a mailserver at all and the client of a 
> customer of yours
> > (we're an ISP) tells your customer "manage to receive my 
> email or I'll
> > cancel the contract" what would you tell your customer?
> > How many of your own customers can you afford to loose 
> because of that?
> 
> How many customers can we afford to lose if we continue to 
> allow the huge
> amounts of spam that were coming in via dialups?  ;-)  As 
> always, tradeoffs.
> Actually, we've had little to no complaints.  Our user base 
> is about 100,000.
> -- 
> 
> Steven F. Siirila			Office: Lind Hall, Room 130B
> Internet Services			E-mail: [email-masked]
> Office of Information Technology	Voice: (612) 626-0244
> University of Minnesota
> 
_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: Steven F Siirila <[email-masked]>
Date: Fri, 28 Mar 2003 14:56:12 -0600

> they are blacklisted before they ever send a mail.

I don't dispute the maintenance headaches with such lists.

> know is that there is a university with a faulty mail service.

Our rejection messages include a 550 with an embedded URL containing
encrypted information where the user can go to find out why they were
blocked and how they can request an override from our user.  I guess
the fact that we allow our users to override our default blocking is
what allows us to be heavier-handed in the first place.

> in completely different IP address blocks.

I had thought this was an RFC requirement.  I could be wrong.

> complaints sent to when it does the initial SMTP HELO

Now I know that is not standardized.  How would I know that's what you meant
by putting an IP address in the HELO?  Most sites ignore the HELO parameter
as it is really only a comment, strictly speaking.
--

---

From: [email-masked]
Date: Fri, 28 Mar 2003 17:12:15 -0500

> The only Internet protocol that requires a static IP 

Even that isn't totally true.

2136 Dynamic Updates in the Domain Name System (DNS UPDATE). P. Vixie,
     Ed., S. Thomson, Y. Rekhter, J. Bound. April 1997. (Format: TXT=56354
     bytes) (Updates RFC1035) (Updated by RFC3007) (Status: PROPOSED
     STANDARD)

Even the NS RR can point at a dunamic address if you play games with the TTL ;)

---

From: "Tim Kehres" <[email-masked]>
Date: Sat, 29 Mar 2003 10:08:59 +0800

> they are blacklisted before they ever send a mail.

Our home DSL connection has been blacklistsed for a few years now, along
with other DSL networks the territory.   Personally, given the cheap cost of
such connections and the high penetration of such connections in the local
community, I think that this is most likely a good thing.  It was pretty
simple to for us  to determine this - when we originally configured our mail
servers we got mail back saying we were denied because of the IP address
which we originated from.  It is a common problem here unfortunately.

We have gotten around this problem here and on other networks in other
countries by employing a combination of BSMTP for inbound and authenticated
SMTP for outbound mail to our head office, effectively tunneling through the
ISP.  But that can be problematic as some ISP's are now also blocking
OUTBOUND smtp from their dialup/DSL pools.   I suspect that these numbers
will rise as more get clued into trying to combat the spam problems
originating from their networks.   To add insult to injury, at least in this
part of the world (Asia), getting connected with an ISP that provides
reliable IP *AND* provides a reliable mail relay can be a daunting task.

What you bring up is a significant problem that needs to be addressed.   I'm
not convinced that this is the right place for it however.   On the other
hand, it would not be the first time I  was wrong...   :-)

> in completely different IP address blocks.

Exactly!

Best Regards,

-- Tim

---

From: Kee Hinckley <[email-masked]>
Date: Sat, 29 Mar 2003 00:00:36 -0500

>blocked and how they can request an override from our user.  I guess

I have a bounce message that has several sentences in plain English 
telling the sender to stop sending email to the address in question. 
Yet it gets ignored by people.  When I ask why (assuming that I can 
get the person to reply), the common response is:

"I didn't recognize the sender (mailer-daemon), and I know I'm not 
supposed to open mail from people I don't know, so I deleted it."

And you expect them to click on an encrypted URL?

I think it works for you because you are a university.  You're 
dealing with a user-base that tends to be more technical and less 
mission-critical.  You aren't going to lose customers because of a 
block.

-- 
Kee Hinckley
http://www.puremessaging.com/        Junk-Free Email Filtering
http://commons.somewhere.com/buzz/   Writings on Technology and Society

I'm not sure which upsets me more: that people are so unwilling to accept
responsibility for their own actions, or that they are so eager to regulate
everyone else's.
_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg