Subject: Re: [Asrg] Deprecating plain POP accounts

From: "Raymie Stata" <[email-masked]>
Date: Wed, 5 Mar 2003 07:51:54 -0800

Using the vocabulary from my previous message, I believe Hadmut Danisch is arguing as follows.  He's agreeing that sender domain tracking is desireable, but at the same time he thinks that MTA-chaing tracking is more practical.  By requiring all mail from a domain D to be injected via an MTA blessed by domain D, MTA-chain tracking achieves sender-domain tracking.  So he's asking, why not impose such a requirement?

First, it seems to me that any scheme involving sender-domain tracking will require messages "From:" domain D to eventually pass through an MTA blessed by D.  Thus, Hadmut's requirement of juswt making this the first MTA seems reasonable from this perspective.

My only concern is this.  Networks often block outgoing connections to port 25 (and for good reason).  Pop-before-smtp and/or authenticated smtp don't help with this problem.  How do we deal with this problem?  Maybe requiring smtp-over-SSL in these situations will work (most MUAs seem to support this now).  However, this solution assumes most "ISP-like" networks will allow port 925 traffic to go out, I don't have 1st-hand experience, perhaps even this won't work.

Other solutions?  Or is this a show-stopper for requiring the first MTA be an MTA blessed by the sending domain?
_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: Hadmut Danisch <[email-masked]>
Date: Wed, 5 Mar 2003 19:55:46 +0100

On Wed, Mar 05, 2003 at 07:51:54AM -0800, Raymie Stata wrote:

> Using the vocabulary from my previous message, I believe Hadmut
> Danisch is arguing as follows.  He's agreeing that sender domain
> tracking is desireable, but at the same time he thinks that
> MTA-chaing tracking is more practical.  By requiring all mail from a
> domain D to be injected via an MTA blessed by domain D, MTA-chain
> tracking achieves sender-domain tracking.  So he's asking, why not
> impose such a requirement? 

Exactly. That's it. :-)

> My only concern is this.  Networks often block outgoing connections
> to port 25 (and for good reason).  Pop-before-smtp and/or
> authenticated smtp don't help with this problem.  How do we deal with
> this problem?  Maybe requiring smtp-over-SSL in these situations will
> work (most MUAs seem to support this now).  However, this solution
> assumes most "ISP-like" networks will allow port 925 traffic to go
> out, I don't have 1st-hand experience, perhaps even this won't work.

I didn't understand what you wanted to say. Where exactly do you 
see a problem?

regards
Hadmut