Subject: Re: [atoca] [Ecrit] Scope of the Work

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 19 Sep 2011 08:15:14 +0800

This is a good question.  Sent to the wrong WG :)

If anyone has any thoughts on this topic, I'd be interested to hear them.

(And then I did exactly the same thing...)

On 2011-09-19 at 02:32:07, Hannes Tschofenig wrote:
> Hi all,
> 
> in earlier discussions we had always listed the school shooting 
> scenario as a use case to summarize a cluster of solutions that use 
> existing protocols, such as XMPP or SIP, to convey the alerts in a 
> point-to-point fashion (using a subscribe/notify paradigm).
> A few of us had worked on these solutions, such as 
> http://xmpp.org/extensions/xep-0127.html or 
> http://tools.ietf.org/html/draft-rosen-sipping-cap-04. These writeups 
> should give you more background about the characteristics of the 
> provided solution (in case the scenario description isn't so good).
> 
> These solutions are not suitable for mass delivery (aka Tsunami 
> warning
> case) but work fine in various other use cases. I had a short writeup 
> of the scenario in the architecture mail I distributed yesterday.
> 
> Now, in off-list discussions for the virtual interim meeting the 
> question was raised whether this use case is something that should not 
> be dealt with in the group but instead the focus be spent on the mass 
> delivery. From a requirements point of view these two cases are 
> obviously quite different and the mass delivery case would make use of 
> multicast/broadcast delivery instead.
> 
> I would need feedback from the rest of the group. There are two 
> choices, I believe:
> 
> 1) Focus on the mass alert delivery work,
> 
> 2) In addition to the mass delivery work also address the school 
> shooting scenario (based on how I described it in my architectural 
> writeup, see http://www.ietf.org/mail- 
> archive/web/atoca/current/msg00536.html, that would lead to a
> point-to- point alert delivery.
> 
> What would you prefer?
> 
> Ciao
> Hannes

---

From: Art Botterell <[email-masked]>
Date: Sun, 18 Sep 2011 17:40:55 -0700

Let me just confess a feeling that we may have a shortfall of analysis here.  Particular use cases are valuable to the extent they reveal underlying patterns that can then become generalized; otherwise we wind up building single functions instead of flexible tools..  In this case, what seems like a dichotomy may actually be a continuum, with the use-cases we're considering being relatively near the opposite ends of a spectrum, and with a variety of others lying between them.

Anyway, perhaps the correct formulation isn't "mass" versus "school" so much as broadly-targeted vs. narrowly targeted... or perhaps attribute-constrained vs. list-constrained (where geography is one of a variety of possible attributes that might inform the distribution of an alert).  In any event, most of the qualitative distinctions reflect technology artifacts rather than different requirements.  In particular, list-driven approaches tend not to scale well due both to network inefficiencies and the exponential cost of maintaining large-yet-accurate lists.

Ultimately, I think... and I believe I've said this before, so please forgive the repetition... that what we're really looking at is a relatively generic, albeit still unresolved, problem of multicasting, as opposed to the scalability problems of a unicast approach.

- Art

On Sep 18, 2011, at 5:15 PM, Thomson, Martin wrote:

> _______________________________________________
> atoca mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/atoca

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 19 Sep 2011 14:13:43 +0300

Hi Art, 

I have used these scenario terms only for convenience reasons to refer to the different classes of systems. 

There is one solution cluster that uses unicast alert delivery (I mentioned the XMPP/Atom/etc. approach here) and then there is the second one that uses multicast/broadcast. The requirements for these two are quite different and from the feedback I had gotten regarding scoping there seems to be a preference to work on the latter but not on the former (with the impression being that the former category is already being worked on). 

Ciao
Hannes

PS: I have indeed sent the message to the wrong mailing list. Sorry about that.