Subject: RE: Optical Channel MIB changes

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Thu, 18 Jan 2001 17:34:39 -0500

Mark,

The ODUkT layer network is a sub-layer of the optical data unit layer, which
provides the capability for tandem connection monitoring. 
One to six nested levels of monitoring are defined for OTN in ITU-T G.709
(Network Node Interface for Optical Transport Network). Six fields of ODUk
Tandem Connection Monitoring (TCM) overhead are defined in the ODUk
overhead. 

TCM supports monitoring of ODUk connections for one or more of the following
network applications:
-	optical UNI to UNI tandem connection monitoring; monitoring the ODUk
connection through the public transport network (from public network Ingress
Network Termination to Egress Network Termination);
-	optical NNI to NNI tandem connection monitoring; monitoring the ODUk
connection through the network of a network operator (from operator network
Ingress Network Termination to Egress Network Termination);
-	sublayer monitoring for linear 1+1, 1:1 and 1:n optical channel
subnetwork connection protection switching, to determine the Signal Fail and
Signal Degrade conditions;
-	sublayer monitoring for optical channel shared protection ring
(SPring) protection switching, to determine the Signal Fail and Signal
Degrade conditions;
-	monitoring an optical channel tandem connection for the purpose of
detecting a signal fail or signal degrade condition in a switched optical
channel connection, to initiate automatic restoration of the connection
during fault and error conditions in the network;
-	monitoring an optical channel tandem connection for, e.g., fault
localisation or verification of delivered quality of service.

Further details can be found in G.709.

Regards,
Kam

-----Original Message-----
From: Mark Stewart [mailto:[email-masked]]
Sent: Wednesday, January 17, 2001 6:45 PM
To: Lam, Hing-Kam (Kam)
Cc: AToM Working Group
Subject: Re: Optical Channel MIB changes

Kam,

Okay, but what are the 1 to 6 layers for?

This doesn't really affect legacy DWDM systems since most will not
have the Och sublayers but I want to know how it might impact future
products.

Thanks,

- Mark

"Lam, Hing-Kam (Kam)" wrote:
> 
> Mark,
> 
> According to G.709, within a OCh layer, it is possible to have zero to six
> instances of ODUkT sublayers. That is, the relationship between OCh and
> ODUkT is one to n (0 <= n <= 6). Therefore, the index of the ODUkT group
in
> the San Diego version of the MIB should be updated to allow this.
> 
> Regarding ARC, Anni and I propose the following:
> 
> 1.  In the next version of the otn-MIB:
> Create a new ARC table. ( if we can find home for this table in the DISMAN
> WG, then it will be deleted from the otn mib,
> otherwise, it will stay.)
> 
> 2.  We are going to propose a ARC MIB to DISMAN WG explaining why it is
> important to have ARC. Both items are targeted for the March IETF meeting.
> We think this will make the MIB cleaner and cover the requirements for
both
> pre-otn and otn network devices.
> 
> Regards,
> Kam
> 
> -----Original Message-----
> From: Nathan Kohn [mailto:[email-masked]]
> Sent: Wednesday, January 17, 2001 11:23 AM
> To: Mark Stewart
> Cc: AToM Working Group
> Subject: Optical Channel MIB changes
> 
> mark
> 
> in conversation you've mentioned a few changes you might make (additions
> or deletions) to  the Optical Channel MIB since it was originally posted
> for the San Diego IETF atommib session.
> 
> for the benefit of the WG could you summarize these changes, e.g.
> alarms, add/drop, etc., any new info on the open issues from the meeting
> and perhaps also comment on how this work with other WG such as disman.
> (you may want to break it up into two or three emails in order to
> establish threads)
> 
> also, according the charter changes regarding the Optical Channel MIB,
> another rev was going to come out in january, do you think that will
> still happen?
> 
> the next IETF mtg is only 2 months away, so i suppose that it is not to
> early to be thinking about requesting a slot for atommib.
> 
> thanks
> nathan kohn
> [email-masked]

---

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Thu, 18 Jan 2001 18:28:42 -0500

Draft G.709 can be found at

ftp://ftp.t1.org/T1X1/X1.5/1x150320.doc

Regards,
Kam

-----Original Message-----
From: Jon Saperia [mailto:[email-masked]]
Sent: Thursday, January 18, 2001 6:10 PM
To: Lam, Hing-Kam (Kam)
Subject: Re: Optical Channel MIB changes 

I can not seem to find the document in the internet drafts
directory. Can you send me  the pointer please?

Thanks,
/jon
--

Jon Saperia		     [email-masked]
			     Phone: 617-744-1079
			     Fax:   617-249-0874
			     http://www.jdscons.com/