Subject: Managed Objects for SONET/SDH Virtually Concatenated Paths

From: [email-masked]
Date: Mon, 19 Mar 2001 09:21:44 +0000

Hello,
I'd appreciate it if you could help answer the following question(s):

the SONET/SDH Interfaces MIB RFC 2558 supports ifTypes for SONET
(medium/line/section), path and VT. So...

How should virtual concatenation groups be represented in the ifTable and
ifStackTable?

Is the ifType for a VCn-Xv, 'path'?

Should the virtual concatenation group be modelled as a distinct layer  above
the component links in the ifStackTable, especially in the light of the draft
LCAS protocol for dynamically adding/removing links from virtual concatenation
groups?)

Regards,

Thomas Jordan

Software Analyst,
Marconi,
Poole,
Dorset, UK

---

From: "C. M. Heard" <[email-masked]>
Date: Mon, 19 Mar 2001 05:49:12 -0800 (PST)

> Is the ifType for a VCn-Xv, 'path'?

You are in uncharted territory here. I think your choices are either to
use sonetPath(50) or to get a new ianaIfType number assigned.  I would
think that the latter would be preferred.  See

  ftp://ftp.isi.edu/mib/ianaiftype.mib

for current assignments.

> Should the virtual concatenation group be modelled as a distinct layer
> above the component links in the ifStackTable, especially in the light
> of the draft LCAS protocol for dynamically adding/removing links from
> virtual concatenation groups?)

That seems reasonable.  Why don't you publish a proposal in the form of
an Internet Draft?  That's the best way to get the ball rolling on stuff
like this.

Mike

---

From: Kaj Tesink <[email-masked]>
Date: Tue, 20 Mar 2001 12:58:08 -0500

if thomas' proposal is a complex addition to 2558
then i'd support a separate Internet Draft. if it is a
straightforward minor extension to 2558 i suggest we can
do it through the next update of 2558 (according to the
charter we need to accommodate implementation experience
this year.
thomas, can you draft your proposal - we can get a new ifType
value once we agree on the course of action.

kaj

=============================================================

the change proposals i've collected sofar are as follows:

     REVISION      "xxxxxxxxxx"
     DESCRIPTION
         "The key changes made to this MIB module
         since its initial publication in RFC 2558
         are as follows.

         (1) Corrected typographical error
             (bellcore1991(2) in sonetSESthresholdSet)

         (2) Added support for sts192c/STM64(6) in
             sonetPathCurrentWidth

         (3) Corrected description of the applicability
             of VTs for SDH for improved accuracy
             "

Bug report sources:
(1) many
(2) proposal by Dennis Rogers 4/19/99
(3) proposal by Patrik Jarl 7/6/99:

2558 TEXT:
-- the SONET/SDH Virtual Tributary group

-- this group consists of 2 tables:
-- - the SONET/SDH VT Current Table
-- - the SONET/SDH VT Interval Table

-- For SDH signals, virtual tributaries are
-- called VCs instead of VTs

-- A VT1.5 = VC11
-- A VT2 = VC12
-- A VT3 = none
-- A VT6 = VC3

DRAFT REVISED TEXT:
-- the SONET/SDH Virtual Tributary group

-- this group consists of 2 tables:
-- - the SONET/SDH VT Current Table
-- - the SONET/SDH VT Interval Table

-- Corresponding SDH signals for SONET VTs are
-- as follows:

-- A VT1.5 = TU11
-- A VT2 = TU12
-- A VT3 = none
-- none  = TU3
-- A VT6 = TU2

>an Internet Draft?  That's the best way to get the ball rolling on stuff

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

Kaj Tesink
Telcordia Technologies
Email  [email-masked]
Tel    732.758.5254
Fax    732.758.2269
Postal 331 Newman Springs Rd
        Red Bank, NJ 07701
        USA

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

---

From: Subrahmanya Hegde <[email-masked]>
Date: Tue, 20 Mar 2001 10:27:22 -0800

Kaj
 I am just curious; Does it make sense to add an enumeration for
OC-768 in sonetPathCurrentWidth?

Thanks
Subra