Subject: RE: Extensbility and Versioning Paces

From: "David Orchard" <[email-masked]>
Date: Wed, 15 Sep 2004 14:25:56 -0700

> > In both cases - atom makes an incompatible change or
> > 3rd party adds
> > mandatory extension - the version attribute is
> > unnecessary compared to
> > namespaces for indicating incompatibility.  One
> > reason why I don't
> > believe version attributes should be used for major
> > or incompatible
> > versions.
> 
> The bottom line of my argument is that if the same
> namespace name is used for different versions of the
> format then how do I identify which version a
> publisher is using?
> 
> If I go to some site that uses Atom 1.1 instead of
> Atom 1.0 and the namespace name doesn't change how can
> I tell? It's fine and dandy that an aggregator will
> ignore any added optional elements between versions
> but what about humans reading the feed that want to
> know what spec defines the elements and attributes in
> the feed? Will the namespace name point to network
> retrievable resource that lists the various versions
> of Atom then the user has to play hide and seek trying
> to figure out which one applies to the feed he just
> saw?
> 

We're agreed that Atom 1.1 would be backwards compatible with Atom 1.0.
So why would a human want to look at the 1.0 wrt the site?  The site
doesn't care about Atom 1.0 any more, it's moved to 1.1.  

Say something optional has been added.  Then the 1.1 site now knows
about the optional thing.  From the clients perspective, there's nothing
different between something optional in v1.0 and something optional
added into v1.1.  It can ignore the v1.0 and the v1.1 optional thing.  

Having said that, I can see the version attribute being used to indicate
this "minor" version.  

A scenario I was thinking of was say a site will return an image in v1.1
and not in v1.0 for whatever request.  If the site knows the client is
v1.0 then it could know to not return the image (even though the image
will be safely ignored by the client) for performance reasons.  

Cheers,
Dave

---

From: Dare Obasanjo <[email-masked]>
Date: Wed, 15 Sep 2004 15:11:43 -0700 (PDT)

> doesn't care about Atom 1.0 any more, it's moved to

*sigh* 

If there is no version number how do you know what
version of Atom the site supports. When I first
started implementing RSS Bandit I did so by looking at
the feeds of various sites I wanted to be able to read
then going to the spec for the version of RSS they
supported. 

If there is no version number in the feed how do I
tell which version of atom
<atom:some-optional-element> is defined? 
 
> added into v1.1.  It can ignore the v1.0 and the

I know that I said as much in my mail you are
responding to. 

> Having said that, I can see the version attribute
 
Exactly. 

> will be safely ignored by the client) for

I don't think this is mainstream scenario. 

=====
THINGS TO DO IF I BECOME AN EVIL OVERLORD #23
I will keep a special cache of low-tech weapons and train my troops in their use. That way -- even if the heroes manage to neutralize my power generator and/or render the standard-issue energy weapons useless -- my troops will not be overrun by a handful of savages armed with spears and rocks.

_______________________________
Do you Yahoo!?
Declare Yourself - Register online to vote today!
http://vote.yahoo.com