Subject: web/uri/iri/url [Fwd: Re: [whatwg] [wf2] type="url"]

From: Robert Sayre <[email-masked]>
Date: Sun, 20 Mar 2005 20:32:13 -0500

-------- Original Message --------
Subject: Re: [whatwg] [wf2] type="url"
Date: Mon, 21 Mar 2005 01:28:41 +0000 (UTC)
From: Ian Hickson <[email-masked]>
To: Anne van Kesteren <[email-masked]>
CC: WHAT WG List <[email-masked]>
References: <[email-masked]>

On Sun, 13 Feb 2005, Anne van Kesteren wrote:
>
> After thinking about it. Having |type="url"| instead of |type="uri"| or
> |type="iri"| might not be so bad.

type="url" will get me lynched by standards purists.
type="iri" will get me lynched by confused authors.
type="uri" is a compromise.

-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'

---

From: Tim Bray <[email-masked]>
Date: Sun, 20 Mar 2005 18:03:49 -0800

> type="uri" is a compromise.

I hereby promise that should I ever again be tempted to raise an issue 
around the naming of web addresses, I shall strike myself firmly on the 
head with a heavy blunt object until I come to my senses. -Tim