Subject: HTTP Accept Headers for Atom V1.0?

From: "Bob Wyman" <[email-masked]>
Date: Fri, 15 Jul 2005 15:33:39 -0400

What would the HTTP Accept Headers for Atom V1.0 look like? i.e. if I want
to tell the server that I want Atom V1.0 but do not want Atom 0.3?

                        bob wyman

---

From: "A. Pagaltzis" <[email-masked]>
Date: Sat, 16 Jul 2005 06:48:58 +0200

* Bob Wyman <[email-masked]> [2005-07-15 21:45]:
> What would the HTTP Accept Headers for Atom V1.0 look like?
> i.e. if I want to tell the server that I want Atom V1.0 but do
> not want Atom 0.3?

There is no official MIME type for Atom 0.3, is there? So
technically you can’t even ask the server for Atom 0.3. If people
do give you that in return for a request for Atom 1.0, well, no
standard is going to be much help – the failure is at their end
and you simply can’t do anything about that.

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>

---

From: Mark Baker <[email-masked]>
Date: Sat, 16 Jul 2005 11:13:52 -0400

On Sat, Jul 16, 2005 at 06:48:58AM +0200, A. Pagaltzis wrote:
> There is no official MIME type for Atom 0.3, is there?

Well, "official" in the sense that a spec was written and code was
written to that spec; it's "application/atom+xml";

  However, the canonical serialization of an Atom document is XML 1.0,
  and this is the only serialization that can be identified with the
  "application/atom+xml" media type.
   -- http://www.mnot.net/drafts/draft-nottingham-atom-format-02.html

So to answer's Bob's question, "You can't do that".

Mark.
-- 
Mark Baker.  Ottawa, Ontario, CANADA.          http://www.markbaker.ca
Coactus; Web-inspired integration strategies   http://www.coactus.com