Subject: Re: More on Atom XML signatures and encryption

From: "Bob Wyman" <[email-masked]>
Date: Fri, 1 Jul 2005 00:13:06 -0400

Paul Hoffman wrote:
>>Same as above.  Even though it is included-by-reference, the referenced 
>>content is still a part of the message.
> No, it isn't. The reference is part of the message.
+1
    The signature should only cover the bits that are actually in the 
element (feed or entry) that is signed. Referenced data may be under 
different administrative control, may change independently of the signed 
element, etc.

        bob wyman

---

From: James M Snell <[email-masked]>
Date: Thu, 30 Jun 2005 21:23:10 -0700

Ok, this is fine.  I'll back this out of the draft.

Bob Wyman wrote:

> Paul Hoffman wrote:
>
>>> Same as above.  Even though it is included-by-reference, the 
>>> referenced content is still a part of the message.
>>
> different administrative control, may change independently of the 
> signed element, etc.
>
>        bob wyman
>
>
>