Subject: Query on atom:source/atom:author in draft 10

From: Isofarro <[email-masked]>
Date: Fri, 15 Jul 2005 22:47:30 +0100

In defining both an atom:feed and atom:entry, atomAuthor is specified as 
allowing multiple authors, in both the text description and RELAX-NG 
formats.

The atom:source defines atomAuthor as 0 or 1, not allowing multiple 
atomAuthors. (Section 4.2.11)

Is that what was intended? Just seemed a little inconsistent.

Thanks,
Mike

---

From: James M Snell <[email-masked]>
Date: Fri, 15 Jul 2005 15:36:54 -0700

Isofarro wrote:

>
>
> In defining both an atom:feed and atom:entry, atomAuthor is specified 
> as allowing multiple authors, in both the text description and 
> RELAX-NG formats.
>
Whoops. Looks like an editorial oversight..

   atomSource =
      element atom:source {
         atomCommonAttributes,
         (atomAuthor?
          & atomCategory*
          & atomContributor*
          & atomGenerator?
          & atomIcon?
          & atomId?
          & atomLink*
          & atomLogo?
          & atomRights?
          & atomSubtitle?
          & atomTitle?
          & atomUpdated?
          & extensionElement*)
      }

atomAuthor? should be atomAuthor*

Good catch.

- James