Subject: RNG validators capable of fully using the Atom schema?

From: Henri Sivonen <[email-masked]>
Date: Sun, 10 Jul 2005 11:53:48 +0300

I'm wondering which validator was used for testing the Atom 
RNG+Schematron schema. Which validators support Compact Syntax with 
embedded Schematron? I am particularly interested in Java solutions.

(Specifically, I would like to fully support the Atom schema in 
http://hsivonen.iki.fi/validator/ )

-- 
Henri Sivonen
[email-masked]
http://hsivonen.iki.fi/

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Tue, 12 Jul 2005 10:24:47 +0200

>embedded Schematron? I am particularly interested in Java solutions.

http://www.topologi.com/products/validator/ is said to support it.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Weinh. Str. 22 · Telefon: +49(0)621/4309674 · http://www.bjoernsworld.de
68309 Mannheim · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Dave Pawson <[email-masked]>
Date: Tue, 12 Jul 2005 16:53:23 +0100

> http://www.topologi.com/products/validator/ is said to support it.

I used Norm's relax-ng schema + msv.

Seems good to me?

http://www.dpawson.co.uk/nodesets/nodesets.xml  You tell me if it's
bad[==invalid]
The spec doesn't ... in language I understand.

-- 
Regards, 

Dave Pawson
XSLT + Docbook FAQ
http://www.dpawson.co.uk

---

From: Norman Walsh <[email-masked]>
Date: Tue, 12 Jul 2005 12:16:25 -0400

/ Henri Sivonen <[email-masked]> was heard to say:
| I'm wondering which validator was used for testing the Atom
| RNG+Schematron schema. Which validators support Compact Syntax with
| embedded Schematron? I am particularly interested in Java solutions.

I use Kohsuke's MSV. (msv.dev.java.net)

                                        Be seeing you,
                                          norm

-- 
Norman Walsh <[email-masked]> | Everything should be made as simple as
http://nwalsh.com/            | possible, but no simpler.

---

From: Dave Pawson <[email-masked]>
Date: Tue, 12 Jul 2005 18:22:44 +0100

> I use Kohsuke's MSV. (msv.dev.java.net)

Make sure you pick up the overnight builds.
Sun seem lax on keeping the main feed up to date.

regards DaveP

---

From: Henri Sivonen <[email-masked]>
Date: Wed, 13 Jul 2005 11:21:06 +0300

> I use Kohsuke's MSV. (msv.dev.java.net)

Cool. Thanks.

I had allowed relaxng.org tell me that MSV "Supports XML syntax only."

-- 
Henri Sivonen
[email-masked]
http://hsivonen.iki.fi/