Subject: examples of merged feeds/feed aggregation?

From: Michael Stillwell <[email-masked]>
Date: Wed, 21 Dec 2005 15:53:50 +1100

Can someone point me to some examples of merged feeds, or any
discussion of same?

I'm thinking of a situation where you have a.xml and b.xml and they
are merged into merge.xml, from which a.xml and b.xml are individually
recoverable.  (Or almost so.)

Is the <link rel="via" href="a.xml"> element the right way to do this?

(To motivate this question, a use-case would be where you wanted to
present someone's del.icio.us and flickr.com feeds as a single feed.)

--M.

--
http://beebo.org
+44 78 2118 9049

---

From: "A. Pagaltzis" <[email-masked]>
Date: Wed, 21 Dec 2005 06:24:43 +0100

* Michael Stillwell <[email-masked]> [2005-12-21 06:05]:
> I'm thinking of a situation where you have a.xml and b.xml and
> they are merged into merge.xml, from which a.xml and b.xml are
> individually recoverable.  (Or almost so.)
> 

No, that is for citing sources in an entry.

For merging feeds, you put the originating feed’s metadata in an
atom:source element inside the atom:entry.

You could take a look at the combined “use Perl” journals feed I
provide:

    http://plasmasturm.org/feeds/planet-useperl/

I only copy as much metadata as is required to identify the
source feed there.

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>

---

From: Eric Scheid <[email-masked]>
Date: Wed, 21 Dec 2005 16:33:33 +1100

> Is the <link rel="via" href="a.xml"> element the right way to do this?

the atom:source element is the right way.

e.