Subject: Re: Can/Does/Should the FeedValidator catch improperly escaped XHTML?

From: "M. David Peterson" <[email-masked]>
Date: Thu, 31 Aug 2006 18:58:44 -0600

Both points well taken.

I would like to change my initial vote to -1, though +1 for both James and
Aristotle's follow-up.

On 8/31/06, A. Pagaltzis <[email-masked]> wrote:
>
>
> * James Holderness <[email-masked]> [2006-09-01 01:30]:
> > Encouraging people to use xhtml when they don't know enough to
> > have made that decision themselves is just asking for trouble.
>
> +1
>
> Regards,
> --
> Aristotle Pagaltzis // <http://plasmasturm.org/>
>
>

-- 
/M:D

M. David Peterson
http://mdavid.name | http://www.oreillynet.com/pub/au/2354

---

From: Asbjørn Ulsberg <[email-masked]>
Date: Sat, 02 Sep 2006 12:23:51 +0200

On Fri, 01 Sep 2006 01:19:35 +0200, James Holderness  
<[email-masked]> wrote:

> Just because a feed appears to contain well-formed xhtml content today,  
> that doesn't mean it's going to be well-formed tomorrow. Encouraging  
> people to use xhtml when they don't know enough to have made that  
> decision themselves is just asking for trouble. Sooner or later they're  
> going to end up with broken xml which will be completely unreadable in  
> many aggregators.

Well, that completely depends on how we present this information to the  
user. I was not thinking of a simple message saying "This is valid XHTML,  
change @type to 'xhtml' ASAP, you newb!", but more along the lines of  
informing the user that the content looks like wellformed XHTML, that he  
can read more about it here and there, why he should try to keep it  
wellformed and why he should not change it if he's not sure of its  
welformedness.

Something like that.

> Also, escaped html tends to be better supported by aggregators anyway.

That's today. I would hope and assume that this changes in the future.

-- 
Asbjørn Ulsberg     -=|=-    http://virtuelvis.com/quark/
«He's a loathsome offensive brute, yet I can't look away»

---

From: "M. David Peterson" <[email-masked]>
Date: Sat, 2 Sep 2006 05:32:39 -0600

+1

-- 
/M:D

M. David Peterson