Subject: Re: fh:complete & cf:treatAs

From: Mark Nottingham <[email-masked]>
Date: Wed, 3 Oct 2007 14:35:34 +1000

cf:treatAs talks about the ordering of the list; fh:complete doesn't.

That said, I don't think there's much harm in using both.

Cheers,

On 30/09/2007, at 5:55 PM, Franklin Tse wrote:

>
> Hi all,
>
> <fh:complete /> in RFC 5005 (http://tools.ietf.org/html/rfc5005)  
> and <cf:treatAs>list</cf:treatAs> in the Simple List Extensions  
> Specification (http://msdn.microsoft.com/xml/rss/sle/) have the  
> same meaning. However, only the latter one is being supported by  
> feed readers at the moment.
>
> I am not sure if there has been any feed reader supporting  
> <fh:complete />, but I want to add the element to my feed as more  
> implementations of RFC 5005 are expected in the future.
>
> Is it a good practice to use both <fh:complete /> and  
> <cf:treatAs>list</cf:treatAs> in the same feed?
>
> <?xml version="1.0" encoding="UTF-8"?>
> <feed xmlns="http://www.w3.org/2005/Atom" xmlns:fh="http://purl.org/ 
> syndication/history/1.0" xmlns:cf="http://www.microsoft.com/schemas/ 
> rss/core/2005" xml:lang="en">
> ...
> <fh:complete />
> <cf:treatAs>list</cf:treatAs>
> ...
> </feed>
>
> Regards,
> Franklin
>

--
Mark Nottingham     http://www.mnot.net/

---

From: "Franklin Tse" <[email-masked]>
Date: Sun, 7 Oct 2007 20:19:05 +0800

Thanks for your reply. Do you know if there has been any feed reader 
supporting RFC 5005 (complete feed||paged feed||archived feed)?

-Franklin

--------------------------------------------------
From: "Mark Nottingham" <[email-masked]>
Date: Wednesday, 03 October, 2007 12:35
To: "Franklin Tse" <[email-masked]>
Cc: "atom-syntax" <[email-masked]>
Subject: Re: fh:complete & cf:treatAs

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 8 Oct 2007 20:44:45 +1000

AFAIK, no feed readers yet; it's in a couple of tools (e.g., Abdera,  
Argotic) though.

Cheers,

On 07/10/2007, at 10:19 PM, Franklin Tse wrote:

> Thanks for your reply. Do you know if there has been any feed  
> reader supporting RFC 5005 (complete feed||paged feed||archived feed)?
>
> -Franklin
>