Subject: Fwd: Re: Atom namespace documents

From: Paul Hoffman <[email-masked]>
Date: Sat, 13 Oct 2007 14:53:48 -0400

Dan's fast.

>Subject: Re: Atom namespace documents
>From: Dan Connolly <[email-masked]>
>To: Asbjørn Ulsberg <[email-masked]>
>Cc: Paul Hoffman <[email-masked]>, Tim Bray <[email-masked]>,
>         Philippe Le Hegaret <[email-masked]>
>Date: Fri, 12 Oct 2007 21:26:37 -0500
>X-Mailer: Evolution 2.12.0
>
>
>On Sat, 2007-10-13 at 03:11 +0200, Asbjørn Ulsberg wrote:
>>  Hi, Dan. I've taken the liberty to do some adjustments to the Atom 
>>  Syndication Format and Atom Publishing Protocol namespace documents so 
>>  they are more in line with other namespace documents published on W3C, 
>>  like e.g. <http://www.w3.org/1999/xhtml/>.
>>
>>  I've added the "Namespaces in XML" reference, referenced the same 
>>  stylesheet as the XHTML namespace document references, adjusted the IETF 
>>  logo to fit better with the W3C logo, adjusted the title of the documents 
>>  to be more coherent and added header elements to both documents to match 
>>  the XHTML namespace document and updated the AtomPub namespace document to 
>>  reflect that it is a proposed standard (RFC-5023).
>>
>>  I hope you think these changes are okay and would publish these documents 
>>  along with the attached IETF logo on the W3C website whenever you feel 
>>  like it.
>
>Thanks; I published your revisions:
>
>  http://www.w3.org/2007/app
>  $Revision: 1.3 $ of $Date: 2007/10/13 02:23:21 $
>
>  http://www.w3.org/2005/Atom
>  $Revision: 1.10 $ of $Date: 2007/10/13 02:19:32 $
>
>I made just one change, to tidy the documents so that I could
>see the diffs more clearly.
>
>>
>>  --
>>  Asbjørn Ulsberg          -=|=-         [email-masked]
>>  «He's a loathsome offensive brute, yet I can't look away»
>--
>Dan Connolly, W3C http://www.w3.org/People/Connolly/

---

From: Sam Ruby <[email-masked]>
Date: Sat, 13 Oct 2007 21:48:08 -0400

> Dan's fast.

I realize that there is no requirement to be consistent, but why the 
difference:

http://www.w3.org/2005/Atom => http://tools.ietf.org/html/rfc4287
http://www.w3.org/2007/app  => http://www.ietf.org/rfc/rfc5023.txt

Given that the tools.ietf.org/html version contains a prominent link to 
the .txt version, I'd suggest it be used in both places.

- Sam Ruby

>>>  Syndication Format and Atom Publishing Protocol namespace documents 
>>> so  they are more in line with other namespace documents published on 
>>> W3C,  like e.g. <http://www.w3.org/1999/xhtml/>.
>>>
>>>  stylesheet as the XHTML namespace document references, adjusted the 
>>> IETF  logo to fit better with the W3C logo, adjusted the title of the 
>>> documents  to be more coherent and added header elements to both 
>>> documents to match  the XHTML namespace document and updated the 
>>> AtomPub namespace document to  reflect that it is a proposed standard 
>>> (RFC-5023).
>>>
>>>  I hope you think these changes are okay and would publish these 
>>> documents  along with the attached IETF logo on the W3C website 
>>> whenever you feel  like it.
>>

---

From: Julian Reschke <[email-masked]>
Date: Sun, 14 Oct 2007 14:18:31 +0200

> the .txt version, I'd suggest it be used in both places.

Speaking of which, I have XML and "true" HTML (*) versions available at 
<http://greenbytes.de/tech/webdav/#rfc5023>.

Best regards, Julian

(*) As in: not the result of post-processing the TXT version.

---

From: Tim Bray <[email-masked]>
Date: Sun, 14 Oct 2007 07:51:20 -0700

On Oct 14, 2007, at 5:18 AM, Julian Reschke wrote:

>
> Sam Ruby wrote:
>> I realize that there is no requirement to be consistent, but why  
>> the difference:
>> Given that the tools.ietf.org/html version contains a prominent  
>> link to the .txt version, I'd suggest it be used in both places.
>> - Sam Ruby
>
> Speaking of which, I have XML and "true" HTML (*) versions  
> available at <http://greenbytes.de/tech/webdav/#rfc5023>.

What's the upstream XML source for that?  Did you get the RFC editor  
corrections in? -Tim

---

From: Sam Ruby <[email-masked]>
Date: Sun, 14 Oct 2007 11:18:57 -0400

Tim Bray wrote:
>>> Given that the tools.ietf.org/html version contains a prominent link 
>>> to the .txt version, I'd suggest it be used in both places.
>>> - Sam Ruby
>>
>> Speaking of which, I have XML and "true" HTML (*) versions available 
>> at <http://greenbytes.de/tech/webdav/#rfc5023>.
> 

http://intertwingly.net/stories/2007/10/14/rfc5023.diff

Mostly page length and width differences.

this/This; Email/EMail

The greenbytes version also has a Copyright notice and an 
Acknowledgement that the IETF version does not.

- Sam Ruby

---

From: Julian Reschke <[email-masked]>
Date: Sun, 14 Oct 2007 17:55:39 +0200

> What's the upstream XML source for that?  Did you get the RFC editor 

Of course. It's draft 17 plus the AUTH48 changes.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Sun, 14 Oct 2007 18:00:56 +0200

> Acknowledgement that the IETF version does not.

Well, it's not the "greenbytes" version, but the thing you are producing 
from XML using xml2rfc. Right now, xml2rfc can't *exactly* produce what 
the RFC Editor publishes -- I agree that this isn't satisfying; it would 
be really great if the RFC Editor once and for all could tell the 
xml2rfc maintainers what *exactly* it should produce.

Best regards, Julian

---

From: Sam Ruby <[email-masked]>
Date: Sun, 14 Oct 2007 12:22:40 -0400

> xml2rfc maintainers what *exactly* it should produce.

Perhaps this will be clearer then.

Example of a non-page dimension differences between the .txt version 
posted on the greenbytes site and the .txt version posted on the ietf site:

-Copyright Notice
-
-   Copyright (C) The IETF Trust (2007).
-

-Status of this Memo
+Status of This Memo

-   Email: [email-masked]
+   EMail: [email-masked]

-   Email: [email-masked]
+   EMail: [email-masked]

-Acknowledgment

-   Funding for the RFC Editor function is provided by the IETF
-   Administrative Support Activity (IASA).

I don't know the root cause of these differences, nor do I know whether 
or not they indicate that there might be other, more substantive, 
differences that I missed.

- Sam Ruby

---

From: Julian Reschke <[email-masked]>
Date: Sun, 14 Oct 2007 18:57:36 +0200

Sam Ruby wrote:
> ...
 > ...

The boilerplate isn't part of the XML source, it's generated by xml2rfc.

Which means that everytime the RFC Editor decides to make a minor 
change, xml2rfc will have to be updated. It doesn't help that these 
changes usually aren't announced, nor used consistently.

That being said, you may get of some more differences by including the

	<?rfc rfcedstyle="yes"?>

processing instruction.

Best regards, Julian