Subject: Atom Bidi Attribute Draft

From: James M Snell <[email-masked]>
Date: Fri, 19 Oct 2007 11:21:58 -0700

I've updated the Atom bidi draft (mainly to address a few editorial
issues and bump the expiration date up).  I'm not in any particular
hurry to get this one done, but feedback is always helpful and useful.
FWIW, I've implemented this in Abdera, along with a number of direction
guessing algorithms based on xml:lang, text properties, etc.

- James

---

From: "Franklin Tse" <[email-masked]>
Date: Sat, 20 Oct 2007 10:47:37 +0800

Hi James,

The draft contains a normative reference to the 1999 edition of the 
"Namespaces in XML" W3C Recommendation. I think it should be updated to the 
2006 edition, as used in RFC 5023:

   [REC-xml-names]
              Hollander, D., Bray, T., Tobin, R., and A. Layman,
              "Namespaces in XML 1.0 (Second Edition)", World Wide Web
              Consortium Recommendation REC-xml-names-20060816, August
              2006, <http://www.w3.org/TR/2006/REC-xml-names-20060816>.

Regards,
Franklin

--------------------------------------------------
From: "James M Snell" <[email-masked]>
Date: Saturday, 20 October, 2007 02:21
To: "atom-syntax" <[email-masked]>; "atom-protocol" 
<[email-masked]>
Subject: Atom Bidi Attribute Draft

---

From: James M Snell <[email-masked]>
Date: Fri, 19 Oct 2007 20:15:30 -0700

Thank you. Will be fixed in the next version.

Franklin Tse wrote:
> "Namespaces in XML" W3C Recommendation. I think it should be updated to
> the 2006 edition, as used in RFC 5023:
> 
>   [REC-xml-names]

---

From: "Franklin Tse" <[email-masked]>
Date: Sat, 20 Oct 2007 18:44:33 +0800

Besides, I have two question about a new requirement added in the the latest 
draft...

In Draft 05, the current draft:

   Values other than "ltr", "rtl" and "" MUST be ignored and processed
   as if the dir attribute was not present; Atom processors MUST NOT
   stop processing or signal an error.  The value of the attribute is
   not case-sensitive. Leading or trailing whitespace MUST be ignored.

In Draft 04, the previous draft:

   Values other than "ltr", "rtl" and "" MUST be ignored and processed
   as if the dir attribute was not present; Atom processors MUST NOT
   stop processing or signal an error.

Is it necessary for the draft to mention "Leading or trailing whitespace 
MUST be ignored."? That should have done by the XML processors, according to 
the XML Specification: http://www.w3.org/TR/xml/#AVNormalize

Is it good to allow the value to be case-insensitive? In XHTML, the value is 
matched case-sensitively. It is also rare to allow attribute values to be 
case-insensitive - the "type" attribute of Atom text constructs and the 
"rel" attribute of atom:link are both case-sensitive.

-Franklin

---

From: "Anne van Kesteren" <[email-masked]>
Date: Sat, 20 Oct 2007 13:39:12 +0200

On Sat, 20 Oct 2007 12:44:33 +0200, Franklin Tse  
<[email-masked]> wrote:
> Is it good to allow the value to be case-insensitive? In XHTML, the  
> value is matched case-sensitively.

This is not true for (at least) XHTML5, and implementations of XHTML in  
Opera and Firefox. Demo used:

   data:text/xml,<html xmlns='http://www.w3.org/1999/xhtml'  
dir='RTL'>test</html>

-- 
Anne van Kesteren
<http://annevankesteren.nl/>
<http://www.opera.com/>

---

From: "Franklin Tse" <[email-masked]>
Date: Sat, 20 Oct 2007 19:53:06 +0800

http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fpeaceable_whale.sinacampus.com%2FBidi%2Fbidi-uppercase.xhtml

value of attribute "dir" cannot be "LTR"; must be one of "ltr", "rtl".

If the specification says that the value is case-insensitive, then all 
implementations have to do a case insensitive match. If not, implementations 
can choose if they support the case insensitive values of "ltr" and "rtl", 
while the specification allows "ltr" and "rtl" only.

-Franklin

--------------------------------------------------
From: "Anne van Kesteren" <[email-masked]>
Date: Saturday, 20 October, 2007 19:39
To: "Franklin Tse" <[email-masked]>; "James M Snell" 
<[email-masked]>
Cc: "atom-syntax" <[email-masked]>; "atom-protocol" 
<[email-masked]>
Subject: Re: Atom Bidi Attribute Draft

---

From: "Franklin Tse" <[email-masked]>
Date: Sat, 20 Oct 2007 20:06:38 +0800

For interoperability, "ltr" and "rtl" in all lowercase should be the best.

The specification should not say that implementations are allowed to differ, 
but it cannot control the real situation. Programmers still can decide how 
their programs handle the values, even though the spec. said "MUST NOT".

-Franklin

--------------------------------------------------
From: "Anne van Kesteren" <[email-masked]>
Date: Saturday, 20 October, 2007 19:58
To: "Franklin Tse" <[email-masked]>
Cc: "atom-syntax" <[email-masked]>; "atom-protocol" 
<[email-masked]>
Subject: Re: Atom Bidi Attribute Draft

> On Sat, 20 Oct 2007 13:53:06 +0200, Franklin Tse 
> I didn't claim anything about XHTML 1.x.
>
>
>> implementations have to do a case insensitive match. If not, 
>> implementations can choose if they support the case insensitive values 
>> of "ltr" and "rtl", while the specification allows "ltr" and "rtl" only.
>
> It doesn't help interoperability if implementation are allowed to differ.
>
>
> -- 
> Anne van Kesteren

---

From: "Anne van Kesteren" <[email-masked]>
Date: Sat, 20 Oct 2007 13:58:19 +0200

---

From: Joe Cheng <[email-masked]>
Date: Mon, 22 Oct 2007 16:50:01 -0700

You mean, they can decide whether to be interoperable or to be spec
compliant? Please don't put us poor implementers in that position.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Franklin Tse
Sent: Saturday, October 20, 2007 5:07 AM
To: Anne van Kesteren
Cc: atom-syntax; atom-protocol
Subject: Re: Atom Bidi Attribute Draft

-Franklin

---

From: "Franklin Tse" <[email-masked]>
Date: Tue, 23 Oct 2007 08:29:34 +0800

No.

If both publishers and implementers use and support "ltr" and "rtl" in 
lowercases only, where is the problem of interoperability?

If the spec. allows the use of "ltr", "rtl" and "" only, simply supporting 
this three values is already spec. compliant. If a publisher used "rTl" or 
"RTL", these values are invalid and not supported.

Also, other attributes on an Atom document are case-sensitive: 
http://feeds.feedburner.com/franklin/atom-attributes

So, why must "ltr" and "rtl" be matched case-insensitively?

Regards,
Franklin

--------------------------------------------------
From: "Joe Cheng" <[email-masked]>
Date: Tuesday, 23 October, 2007 07:50
To: "Franklin Tse" <[email-masked]>; "Anne van Kesteren" 
<[email-masked]>
Cc: "atom-syntax" <[email-masked]>; "atom-protocol" 
<[email-masked]>
Subject: RE: Atom Bidi Attribute Draft