Subject: Re: Feed Paging for Efficient Feed Synchronization

From: Bill de hOra <[email-masked]>
Date: Tue, 01 Jan 2008 14:42:33 +0000

Brian Smith wrote:
> James M Snell wrote:
>> Excellent points.  The primary issue for me is the fact that 
>> the set of entries we're synchronizing has to remain stable 
>> throughout the synchronization process or else we risk race 
>> conditions and a variety of  possible conflicts.  If the 
>> stability of the pages can be reasonably guaranteed then 
>> paging is acceptable.
> 
> I'm pretty sure I agree with you, but please define "stable".

Look at how twitter implements paging (it's not using atom, but the 
concept stands). The content on page=2 of your twitter changes as a 
function of new posts on the home page, although the entries themselves 
are uniquely identified. That's not stable.

cheers
Bill

---

From: "Brian Smith" <[email-masked]>
Date: Sun, 6 Jan 2008 14:57:01 -0800

Bill de hOra wrote:
> Look at how twitter implements paging (it's not using atom, 
> but the concept stands). The content on page=2 of your 
> twitter changes as a function of new posts on the home page, 
> although the entries themselves are uniquely identified. 
> That's not stable.

Let's say I have this at time T:
  Page: (prev)
	Entry A
	Entry B
  Page: (current)
	Entry C
	Entry D
  Page: (next)
	Entry E
	Entry F

I page through the feed and I am on the second page. Entry E gets updated before I nagivate to the next page page:

  Page:
	Entry E
  Page: (prev)
	Entry A
	Entry B
  Page: (current)
	Entry C
	Entry D
  Page: (next)
	Entry F	

Is this still "stable"? Or does stability require snapshot semantics, like this?:

  Page:
	Entry E (new version)
  Page: (prev)
      Entry A
	Entry B
  Page: (current)
      Entry C
	Entry D
  Page: (next)
      Entry E (old version)
      Entry F

- Brian

---

From: John Panzer <[email-masked]>
Date: Sun, 06 Jan 2008 13:37:22 -0800

> Is this still "stable"? Or does stability require snapshot semantics, like this?:
Call the two concepts page-stability and snapshot-stability 
(snapshot-stability implies page-stability).  Page-stability is a useful 
concept in itself and doesn't require the overhead of snapshot 
semantics.  I'm most interested in page-stability personally for things 
like synchronization.

---

From: Bill de hOra <[email-masked]>
Date: Mon, 07 Jan 2008 00:31:48 +0000

> Is this still "stable"? Or does stability require snapshot semantics, like this?:

That's CAP. Pick two.

cheers
Bill