Subject: Google Reader and Namespace Prefixes

From: Stéphane Bortzmeyer <[email-masked]>
Date: Wed, 6 Feb 2008 12:06:14 +0100

[A bit off-topic, I know, but it seems related with the recent thread
on "Status of the <xhtml:div> wrapper".]

My blog's Atom feed (http://www.bortzmeyer.org/feed-full.atom, made by
a custom program) is awful when seen with Google Reader (for instance
http://www.google.com/reader/m/view/feed/http://www.bortzmeyer.org/feed-full.atom?i=-628233248182762503&c=CKe0oJaD_ZAC&n=1)

My feeling is that Google is wrong: the feed validates (both locally,
with rnv and with http://feedvalidator.org).

Also, other feed readers have no problem, for instance the Liferea
aggregator (running on Linux) or
http://xmlfr.org/actualites/planete/xmlfr/fr/.

One of the warnings sent by feedvalidator is:

http://feedvalidator.org/docs/warning/AvoidNamespacePrefix.html

I do use namespace prefixes. Can anyone confirm / infirm that Google
Reader has problems with them?

---

From: Karl Dubost <[email-masked]>
Date: Wed, 6 Feb 2008 23:26:44 +0900

> Reader has problems with them?

www.詹姆斯.com/blog/2007/11/atom-namespace-problems
known issue, it seems

--
Karl Dubost - W3C
http://www.w3.org/QA/
Be Strict To Be Cool

---

From: Karl Dubost <[email-masked]>
Date: Wed, 6 Feb 2008 23:24:14 +0900

salut stéphane,

> with rnv and with http://feedvalidator.org).

not quite :) but I'm not sure it is the source of the issue.
http://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Fwww.bortzmeyer.org%2Ffeed-full.atom

--
Karl Dubost - W3C
http://www.w3.org/QA/
Be Strict To Be Cool

---

From: Daniel Aleksandersen <[email-masked]>
Date: Wed, 6 Feb 2008 15:59:46 +0100

> www.詹姆斯.com/blog/2007/11/atom-namespace-problems

That is http://www.xn--8ws00zhy3a.com/blog/2007/11/atom-namespace-problems 
to the rest of the world. ☺
-- 
Daniel Aleksandersen <[email-masked]>

---

From: Stéphane Bortzmeyer <[email-masked]>
Date: Wed, 6 Feb 2008 16:02:47 +0100

On Wed, Feb 06, 2008 at 11:26:44PM +0900,
 Karl Dubost <[email-masked]> wrote 
 a message of 19 lines which said:

> www.?????????.com/blog/2007/11/atom-namespace-problems
> known issue, it seems

This page reminds there is a problem but Google is not mentioned.

---

From: Stéphane Bortzmeyer <[email-masked]>
Date: Wed, 6 Feb 2008 16:01:26 +0100

On Wed, Feb 06, 2008 at 11:24:14PM +0900,
 Karl Dubost <[email-masked]> wrote 
 a message of 19 lines which said:

> not quite :)

It *is* valid, there are just a few known warnings (warnings, not
errors).

> Be Strict To Be Cool

I will :-)

---

From: Karl Dubost <[email-masked]>
Date: Thu, 7 Feb 2008 00:22:58 +0900

> This page reminds there is a problem but Google is not mentioned.

	"More of an issue was the xhtml prefix,
	which caused problems for nearly two thirds
	of the aggregators tested. 3"

following the "3"

	"3 Including Google Reader, NewsGator Online,
	FeedDemon, Thunderbird 1.5.0.13, and RSS
	Bandit 1.5.0.17."

;)
--
Karl Dubost - W3C
http://www.w3.org/QA/
Be Strict To Be Cool

---

From: Julian Reschke <[email-masked]>
Date: Thu, 07 Feb 2008 15:36:44 +0100

>     FeedDemon, Thunderbird 1.5.0.13, and RSS

So do we know whether Google is aware of this problem?

Hmm. Joe, maybe you?

BR, Julian

---

From: Julian Reschke <[email-masked]>
Date: Wed, 20 Feb 2008 13:49:32 +0100

> So do we know whether Google is aware of this problem?

For the record: I reported the issue over at 
<http://groups.google.com/group/google-reader-troubleshoot/browse_thread/thread/b592d6496ed7607> 
ten days ago, and got no replies.

BR, Julian

---

From: John <[email-masked]>
Date: Wed, 20 Feb 2008 21:22:19 -0800

-John

On Feb 20, 2008, at 4:49 AM, Julian Reschke <[email-masked]>  
wrote:

> For the record: I reported the issue over at <http://groups.google.com/group/google-reader-troubleshoot/browse_thread/thread/b592d6496ed7607 
There's a reply now.

---

From: Julian Reschke <[email-masked]>
Date: Fri, 22 Feb 2008 13:22:23 +0100

John wrote:
> ...
 > ...

And, as of yesterday, they say it's understood and a fix is being worked on.

Maybe it's a bit premature to say this, but anyway...: do not accept 
namespace-broken software as a given, try to get fixes in.

BR, Julian