Subject: Re: URI Templates in Atom links

From: Jan Algermissen <[email-masked]>
Date: Tue, 02 Mar 2010 11:34:31 +0100

On Feb 26, 2010, at 4:23 PM, Joe Gregorio wrote:

> Using URI Templates will require either creating a custom namespaced
> element for your
> specific case, or creating a more general namespaced 'tlink' element
> that is just like
> 'link', but the value of href is expected to be a URI Template.

I have come across the '<tlink>-use case' almost every time I use Atom so IMO it is worth standardiziing it.

What would be the best way to do that (is there a better way than just writing up an I-D)?

(Given that there is a dependency on the URI template I-D should that one be finsihed first?)

Jan

-----------------------------------
 Jan Algermissen, Consultant
 NORD Software Consulting

 Mail: [email-masked]
 Blog: http://www.nordsc.com/blog/
 Work: http://www.nordsc.com/
-----------------------------------

---

From: Julian Reschke <[email-masked]>
Date: Tue, 02 Mar 2010 12:05:34 +0100

>> 'link', but the value of href is expected to be a URI Template.

+1

> I have come across the '<tlink>-use case' almost every time I use Atom so IMO it is worth standardiziing it.

Indeed.

> What would be the best way to do that (is there a better way than just writing up an I-D)?

I think writing an I-D is the best way.

> (Given that there is a dependency on the URI template I-D should that one be finsihed first?)

They could be developed in parallel; having a spec reference the 
template spec would be a good test for the usability of the template spec...

Best regards, Julian

---

From: Asbjørn Ulsberg <[email-masked]>
Date: Wed, 03 Mar 2010 10:11:25 +0100

> so IMO it is worth standardiziing it.

With my recent thread regarding an Atom Media Repository, I have no choice  
but to agree completely. :)

> What would be the best way to do that (is there a better way than just  

I'd say so, yea.

> (Given that there is a dependency on the URI template I-D should that  

That just means the tlink I-D needs to await the completion of the URI  
template I-D before it can reach its own completion status. I think that's  
rather common in the IETF community, actually. I don't see a problem with  
it, at least.

-- 
Asbjørn Ulsberg           -=|=-        [email-masked]
«He's a loathsome offensive brute, yet I can't look away»