Subject: to/cc/bcc extension

From: James Snell <[email-masked]>
Date: Fri, 15 Oct 2010 14:02:47 -0700

Wanted to draw attention to this:

  http://tools.ietf.org/html/draft-norris-atompub-audience-00.html

It introduces to/cc/bcc elements to an Atom entry.

  <entry>
    ...
    <to>acct:[email-masked] <[email-masked]></to>
    <to>acct:[email-masked] <[email-masked]></to>
    <cc>acct:[email-masked] <[email-masked]></cc>
    <cc>acct:[email-masked] <[email-masked]></cc>
    <bcc>acct:[email-masked] <[email-masked]></bcc>
    <bcc>acct:[email-masked] <[email-masked]></bcc>
    ...
  </entry>

Comments are welcomed and requested.

- James

---

From: "Ernest N. Prabhakar, Ph.D." <[email-masked]>
Date: Fri, 15 Oct 2010 15:41:16 -0700

HI James,

Given our previous discussion about icons: why aren't these link relations with mailto URLs?

-- Ernie P.

On Oct 15, 2010, at 2:02 PM, James Snell wrote:

>     <to>acct:[email-masked]</to>
>     <to>acct:[email-masked]</to>
>     <cc>acct:[email-masked]</cc>
>     <cc>acct:[email-masked]</cc>
>     <bcc>acct:[email-masked]</bcc>
>     <bcc>acct:[email-masked]</bcc>
>     ...
>   </entry>
>

---

From: Alexander Johannesen <[email-masked]>
Date: Sat, 16 Oct 2010 09:54:13 +1100

*grumble*

> Given our previous discussion about icons: why aren't these link relations

Not meant to fixate this on the follow-up'er, but everything you ever
wanted and extend Atom with is just conceptual things. There is no
difference between a defined ontology with all the entities and
relationships of Atom, and in fact you can define the whole shebang in
any ontological language. It just so happens that Atom is a short-list
of ontological expression defined in a format of sorts.

Where do the data model, format it's defined in and the ontology stop and start?

At some point the Atom model becomes so complex that it loses its easy
applicability, and perhaps should enter the realm of ontological work.
Anyone done any mappings of this so far?

Kind regards,

Alex
-- 
 Project Wrangler, SOA, Information Alchemist, UX, RESTafarian, Topic Maps
--- http://shelter.nu/blog/ ----------------------------------------------
------------------ http://www.google.com/profiles/alexander.johannesen ---

---

From: James Snell <[email-masked]>
Date: Fri, 15 Oct 2010 15:57:44 -0700

link certainly could be used but just doesn't seem like a good fit. Things
like type, length, hreflang, nor ANY of the proposed link extensions would
apply.

---

From: John Panzer <[email-masked]>
Date: Sat, 16 Oct 2010 14:53:23 -0700

I like  the concept and this may be a reasonable implementation.  
There's related work done on this for OStatus and Salmon which might be 
worth looking at.

My big question though is what the semantics of this are supposed to be; 
the names are suggestive of email, clearly intentionally, but the spec 
doesn't state this.  Are there suggested semantics?  Or is intended to 
inherit semantics from email (which inherited from business snail mail...)?

(Also, bcc is untenable for use with signed content.)

On 10/15/2010 2:02 PM, James Snell wrote:
> <to>acct:[email-masked] <mailto:[email-masked]></to>
> <to>acct:[email-masked] <mailto:[email-masked]></to>
> <cc>acct:[email-masked] <mailto:[email-masked]></cc>
> <cc>acct:[email-masked] <mailto:[email-masked]></cc>
> <bcc>acct:[email-masked] 
> <mailto:[email-masked]></bcc>
> <bcc>acct:[email-masked] <mailto:[email-masked]></bcc>
>     ...
> </entry>
>

---

From: Bob Wyman <[email-masked]>
Date: Sat, 16 Oct 2010 18:21:10 -0400

To, cc, and bcc are said to include the atomCommonAttributes which are base,
lang and undefined... I'm not sure I understand how either base or lang
really make sense for these elements. If they do make sense, could you
provide some examples that motivated their being included?

bob wyman

---

From: Sam Johnston <[email-masked]>
Date: Sat, 16 Oct 2010 20:35:22 -0400

On Sat, Oct 16, 2010 at 5:53 PM, John Panzer <[email-masked]> wrote:

>  I like  the concept and this may be a reasonable implementation.  There's
> related work done on this for OStatus and Salmon which might be worth
> looking at.
>

I'd be inclined to include a scheme - eg mailto: - in which case the <link>
element makes the most sense to me even if hreflang et al don't apply. Could
also have a generic "recipient" relationship with an extensible type (to,
cc, bcc).

The bar to extend the basic Atom metamodel should be very high - if anything
we should be looking at *removing* things like author (e.g. making them
optional) as they often don't make sense in today's applications (eg GData).

Sam

---

From: Aristotle Pagaltzis <[email-masked]>
Date: Mon, 25 Oct 2010 21:52:22 +0200

> Comments are welcomed and requested.

First: your example XML is broken. (Unescaped angle brackets in
content.)

Next: microparsing, and of text content no less (as opposed to
attribute values)? How hideous.

I will suggest something like

    <audience rel="to"
        address="acct:[email-masked]"
        label="acct:[email-masked]" />

The label should be optional of course.

Now you have something tractable to XML tools, eg. you can write
reasonable XPath queries across these elements.

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>

---

From: James Snell <[email-masked]>
Date: Mon, 25 Oct 2010 13:05:02 -0700

Aristotle, the email application messed up the markup... it's supposed to be
just...

  <to> acct: john.doe @ example.org </to>

(I added some spaces to try to keep the example from being messed up again)

- James

On Mon, Oct 25, 2010 at 12:52 PM, Aristotle Pagaltzis <[email-masked]>wrote:

> >     <to>acct:[email-masked] <[email-masked]> <
> [email-masked] <[email-masked]>></to>
> >     <to>acct:[email-masked] <[email-masked]> <
> [email-masked] <[email-masked]>></to>
> >     <cc>acct:[email-masked] <[email-masked]> <
> [email-masked] <[email-masked]>></cc>
> >     <cc>acct:[email-masked] <[email-masked]> <
> [email-masked] <[email-masked]>></cc>
> >     <bcc>acct:[email-masked] <[email-masked]> <
> [email-masked] <[email-masked]>></bcc>
> >     <bcc>acct:[email-masked] <[email-masked]> <
> [email-masked] <[email-masked]>></bcc>
> >     ...
> >   </entry>
> >
>        address="acct:[email-masked] <[email-masked]>"
>        label="acct:[email-masked] <[email-masked]>" />
>