Subject: [Autoconf] Fwd: New Version Notification for draft-baccelli-multi-hop-wireless-communication-04

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 24 May 2010 15:42:23 -0700

Hello folks,

We have submitted a revised version of the draft
with some significant corrections.  Here is a URL
for the revision:
	http://www.ietf.org/internet-drafts/draft-baccelli-multi-hop-wireless-communication-04.txt

Would there be interest in the working group to
accept this as a working group document?

Regards,
Charlie P.

-------- Original Message --------
Subject: New Version Notification for 
draft-baccelli-multi-hop-wireless-communication-04
Date: Mon, 24 May 2010 17:38:38 -0500
From: IETF I-D Submission Tool <[email-masked]>
To: Perkins, Charles <[email-masked]>
CC: <[email-masked]>

A new version of I-D, 
draft-baccelli-multi-hop-wireless-communication-04.txt has been 
successfully submitted by Charles Perkins and posted to the IETF repository.

Filename:	 draft-baccelli-multi-hop-wireless-communication
Revision:	 04
Title:		 Multi-hop Ad Hoc Wireless Communication
Creation_date:	 2010-05-24
WG ID:		 Independent Submission
Number_of_pages: 9

Abstract:
This document describes some important characteristics of
communication between nodes in a multi-hop ad hoc wireless network.
These are not requirements in the sense usually understood as
applying to formulation of a requirements document.  Nevertheless,
protocol engineers and system analysts involved with designing
solutions for ad hoc networks must maintain awareness of these
characteristics.

The IETF Secretariat.

---

From: Ryuji Wakikawa <[email-masked]>
Date: Mon, 24 May 2010 16:47:22 -0700

Thanks, Charlie for the updates.

Apologize chair's delay for updating the charter and sharing it.
We will share the new draft charter and move the discussion forward.

regards,
ryuji

On 2010/05/24, at 15:42, Charles E. Perkins wrote:

> Subject: New Version Notification for draft-baccelli-multi-hop-wireless-communication-04
> A new version of I-D, draft-baccelli-multi-hop-wireless-communication-04.txt has been successfully submitted by Charles Perkins and posted to the IETF repository.
> 
> _______________________________________________
> Autoconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/autoconf

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Tue, 25 May 2010 20:09:10 +0200

Hi Charlie,

I support this kind of document. I think it's useful. I still have to do
my homework and read it carefully to provide feedback.

Thanks,

Carlos

-- 
Carlos Jesús Bernardos Cano     http://www.netcoms.net
GPG FP: D29B 0A6A 639A A561 93CA  4D55 35DC BA4D D170 4F67

---

From: Teco Boot <[email-masked]>
Date: Wed, 26 May 2010 14:27:11 +0200

I support this document being published as RFC.
Could be done as WG document, no problems with alternative way.
Regards, Teco

---

From: "Ramrekha, Arvind" <[email-masked]>
Date: Wed, 26 May 2010 13:42:12 +0100

I would also support accepting this as a working group document.

Kind regards

Arvind.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Teco Boot
Sent: 26 May 2010 13:27
To: Charles E.Perkins
Cc: [email-masked]
Subject: Re: [Autoconf] Fwd: New Version Notification for draft-baccelli-multi-hop-wireless-communication-04

This email has been scanned for all viruses by the MessageLabs Email
Security System.

This email has been scanned for all viruses by the MessageLabs Email
Security System.

---

From: Paul Lambert <[email-masked]>
Date: Wed, 26 May 2010 10:34:10 -0700

I find this document misleading and confusing in that it does not mention the use of link layer acknowledgments.  It assumes one particular link layer service type and does not indicate that it is only referring to unacknowledged transmission.

Radio links that require ACKs are symmetric. 

Paul

> Sent: Wednesday, May 26, 2010 5:27 AM
> To: Charles E.Perkins
> Cc: [email-masked]
> > A new version of I-D, draft-baccelli-multi-hop-wireless-communication-
> 04.txt has been successfully submitted by Charles Perkins and posted to
> the IETF repository.
> >

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 26 May 2010 10:51:33 -0700

Hello Paul

On 5/26/2010 10:34 AM, Paul Lambert wrote:

> I find this document misleading and confusing in that it does not
> mention the use of link layer acknowledgments.  It assumes one
> particular link layer service type and does not indicate that it
> is only referring to unacknowledged transmission.

I don't think this omission causes the entire
document to be misleading and/or confusing.
Plus, it is a problem easily solved.

Would you like to propose some text that would
(a) mention link-layer acknowledgements, and
(b) eliminate the confusion that you found?
I haven't checked with Emmanuel, but speaking
only for myself I'd be happy to support the update.

> Radio links that require ACKs are symmetric.

What about multicast?

Regards,
Charlie P.

---

From: Paul Lambert <[email-masked]>
Date: Wed, 26 May 2010 11:31:23 -0700

Yes - easily solved with a sentence or two somewhere ... the base terminology and models are useful.  It's just that most shorter distance wireless technologies (like 802.11) have acknowledgment based reliability. 
Wireless links are typically not open-loop, but have feedback with acks that provide reliability and indications of the link connectivity.  

> What about multicast?
There are now reliable multicast mechanisms (802.11aa).  These are not common (yet), but would have the same considerations and would always be symmetric.  

Perhaps a sentence or two that mentions acknowledged versus unacknowledged link layers - and that the asymmetric behavior described is for unacknowledged link layer frames. 

Hope this helps ...

Paul

PS - sorry for the not very timely comment ... I lurk on this list infrequently

> From: Charles E. Perkins [mailto:[email-masked]]
> Sent: Wednesday, May 26, 2010 10:52 AM
> To: Paul Lambert
> Cc: Teco Boot; [email-masked]
> Subject: Re: [Autoconf] Fwd: New Version Notification fordraft-baccelli-
> multi-hop-wireless-communication-04
> 
> 
> Hello Paul
>