Subject: RTP (encapsulating H263) framing mechanism?

From: "Mohamed K CHERIF" <[email-masked]>
Date: Wed, 17 May 2000 10:20:32 -0700

Hi All,
I need to depacketize RTP packets which encapsulate H263 streams. I was =
thinking that there should be a packet length field in the RTP header, =
but there was not. If an RTP stream is provided, is there a way to tell =
where does the second RTP packet starts?
Thank you so much.
Mohamed

---

From: "Adam Li" <[email-masked]>
Date: Wed, 17 May 2000 18:24:22 -0700

RTP is for packet-switch network. That means you get them in individual
packets, not a continues bitstream as in circuit-switched case.

Hope it helps.

Adam

PS:

In RFC 1889 :
    o The length of the packet must be consistent with CC and
         payload type (if payloads have a known length).

H.263 payloads don't have a fixed length.

----------
Adam H. Li
Image Communication Lab                          (310) 825-5178 (Lab)
University of California, Los Angeles            (310) 825-7928 (Fax)

  -----Original Message-----
  From: Mohamed K CHERIF [mailto:[email-masked]]
  Sent: Wednesday, May 17, 2000 10:21 AM
  To: [email-masked]
  Subject: RTP (encapsulating H263) framing mechanism?

  Hi All,