Subject: [AVT] Comment re. possible change to jitter calculation

From: Ross Finlayson <[email-masked]>
Date: Wed, 08 Aug 2001 03:58:42 -0700

[Re. the discussion in today's AVT meeting.]

If we end up modifying the rule for how receivers calculate jitter (in 
response to Amos Guler's observation about variable-duration RTP packets), 
then we also need to explain what to do about the case where a single 
'frame' is fragmented over multiple RTP packets - something that is 
possible in several payload formats.  Presumably in this case the 'sending 
time' (as used in the jitter calculation) will be the the packet RTP 
timestamp (of the first fragment packet), plus the *total duration* of all 
the fragment packets.  (In all RTP payload formats that I'm aware of that 
support fragmentation, the RTP timestamp of the first fragment packet 
represents the start of the frame, and the RTP timestamps of the following 
fragments are the same as that of the first.)

(I'm assuming here that when a frame is fragmented over multiple RTP 
packets, that none of the fragments get transmitted until the entire frame 
data is ready.)

We also need to make it clear that when fragmentation like this occurs, 
that the jitter calculation is performed only once - for the entire 
'frame', not for each individual RTP packet.

If, on the other hand, we decide *not* to modify the current rule for how 
receivers calculate jitter, then we should add a few words to the RTP spec 
acknowledging the issue that Amos Guler raised, while also explaining why 
we choose not to do anything about it.

         Ross (@4am in California - time to go to bed...)

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www1.ietf.org/mailman/listinfo/avt

---

From: [email-masked]
Date: Wed, 8 Aug 2001 13:41:01 -0500

Seems to me like variable payload duration is (should be) a valid
contributor to jitter, and so the calculation should be left alone.

Otherwise, you couldn't use the jitter measurement to size your jitter
buffer in the presence of variable payload duration.  i.e. on the perfect
network there is zero jitter, so a buffer is set to zero delay, yet the
packets arrive jittered because of the variable payload durations.
Stronger: an adjacent 10ms and 30ms packet pair should be played adjacently
at a 10ms, not 30ms, separation.  So there should've been some delay (20ms
exactly) in the buffer to do this.  No?

Vince Virgilio

                    Ross                                                                                                  
                    Finlayson            To:     [email-masked]                                                             
                    <finlayson@li        cc:                                                                              
                    ve.com>              Subject:     [AVT] Comment re. possible change to jitter calculation             
                    Sent by:                                                                                              
                    avt-admin@iet                                                                                         
                    f.org                                                                                                 

                    08/08/2001                                                                                            
                    05:58 AM

---

From: [email-masked]
Date: Fri, 24 Aug 2001 14:43:14 -0500

Vince Virgilio

                    Ross
                    Finlayson            To:     [email-masked]
                    <finlayson@li        cc:
                    ve.com>              Subject:     [AVT] Comment re.
possible change to jitter calculation
                    Sent by:
                    avt-admin@iet
                    f.org

                    08/08/2001
                    05:58 AM