Subject: [AVT] Re: Question about "PayloadSize" field in MPEG-4 RTP payload format

From: [email-masked]
Date: Wed, 22 Aug 2001 14:50:49 +0200

it is not a singleSL *MODE* issue,

the absolute rule is that the presence of PayloadSize
(SizeLength != 0) is a total equivalence
(mathematical symbol <=> ;-)
with multipleSL mode

i.e.
Single SL mode == NO PayloadSize field (never)
Multiple SL mode == PayloadSize field (always)

HOWEVER

it may happen that in the multipleSL mode
you have an Access Unit so large that
it is actually larger than the MTU,
then you will split this large AU in
several SL packet and therefore
transport each of these SL packets
in one RTP packet.

***********
so this is a "single SL packet" but the MODE
REMAINS multipleSL (the mode cannot change
inside a session anyway)
***********

in that case since the mode is multiple
you HAVE the PayloadSize field.

It would be stupid to waste this field by putting
in this field the (single) SL packet size
since UDP already gives you that !

moreover it is very helpfull to give (repeat)
the *complete AU size* in this PayloadSIze field.
it helps a receuver finding out if
a complete AU has arrived or not in
case of packet losses .

*******
NOTE:

Actually in case this "single" SL packet
in the RTP packet is actually a
complete Access Unit the
packet structure is
exactly the same as previoulsly !

NOTE (2)

of course if you have such a stream
(1 AU >= 1 RTP packet)
you have NOW a choice:

(1) use the SingleSL (default) mode because
it saves SizeLength bits per packet !

(2) use the MultipleSL mode because
it makes AU reconstrcution easier !

but for best efficiency
of AU reconstruction strategy
I would recommend the usage
of AUstartFalg and AUendFlag:
only 2 bits per packet ...
you have to be a Synch Layer
fan to do that though ;-)

*****
in conclusion it is not a mode issue
it is a "smart" exception for
single SL transport in the MultilpleSL mode

is that more clear ?

Regards,

Philippe Gentric
Software architect
Philips Digital Networks - MP4Net
51 rue Carnot B.P. 301
92156 Suresnes FRANCE
tel: +33(0)147283740
fax: +33(0)147283725
[email-masked]
http://www.mpeg-4.philips.com

"Lim, Young-Kwon" <[email-masked]> on 21-08-2001 16:23:08

Please respond to "Lim, Young-Kwon" <[email-masked]>

To:     Philippe Gentric/LIM/CE/PHILIPS@EMEA1
cc:     <[email-masked]>
Subject:  Question about "PayloadSize" field
Classification:

Dear Phillipe and all,

In the latest draft, "PayloadSize" field is defined to contain the entire size of AU in single SL case. But the parameter "SizeLength" will set to zero in default and it indicates the single SL case. This means that the length of "PayloadSize" field will
be zero in single SL case and conflict with the definition of "PayoadSize" field. Did I missed something in between?

Sincerely,
Young.

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www1.ietf.org/mailman/listinfo/avt

---

From: "Lim, Young-Kwon" <[email-masked]>
Date: Wed, 22 Aug 2001 23:01:00 +0900

Dear Phillipe and all,

I see. But the description is not clear enough. Would you revise the definition of PayloadSize, especially the second paragraph, with the text in your e-mail for the clarification?

Sincerely,
Young