Subject: Re: [AVT] Re: Question about "PayloadSize" field in MPEG-4 RTP payload format

From: [email-masked]
Date: Wed, 22 Aug 2001 18:35:09 +0200

I propose to change (3.4.1 Fields of MSLH ):
into
****************************************

3.4.1 Fields of MSLH

   PayloadSize: Indicates the size in bytes of the associated SL Packet
   Payload, which can be found in the SLPPSection of the RTP packet.
   The length in bits of this field is signaled by the SizeLength
   parameter (see section 4.1).

   There is an exception to that. When the RTP packet contains a single  SL packet
(although the mode is "MultipleSL" this can happen for Access Units of size
comparable or greater than the MTU) the PayloadSize field SHALL contain the size of the entire
   corresponding Access Unit. There are two reasons, firstly the size of the
   fragment is not needed when there is only one fragment, secondly
   this is useful in order to detect that a full Access Unit has been
   received after the loss of a packet carrying M bit set to 1.

*******************************************

Is this wording better ?

Regards,

Philippe Gentric
Software architect
Philips Digital Networks - MP4Net
51 rue Carnot B.P. 301
92156 Suresnes FRANCE
tel: +33(0)147283740
fax: +33(0)147283725
[email-masked]
http://www.mpeg-4.philips.com

"Lim, Young-Kwon" <[email-masked]>@ietf.org on 22-08-2001 16:01:00

Please respond to "Lim, Young-Kwon" <[email-masked]>

Sent by:  [email-masked]

To:     Philippe Gentric/LIM/CE/PHILIPS@EMEA1
cc:     <[email-masked]>
        <[email-masked]>
Subject:  [AVT] Re: Question about "PayloadSize" field in MPEG-4 RTP payload format
Classification:

Dear Phillipe and all,

I see. But the description is not clear enough. Would you revise the definition of PayloadSize, especially the second paragraph, with the text in your e-mail for the clarification?

Sincerely,
Young
----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Wednesday, August 22, 2001 9:50 PM
Subject: Re: Question about "PayloadSize" field in MPEG-4 RTP payload format

>
>
>
> it is not a singleSL *MODE* issue,
>
> the absolute rule is that the presence of PayloadSize
> (SizeLength != 0) is a total equivalence
> (mathematical symbol <=> ;-)
> with multipleSL mode
>
> i.e.
> Single SL mode == NO PayloadSize field (never)
> Multiple SL mode == PayloadSize field (always)
>
> HOWEVER
>
> it may happen that in the multipleSL mode
> you have an Access Unit so large that
> it is actually larger than the MTU,
> then you will split this large AU in
> several SL packet and therefore
> transport each of these SL packets
> in one RTP packet.
>
> ***********
> so this is a "single SL packet" but the MODE
> REMAINS multipleSL (the mode cannot change
> inside a session anyway)
> ***********
>
> in that case since the mode is multiple
> you HAVE the PayloadSize field.
>
> It would be stupid to waste this field by putting
> in this field the (single) SL packet size
> since UDP already gives you that !
>
> moreover it is very helpfull to give (repeat)
> the *complete AU size* in this PayloadSIze field.
> it helps a receuver finding out if
> a complete AU has arrived or not in
> case of packet losses .
>
> *******
> NOTE:
>
> Actually in case this "single" SL packet
> in the RTP packet is actually a
> complete Access Unit the
> packet structure is
> exactly the same as previoulsly !
>
> NOTE (2)
>
> of course if you have such a stream
> (1 AU >= 1 RTP packet)
> you have NOW a choice:
>
> (1) use the SingleSL (default) mode because
> it saves SizeLength bits per packet !
>
> (2) use the MultipleSL mode because
> it makes AU reconstrcution easier !
>
> but for best efficiency
> of AU reconstruction strategy
> I would recommend the usage
> of AUstartFalg and AUendFlag:
> only 2 bits per packet ...
> you have to be a Synch Layer
> fan to do that though ;-)
>
>
> *****
> in conclusion it is not a mode issue
> it is a "smart" exception for
> single SL transport in the MultilpleSL mode
>
>
> is that more clear ?
>
> Regards,
>
> Philippe Gentric
> Software architect
> Philips Digital Networks - MP4Net
> 51 rue Carnot B.P. 301
> 92156 Suresnes FRANCE
> tel: +33(0)147283740
> fax: +33(0)147283725
> [email-masked]
> http://www.mpeg-4.philips.com
>
>
>
>
>
> "Lim, Young-Kwon" <[email-masked]> on 21-08-2001 16:23:08
>
> Please respond to "Lim, Young-Kwon" <[email-masked]>
>
> To:     Philippe Gentric/LIM/CE/PHILIPS@EMEA1
> cc:     <[email-masked]>
> Subject:  Question about "PayloadSize" field
> Classification:
>
>
> Dear Phillipe and all,
>
> In the latest draft, "PayloadSize" field is defined to contain the entire size of AU in single SL case. But the parameter "SizeLength" will set to zero in default and it indicates the single SL case. This means that the length of "PayloadSize" field
will
> be zero in single SL case and conflict with the definition of "PayoadSize" field. Did I missed something in between?
>
> Sincerely,
> Young.
>
>
>
>
>
>
>
>
>
>
>

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www1.ietf.org/mailman/listinfo/avt

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www1.ietf.org/mailman/listinfo/avt

---

From: "Lim, Young-Kwon" <[email-masked]>
Date: Thu, 23 Aug 2001 13:24:04 +0900

Dear Phillipe,

> I propose to change (3.4.1 Fields of MSLH ):

How about this?

There is an exception to that. In the case that the RTP packet containes only one SL packet in "Multiple SL mode", the PayloadSize field SHALL contain the size of the entire corresponding Access Unit. This would happen, when the size of AU is comparable or greather than MTU. There are two reasons, firstly the size of the fragment is not needed when there is only one fragment, secondly this is useful in order to detect that a full Access Unit has been  received after the loss of a packet carrying M bit set to 1.

Sincerely,
Young.